Kodi Community Forum
Release Amazon VOD [plugin.video.amazon[vod|-test]] - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Release Amazon VOD [plugin.video.amazon[vod|-test]] (/showthread.php?tid=349255)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-10-01

Yes, we have working branches with py3 Matrix and py2 Leia. You can find the direct link of the repository in the first post (Matrix, Kodi 19).


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - orion_134 - 2020-10-01

(2020-10-01, 13:56)orion_134 Wrote:
(2020-10-01, 13:14)orion_134 Wrote: I'm brand new to all of this. I have a Pi with latest certain OSMC. Everything looks like it works on again and I can see all of my content. I received no errors during install. However, when clicking any of my purchased movies, it shows the little "gonna play" details in the upper right corner as if it's going to do a thing, but then no thing is done. Not sure if this is just user error or worth a github issue report?

Thanks!

Apparently this is a widevine/inputstreamhelper issue as it's failing to load the drm file in the logs:/ I reinstalled to no avail.

I couldn't figure out hotter to parse from my huge log file, so this is the snippet of issues. When I check the ~.kodi/cdm folder the .so file is in there...is it a command execution issue?

2020-10-01 13:45:21.896 T:1350562528 ERROR: [script.module.inputstreamhelper] [u'ldd', u'/home/osmc/.kodi/cdm/libwidevinecdm.so'] cmd failed.
2020-10-01 13:45:21.897 T:1350562528 ERROR: [script.module.inputstreamhelper] Failed to check for missing Widevine libraries.
2020-10-01 13:45:21.897 T:1350562528 ERROR: EXCEPTION: Invalid setting type
2020-10-01 13:45:21.898 T:1350562528 NOTICE: [script.module.inputstreamhelper] Widevine update check was made on 2020-10-01 07:51
2020-10-01 13:45:21.904 T:1350562528 NOTICE: [Amazon VOD] postURL: http://127.0.0.1:44877/gpr/https%3A%2F%2Fatv-ps.amazon.com%2Fcdp%2Fcatalog%2FGetPlaybackResources%3Fasin%3DB07VLNBZJ3%26deviceTypeID%3DAOAGZA014O5RE%26firmware%3D1%26deviceID%3Dc315e430316584ee139843c69c3a05ef11dbfe724eddbc8e3c6982a8%26marketplaceID%3DATVPDKIKX0DER%26format%3Djson%26version%3D1%26gascEnabled%3Dfalse%26subtitleFormat%3DTTMLv2%26resourceUsage%3DImmediateConsumption%26consumptionType%3DStreaming%26deviceDrmOverride%3DCENC%26deviceStreamingTechnologyOverride%3DDASH%26deviceProtocolOverride%3DHttps%26deviceBitrateAdaptationsOverride%3DCVBR%252CCBR%26audioTrackId%3Dall%26languageFeature%3DMLFv2%26videoMaterialType%3DFeature%26desiredResources%3DPlaybackUrls%2CSubtitleUrls%2CForcedNarratives%2CTransitionTimecodes%26supportedDRMKeyScheme%3DDUAL_KEY
2020-10-01 13:45:23.705 T:1350562528 NOTICE: [Amazon VOD] Using Host: Cloudfront
2020-10-01 13:45:23.706 T:1350562528 NOTICE: [Amazon VOD] checkURL: https://pop-iad-2.cf.dash.row.aiv-cdn.net/dm/2$IkjfhNERj3nWREMU1p6Wes5UloY~/37de/844f/dcb4/4190-a012-09b2b83a1f8a/eb97a45c-07e0-4395-9a02-322f7fdc9633_corrected.mpd
2020-10-01 13:45:25.804 T:1350562528 NOTICE: [Amazon VOD] Using inputstream.adaptive Version: 2.4.5
2020-10-01 13:45:25.949 T:1915422256 NOTICE: VideoPlayer::OpenFile: plugin://plugin.video.amazon-test/?asin=B07VLNBZJ3&mode=PlayVideo&adult=0&name=Dora+And+The+Lost+City+Of+Gold&trailer=0&selbitrate=0
2020-10-01 13:45:25.950 T:1324147424 NOTICE: Creating InputStream
2020-10-01 13:45:31.404 T:1324147424 ERROR: AddOnLog: InputStream Adaptive: Unable to load widevine shared library (/home/osmc/.kodi/cdm/libwidevinecdm.so)
2020-10-01 13:45:31.408 T:1324147424 ERROR: AddOnLog: InputStream Adaptive: OpenDRMSystem failed
2020-10-01 13:45:31.410 T:1324147424 ERROR: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.amazon-test


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - strangeintp - 2020-10-05

New to Kodi... test driving it on LibreELEC (9.2.4) running liveUSB on an old (ca. 2012) x86-64.  So potentially I just don't know what I'm doing here...  I tried installing your add-on (8.8 matrix) but I get the following error:  "The dependency on xbmc.python version 3.0.0 could not be satisfied".

Not that the Netflix addon is yours, but I couldn't install that either because, couldn't "pip install"...  so far I'm not finding that LibreELEC "just works" as someone else in this thread was claiming.


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - DarrenHill - 2020-10-05

You're using a Kodi Matrix (with Python 3) version of the addon with Kodi Leia (with Python 2).

You either need a nightly version of LE or a version of the addon for Leia.


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - darnellt0 - 2020-10-09

Hi, 

I am currently using the matrix version which was working fine until recently I noticed some of the descriptions were in Spanish. So I tried to logout and back in to see if maybe I needed to reset my region and now I cannot log back in.

When I try to login and enter my credentials, it asks for them again this time with a captcha, and then I get an error message that states: "Unknown Error, please enable advanced debugging..."

I originally had the region on auto before it stopped working. If I change the region to US it won't login, but if I change the region to ROW North America then I can login successfully but it won't let me access anything.

Can someone help?


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - darnellt0 - 2020-10-09

(2020-10-09, 02:08)darnellt0 Wrote: Hi, 

I am currently using the matrix version which was working fine until recently I noticed some of the descriptions were in Spanish. So I tried to logout and back in to see if maybe I needed to reset my region and now I cannot log back in.

When I try to login and enter my credentials, it asks for them again this time with a captcha, and then I get an error message that states: "Unknown Error, please enable advanced debugging..."

I originally had the region on auto before it stopped working. If I change the region to US it won't login, but if I change the region to ROW North America then I can login successfully but it won't let me access anything.

Can someone help?

nm I found and downloaded 0.8.9_beta+matrix.1.zip and it's working


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Digimaster - 2020-10-09

Good news: the guys from Redfox, with their Anystream software, managed to access Amazon content in FHD, without cracking Widevine L1
So, a method to access these contents exists ...


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-10-14

@Digimaster that's cool but it's not really relevant. It downloads the MP4 streams and then when you play it in a standard media player which has HDCP support it plays back fine (unless they strip the HDCP requirement, I didn't check). The problem for us is that Kodi is not HDCP certified, otherwise we would have 1080p streams just fine. But that's definitely a valid option if you're into this sort of things.


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Digimaster - 2020-10-15

(2020-10-14, 18:59)Varstahl Wrote: @Digimaster that's cool but it's not really relevant. It downloads the MP4 streams and then when you play it in a standard media player which has HDCP support it plays back fine (unless they strip the HDCP requirement, I didn't check). The problem for us is that Kodi is not HDCP certified, otherwise we would have 1080p streams just fine. But that's definitely a valid option if you're into this sort of things.

Hi Varstahl, this is not the full story: in order to access and download these files (not protected), Anystream must have something special because it asks (and gets) HD quality and it's not HDCP certified... So, a "shortcut" to access to these HD contents must exist.
If something can be downloaded with these conditions, it can be streamed...


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-10-16

Well, coming from the guys that strip DRM from DVDs and Bluerays, I wouldn't expect for it to be on the up and up. While technically legal, I'm almost certain it's (ab)using a weakness in the Widevine key transmission to get the HDCP streams, and then deals with it separately. Nothing we can ship in our plugin.

Ofc I could be wrong, but that's what I would do if I was them.


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Digimaster - 2020-10-16

(2020-10-16, 00:42)Varstahl Wrote: Well, coming from the guys that strip DRM from DVDs and Bluerays, I wouldn't expect for it to be on the up and up. While technically legal, I'm almost certain it's (ab)using a weakness in the Widevine key transmission to get the HDCP streams, and then deals with it separately. Nothing we can ship in our plugin.
And so, unfortunately, we have to stay with SD playback in Windows in the days of 4K and more... Sad
It's so sad looking at the total control of playback ways by the usual few subjects and the progressive disappearance of all the others...


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - shaktoo - 2020-10-16

(2020-10-16, 06:22)Digimaster Wrote:
(2020-10-16, 00:42)Varstahl Wrote: Well, coming from the guys that strip DRM from DVDs and Bluerays, I wouldn't expect for it to be on the up and up. While technically legal, I'm almost certain it's (ab)using a weakness in the Widevine key transmission to get the HDCP streams, and then deals with it separately. Nothing we can ship in our plugin.
And so, unfortunately, we have to stay with SD playback in Windows in the days of 4K and more... Sad
It's so sad looking at the total control of playback ways by the usual few subjects and the progressive disappearance of all the others...
Totally agree that its a sorry & sad state of affairs.
If you are desperate you could setup the addon to use Broswer to get FHD playback... its not the best but ....


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Baohen1510 - 2020-10-17

Not working 
" You might be unable to access the service : check the website www.primevideo.com for more infomation"
Pls help me . 
Thanks


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-10-17

Try to log in www.primevideo.com to see if any error messages pop up. It only works with a valid Prime account, not a sub-account, and there are other restrictions which crop up from time to time. If you use the same credentials on www.primevideo.com, and it works, open an issue on GitHub and follow the instructions.

Edit: it might also be a change of Amazon's APIs, without logs and JSON data I can't tell you more.


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Baohen1510 - 2020-10-17

(2020-10-17, 11:49)Varstahl Wrote: Try to log in www.primevideo.com to see if any error messages pop up. It only works with a valid Prime account, not a sub-account, and there are other restrictions which crop up from time to time. If you use the same credentials on www.primevideo.com, and it works, open an issue on GitHub and follow the instructions.

Edit: it might also be a change of Amazon's APIs, without logs and JSON data I can't tell you more.

When log in www.primevideo.com , update location . Now it's working . Thanks Bro


This forum uses Lukasz Tkacz MyBB addons.