Kodi Community Forum
[LINUX] XBMC for Linux port to ARM architecture CPU and SoC chips? - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Feature Requests (https://forum.kodi.tv/forumdisplay.php?fid=9)
--- Thread: [LINUX] XBMC for Linux port to ARM architecture CPU and SoC chips? (/showthread.php?tid=35139)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48


- vane.xbmc - 2010-04-08

davilla Wrote:16:39:03 T:1103313200 M:821952512 NOTICE: GL_VENDOR = NVIDIA Corporation
16:39:03 T:1103313200 M:821952512 NOTICE: GL_RENDERER = NVIDIA Tegra
16:39:03 T:1103313200 M:821952512 NOTICE: GL_VERSION = OpenGL ES 2.0

Hi again,

I've seen you are working with an nvidia tegra, can I ask you where do you obtain the SDK for this GPU? I've seen in nvidia web page it is coming soon for Linux SO.

Regards,

Vane.


- davilla - 2010-04-08

vane.xbmc Wrote:Hi again,

I've seen you are working with an nvidia tegra, can I ask you where do you obtain the SDK for this GPU? I've seen in nvidia web page it is coming soon for Linux SO.

Regards,

Vane.

You would need to talk with nvidia.


- mzsy - 2010-04-12

davilla Wrote:You would need to talk with nvidia.

Hi,davilla

Do you have a plan to enable openmax support on tegra?
http://trac.xbmc.org/ticket/9070

B.R


- davilla - 2010-04-12

mzsy Wrote:Hi,davilla

Do you have a plan to enable openmax support on tegra?
http://trac.xbmc.org/ticket/9070

B.R

Yes. Without OpenMax support, the Tegra2 platform would be as useful as the AppleTV without CrystalHD.


- mzsy - 2010-04-12

davilla Wrote:Yes. Without OpenMax support, the Tegra2 platform would be as useful as the AppleTV without CrystalHD.

That's awesome! Another great work for xbmc!


GUI problems - vane.xbmc - 2010-04-14

Hi all,

I am running XBMC (arm_camelot on Beagle Board with Angstrom and OMAP35x_Graphics_SDK_3_01_00_02) and I've found some problems:

if I leave it running for a while, without press any key or move the mouse, it shows some black elongated letters in the middle of the screen. Then, If I move the mouse, they dissapear.

Also, I can't play mp3.

Anybody knows about these issues?

Thanks,

Vane


- davilla - 2010-04-14

vane.xbmc Wrote:Hi all,

I am running XBMC (arm_camelot on Beagle Board with Angstrom and OMAP35x_Graphics_SDK_3_01_00_02) and I've found some problems:

if I leave it running for a while, without press any key or move the mouse, it shows some black elongated letters in the middle of the screen. Then, If I move the mouse, they dissapear.

Also, I can't play mp3.

Anybody knows about these issues?

Thanks,

Vane

xbmc screensaver kicking in and doing strange things I bet. I see similar strange effects under tegra2.

don't know about mp3 audio. perhaps a pastebin of xbmc.log would be helpful to see.


GUI problems - vane.xbmc - 2010-04-14

davilla Wrote:xbmc screensaver kicking in and doing strange things I bet. I see similar strange effects under tegra2.

Ok, thank you.

davilla Wrote:don't know about mp3 audio. perhaps a pastebin of xbmc.log would be helpful to see.

Here is the URL to my xbmc.log in pastebin: http://pastebin.com/SLuk624B

Also, you can see in the log that I've got an error with DBus, I don know why, because I've got the following prodesses running:
/usr/bin/dbus-daemon --system
/usr/bin/dbus-launch --auto-syntax --exit-with-session
/usr/bin/dbus-daemon --fork --print-pid 6 --print-address 8 --session

Is it related with the exchange of messages between the different threads?

Regards,

Vane.


- davilla - 2010-04-14

vane.xbmc Wrote:Ok, thank you.



Here is the URL to my xbmc.log in pastebin: http://pastebin.com/SLuk624B

Also, you can see in the log that I've got an error with DBus, I don know why, because I've got the following prodesses running:
/usr/bin/dbus-daemon --system
/usr/bin/dbus-launch --auto-syntax --exit-with-session
/usr/bin/dbus-daemon --fork --print-pid 6 --print-address 8 --session

Is it related with the exchange of messages between the different threads?

Regards,

Vane.

"ERROR: Unable to load /usr/share/xbmc/system/players/paplayer/MACDll-arm.so, reason: /usr/share/xbmc/system/players/paplayer/MACDll-arm.so"

This will prevent mp3's from playing. it's been disabled now in arm-camelot trunk, svn up and re-build. See http://trac.xbmc.org/changeset/28989/branches/arm-camelot/trunk

Your DBus errors I think are version related. I see them too under a ubuntu 9.04 filesystem.

EDIT: you also might configure with --disable-pulse to disable pulseaudio.


GUI problems - vane.xbmc - 2010-04-15

davilla Wrote:"ERROR: Unable to load /usr/share/xbmc/system/players/paplayer/MACDll-arm.so, reason: /usr/share/xbmc/system/players/paplayer/MACDll-arm.so"

This will prevent mp3's from playing. it's been disabled now in arm-camelot trunk, svn up and re-build. See http://trac.xbmc.org/changeset/28989/branches/arm-camelot/trunk

EDIT: you also might configure with --disable-pulse to disable pulseaudio.

I had already included the new MusicInfoTagLoaderMP3.cpp, it works configuring with --disable-pulseaudio. Thank you.

davilla Wrote:Your DBus errors I think are version related. I see them too under a ubuntu 9.04 filesystem.

Version of what? I,m using Angstrom with ext3 filesystem.

Regards,

Vane.


- McGeagh - 2010-04-15

Yes, the weird text is to do with the screensaver... i suspect the subtle difference between GL and ES means that ES will just render whatever it had last in memory, most of the time thats random text, other times its the cursor (if you have it enabled and move around a bit)

And I hadnt investigated into why mp3's didnt work yet, but that seems to be fixed now! (Hmm, you lot work fast. Sorry ive not been doing much on this recently, hectic few weeks at work. I promise to continue soon enough!)

BTW, can you lot quit xbmc? My version refuses to do so, so worth seeing if its just my setup thats fucked.


GUI problems - vane.xbmc - 2010-04-15

davilla Wrote:Your DBus errors I think are version related. I see them too under a ubuntu 9.04 filesystem.

I just discovered that I get this error if I run xbmc.bin as root in Angstrom. I don't understand why.

Regards,

Vane


- vane.xbmc - 2010-04-15

McGeagh Wrote:Yes, the weird text is to do with the screensaver... i suspect the subtle difference between GL and ES means that ES will just render whatever it had last in memory, most of the time thats random text, other times its the cursor (if you have it enabled and move around a bit)

Why screensavers don't work? I can try to solve this problem but I don't know how.

McGeagh Wrote:BTW, can you lot quit xbmc? My version refuses to do so, so worth seeing if its just my setup thats fucked.

I can't quit neither.

Vane.


- McGeagh - 2010-04-16

only screensaver dim works, the other fancier ones require OpenGL and havent ported them to ES yet.

Screensaver Dim uses the static function DrawQuad in GUITextureGLES. Start there.
My thought is perhaps with the way i changed it from GL to ES, it wont initialise correctly if its a static function, so perhaps test this by change it so its no longer static. Havent really given this much thought though.


- davilla - 2010-04-16

@McGeagh. Are you using scratchbox or scratchbox2 ?


This forum uses Lukasz Tkacz MyBB addons.