Kodi Community Forum
Bug RPi4 MySQL error - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: Bug RPi4 MySQL error (/showthread.php?tid=355525)



RPi4 MySQL error - kafisc88 - 2020-06-28

I have a strange issue with my RPi4.
The RPi4 is configured to access a MySQL database for series and movies which is hosted on anohter RPi4.
When I browse series or movies, the PRi4 just hangs and reboots itself (Kodi).
The issue occurs on the latest official LE 9.2.3 build, but also on the Milhouse builds.

The poblem does not occur on 2x RPi3 LE 9.2.3, 1x Win10 Kodi v18.7 and on 2x Odroid C2 each with LE 9.2.3 with the same advancedsettings.xml file.
I've already tried a clean installation and 3 different sd-cards, but the issue stays.

advancedsettings.xml looks as following:
https://paste.kodi.tv/yeyuwacujo

Here are the logfiles:
https://pastebin.com/LXusQUBL

I am very grateful for any information.


RE: RPi4 MySQL error - DaVu - 2020-06-29

Either that logfile is incomplete or that logfile is grabbed after the restart. 

Could you please try to reproduce and directly after the reboot/restart of Kodi provide the kodi.log as well as the kodi.old.log, please.

If Kodi crashes, there should also be a crashlog at your home-directory which could be helpful as well.


RE: RPi4 MySQL error - Klojum - 2020-06-29

(2020-06-28, 19:54)kafisc88 Wrote: When I browse series or movies, the PRi4 just hangs and reboots itself (Kodi).

All the other SQL queries, inserts and so on, work with out a glitch according to the log file. So why would MySQL be the problem?

2020-06-28 14:58:13.259 T:2875597680 NOTICE: MYSQL: Connected to version 5.7.26-1
MySQL is at 5.7.30 now, but all-in-all it should work fine.

What OS is running on the RPi4 with the MySQL server on it? Is it a NAS thing?


RE: RPi4 MySQL error - kafisc88 - 2020-06-29

Thank's for the replies.

What OS is running on the RPi4 with the MySQL server on it? Is it a NAS thing?
-> Raspbian GNU/Linux 10 (buster)

The same problem also occurs with another MySQL Server only on the RPi4:  Ubuntu 18.04.4 LTS (fresh installation of MariaDB no changes to standard config except listen port = 0.0.0.0)

I've created new log files. Here is what i did:
- In order to exclude the MicroSD card, i've used another brand new Sandisk MicroSD card. and installe LE 9.2.3 fpr the RPI4 on it.
- Activated Debug Logging.
- restartet and reproduced the problem
- after LE restarded, I've copied the logfiles

kodi.log: https://pastebin.com/jDWzMbPj
kodi.old.log: https://pastebin.com/sSu7NVKZ
There is no crashlog available.

I've filmed the whole procedure: https://www.youtube.com/watch?v=_z87dsGIylU&feature=youtu.be


This forum uses Lukasz Tkacz MyBB addons.