Kodi Community Forum
Beta Testflight access to beta version - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (https://forum.kodi.tv/forumdisplay.php?fid=116)
+---- Forum: Kodi Remote for iOS Official Forum (https://forum.kodi.tv/forumdisplay.php?fid=193)
+---- Thread: Beta Testflight access to beta version (/showthread.php?tid=359717)



RE: Testflight access to beta version - UlfSchmidt - 2022-12-11

(2022-12-11, 22:53)Buschel Wrote:
(2022-12-11, 21:41)UlfSchmidt Wrote: Regression or not?
Regression of a simplification I did, obviously too much simplification. Smile
Thanks for reporting, fixed now.

Thanks!
I am always impressed by your speed Smile


RE: Testflight access to beta version - amasephy - 2022-12-12

Yes, agreed that Buschel’s speed is impressive.

That regression reminds me of something. I’m not sure what description you are speaking of but I noticed what I’m sure is a regression the other day.

The overlay on the now playing screen (the one that displays the codecs and such) is no longer dismissible by pressing on the codecs like before. We had talked awhile back about potentially making it easier to dismiss. At the time I had just learned that dismissal was possible by tapping on the codec graphics as well as the X. Now when I check it you must use the X.


RE: Testflight access to beta version - UlfSchmidt - 2022-12-12

@amasephy

Yes, I was talking about this overlay. And in my opinion it is not a regression, but a correction, if tapping the codec icons is no longer dismissing the overlay. Tapping outside of the overlay could dismiss the overlay too. But not tapping somewhere within the overlay.

@Buschel

In fact, I am still hoping for an extension I already suggested a long time ago: tapping on, for example a Dolby Digital logo could bring a pop-up displaying the language selected and the current channel configuration, like „German 5.1“ or „English 7.4.1“.


RE: Testflight access to beta version - Buschel - 2022-12-12

Correct, the behaviour of the song details view (that's how it's called in the code) is now as for other popovers: close via dedicated button or clicking outside. On iPad it is generally easier to find such empty space than on iPhone. I am still not fully convinced of the implementation on iPad and might apply further changes, but not before the next version. I anyway added way too much risk by the changes of the last weeks -- but overall towards better app experience.
Smile


RE: Testflight access to beta version - amasephy - 2022-12-12

Understood, logically it was strange that tapping the codecs dismissed it.

May I suggest making this overlay dismissible by swiping down?


RE: Testflight access to beta version - Buschel - 2022-12-12

Difficult, as you might have scrollable text in it. I will skip the idea to dismiss via pull. Let's now try to finish the next release and only focus on showstoppers. The next upcoming build already -- again -- will have numerous fixes.


RE: Testflight access to beta version - amasephy - 2022-12-16

Buschel,

You might consider this to be a show stopper. I can’t say where the problem starts but here’s an update on my setup….

I finally updated my devices to iOS 16.2. At the same time my Xbox automatically updated Kodi to the 20.0 RC release. As you can imagine there’s a lot of unhappy people over in the Xbox threads on this forum. The update seemed to work ok for me.

With that out of the way I have a new issue. Using the gesture pad on the remote to adjust the volume causes the app to freeze. The volume adjust for a second or so then starts behaving erratically until it just freezes. Further attempts to disconnect and reconnect to the Kodi server result in failure. Closing the app out resolves the problem.

While I can’t get it to repeat itself, on the Kodi server list page I got a random message about “not being able to complete an action” because my phone is out of storage. It isn’t though. I attempted this while I had triggered the volume gesture bug. Seems some network interface is being overloaded performing this action.

Same problem is present on my iPad.


Secondly, but less important, concerns the overlay on the now playing screen. On iPad if you have a pane over the Now Playing screen such as Global Search and you tap anywhere in the footer, the overlay can be opened and closed even though you shouldn’t be able to interact with the now playing screen.


RE: Testflight access to beta version - Buschel - 2022-12-16

Hi,

the last topic is also came across and it is taken care of with one of the not-yet-merged changes. With this change you cannot open/close the overlay anymore.

You saw the volume gesture problem first after updating to iOS 16.2 and to Kodi 20 RC1 at the same time, right? Before -- latest TF build, but with iOS 16.1 and Kodi 19.x -- this worked? Just to be sure can you try to roll back to the TF build before the current one and retry? If this does not help, can you try to disable TCP remote connection in Kodi (resulting in the "yellow connection" state)?

My iPhone just got update to iOS16.2 and I will try this with my Kodi 19.4 later today.


RE: Testflight access to beta version - amasephy - 2022-12-16

I’m not sure I actually tested the gesture on the current TF before everything got updated. I can rollback the TF and check. I don’t often check the gestures but figured I should since so much for updated all at once.

Edit: It’s a new problem in the latest TF build. Must be related to the NSUrlSession you implemented. It works fine in the previous build.


RE: Testflight access to beta version - Buschel - 2022-12-16

Tested now as well. This also happens with my iPhone und iOS 16.2, the latest TF version (3632) and Kodi 19.4. And I could only reproduce with the volume gesture. But it cures automatically after a few seconds. When I try to run another library browser command (e.g. showing album details) before this resolves I get an error message (from iOS) that the network connection was lost. I only also suspect the NSURLSession changes.

@kambala, any idea on this?

Edit: Even happens in simulator. The issue can be reproduced also with the old NSURLConnection code, but it takes a lot longer to get there. It gets more robust when either rolling back the NSURLSession changes completely, or when using the new implementation and only do a very basic rework to use NSURLConnection again. Which is a sign of NSURLSession vs. NSURLConnection does the trick.

Edit2: This reads similar -> https://stackoverflow.com/questions/32846656/nsurldomainerror-1005-the-network-connection-was-lost


RE: Testflight access to beta version - kambala - 2022-12-17

no ideas out of my head, needs debugging.

from SO:
Quote:It appears to be happening due to the session caching the previous connections.
if it's really so, caching can be disabled (on request level there's cachingPolicy property)


RE: Testflight access to beta version - Buschel - 2022-12-17

What also seems to resolve this is when I again go back to support multiple NSURLSessionTask objects in a single instance of DSJSONRPC and keep the DSJSONRPC object until a new one is needed. Maybe this is even the more desired way of doing this.

Demo code: https://github.com/wutschel/Official-Kodi-Remote-iOS/tree/volume_lock2

Edit: Setting
cpp:
config.requestCachePolicy = NSURLRequestReloadIgnoringLocalCacheData;
does not help.


RE: Testflight access to beta version - amasephy - 2022-12-19

Hi Buschel,

I know you have a lot on your plate with this volume adjustment issue. I did notice a very minor thing I was wondering if had been noticed before.

With the info overlay many codecs and such had graphics associated with them but 4K does not have a logo. 1080p does have a logo. Any chance you might be able to add one for this?

Missing 4K:
Image

1080p:
Image



Edit: Probably not a big concern for this release but I found a way to lock that strange pane sliding behavior when editing the Now Playing playlist. You need to have “shake to clear playlist enabled”.

First populate the playlist, I personally just used the “Party” option. With the playlist now populated, press edit. Now shake your phone. Clear the playlist. Now just go back to the main now playlist screen. Swipe to the remote pane on the right. You will see the abrupt animation now as the app still thinks it’s in edit mode even though edit is grayed out since the playlist is empty. Playlist edit mode should probably be exited upon clearing the playlist with a shake.


RE: Testflight access to beta version - Buschel - 2022-12-19

Thanks, @amasephy. The icons for 4K and 8K were already there, but they needed a capital "K" to work. Looks like this now: https://abload.de/img/bildschirmfoto2022-120zed2.png

I will look into the other topic later today.

Edit: Could not see the problem you described, but could verify that editing continues after shake-to-clear. Fixed this in a PR as well.


RE: Testflight access to beta version - amasephy - 2022-12-19

Looks good, thank you Buschel.

This is could be more of a Kodi server issue but clearing the playlist while party mode is activated can break party mode. Party mode will still be activated (blue icon) but no songs will be added to the playlist once a playlist is emptied. If you only remove one at a time it will keep inserting a new one. If multiple entries are removed it will only insert one additional entry.


This forum uses Lukasz Tkacz MyBB addons.