Kodi Community Forum
Beta Testflight access to beta version - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (https://forum.kodi.tv/forumdisplay.php?fid=116)
+---- Forum: Kodi Remote for iOS Official Forum (https://forum.kodi.tv/forumdisplay.php?fid=193)
+---- Thread: Beta Testflight access to beta version (/showthread.php?tid=359717)



RE: Testflight access to beta version - Buschel - 2022-12-19

I briefly looked into the party mode. Looks like a next set of tracks is backfilled as soon as the playlist is able to advance at least by one next track. So, keeping two tracks left in the playlist (the current playing one, and one more as "next track") is enough to let the party mode fully backfill the playlist. If you remove all tracks or all except the current playing track, the playback stops after the current playing track. So, I agree, in such case the party mode should be switched off. I see this as a minor issue, for which I do not want to risk the playlist logic to screw up. I will not touch the code to improve this behavior for now. I will rather work with kambala on getting all other changes into a next build.


RE: Testflight access to beta version - amasephy - 2022-12-20

I figured messing with the playlist would open a can of worms for the imminent 1.11.1 release. Maybe a future release.

For this release I think I found another slight issue related to dismissing search via scroll. If you start a search in Movies, scroll to dismiss the search, tap a movie, swipe back to movies the search comes back even though it should have been previously dismissed from the scroll.

Edit: Finally I am able to reliably reproduce something I have been noticing lately. Now Playing screen goes from being populated to being blank but still playing.

Please review this video for steps. I can consistently reproduce this issue doing these steps exactly. I recommend performing them from a fresh start of the app.

Edit 2: Pretty minor issue but if you are in ken burns view and suspend the app and open it back up the ken burns panning effect breaks and the image remains static.


RE: Testflight access to beta version - Buschel - 2022-12-20

@amasephy, you're always coming up with the interesting stuff. Smile
  1. keyboard dismiss -> Fixed. Was a quite simple code change.
  2. empty now playing -> Nice! I have seen this as well from time to time and could not reproduce. The key is to enter NowPlaying from a library view, and then swipe instead of pressing the "Back" button in the navigation bar. After this the problem occurs happens. Root cause seems to be a questionable variable handling and a race condition. I have a local code change which already seems to solve the problem, but would like to understand better how the race condition ends up in this problem.
  3. ken burns -> Will not fix for now. If you just wait for a few seconds it starts to animate again automatically. The running animation is just stopped and the next animation cycle will start after a pre-defined sleep (45 seconds for each animation cycle).
Edit: Fixed the now playing issue now, but the related logic needs more rework once the next release is out. There are some global variables which I would like to take care of.


RE: Testflight access to beta version - amasephy - 2022-12-22

Buschel,

I’m glad you find them interesting. 🙂 You will likely find this to be just as interesting.

A quick note: now using 16.0 RC2


Finally another issue I noticed months ago but couldn’t figure out how to reproduce until tonight.

You can trick the app into adding Movies to the Music playlist in Now Playing. This could also be a Kodi Server issue though. You will have to make that call.

Steps to reproduce: Activate party mode on the app. Then use the app remote screen and open Movies on the Kodi server. Long press a movie and tap Play Next. Go back to the Now Playing playlist. You have now added a movie to the music playlist.


A second minor issue I noticed while documenting the above bug is also related to the playlist view. The lingering thumbnail.

Steps to reproduce: Start a movie. Go to the now playing playlist. Clear the playlist by shaking. Stop the movie. The thumbnail is still present in the lower right corner even though nothing is playing and the playlist is empty.

A third minor issue: Frozen playback time in currently playing list item in the playlist.

This is a little tricky to reproduce but basically you need to have a few items in the playlist. I used party mode to populate the playlist.

Steps: Start party mode. Try and grab the right edge of the bottom item in the playlist and swipe left. If you get it right you will reveal the red delete button with the word “Delete” on it. Once you successfully reveal this button the current time of the currently playing item freezes even though playback continues. Using the easily accessible edit mode button does not cause this to happen. Most people probably are even aware swipe to delete is even possible here. It’s tough to do because the pane wants to slide over to the remote. I suspect it will be easier for you do in your simulator.

Another minor thing I noticed when pausing and unpausing items in the Now Playing playlist. Weird numerical values flicker in the progress time. See screenshot below - upper left corner.

-31:-23 <—- weird values.

Image


Edit: a quick note about the Now Playing race condition previously reported. That is not the only way to trigger that error. I can actually get it to happen with just using the normal Now Playing from the main menu. No library Now Playing method required but it takes a few tries to get it to happen. If you need me to document this I can try. Basically I just keep viewing the playlist and tap now playing to go back to the album art screen. I might suspend the app in between a few tries. Eventually you get the blank album art view.


RE: Testflight access to beta version - Buschel - 2022-12-22

(1) adding video/movie to music playlist -> Kodi server bug. I cannot trigger this from the remote library command, only via the remote or directly on the server UI.
(2) mini thumb -> Confirmed and fixed. This generally happened when stopping playback while being in the playlist view.
(3) swipe to delete -> Tried several times and cannot get there, even not on simulator.
(4) weird actual time -> Cannot reproduce. The code is pretty straight forward, possibly the server reports such numbers? Did you test only with Kodi 20? I am using 19.4 here.
(5) blank now playing -> I can reproduce this only when a new instance is starting. This can also be forced when re-entering NowPlaying (NowPlaying runs, press burger to go to main menu, then re-enter). Just by toggling between playlist and now playing view I cannot reproduce.


RE: Testflight access to beta version - amasephy - 2022-12-22

1: Any idea what part of this forum I could report this issue? It’s a labyrinth of sections related to the core server app.

3: Here’s a video of me performing this action. It really can be difficult to pull off. You’ll see the time incrementing until the delete button becomes visible then it halts.

4: Tested with 19.3 on my windows box. Seems the weird time is a new bug on Kodi 20.0. Works fine on 19, no strange numbers.

5: Here’s a video of me triggering this. Sometimes it triggers quicker but this time it took about a minute of fiddling with it. I show from a fresh launch of the app and server connection occurring.


RE: Testflight access to beta version - Buschel - 2022-12-22


  1. Best would be to create a report in GitHub. Or @kambala could point to a place to raise this here in the forum.
  2. Got it now. Quite hard to get there, you really need to swipe super fast. Easiest would be to switch off the editing option here, this is a single line of code. As normally the whole pane should swipe and it's hard to open the "delete" I would be ok doing this. Your thoughts?
  3. Ok, can you raise this here: https://forum.kodi.tv/forumdisplay.php?fid=174 ? I could just try to add a filter to not update negative values. But I would rather like to see this fixed on the server.
  4. Following the video you also restart the NowPlaying view, so a new instance is created. Looks like the same use case as I fixed. I'd say we wait for the next build and you try to reproduce again. It should be fixed.



RE: Testflight access to beta version - amasephy - 2022-12-22

1: I will wait for advisement from Kambala. While I have lurked GitHub I don’t think I have an account there and am not really familiar with the process for reporting stuff there. It’s called pull requests there, right?

2: I’m good with removing the ability to pull out the delete button. It doesn’t make sense for this to exist where a pane can slide.

3: Done

4: Sounds good.


RE: Testflight access to beta version - Buschel - 2022-12-22

(2) Even better: I can handle this properly for iPads (unblock the time update after editing a single row), but removing the delete-via-swipe support for iPhone.

Edit: One more thought. As we, since a while, can enter the remote from NowPlaying via the navigation bar button, we could drop this "swipe left to reach remote" gesture. This would allow to keep the swipe-to-delete in the playlist view. Such rework I would only do for another release though.


RE: Testflight access to beta version - amasephy - 2022-12-22

I would really like to keep the swipe left to reach the remote ability.

There’s already two other methods to clear items from the playlist- going to edit mode and the shake to clear the whole playlist.

Whoever ever possible I avoid using the navigation buttons to access the remote and playlists. It’s just more difficult to reach them even on my tiny phone.


RE: Testflight access to beta version - Buschel - 2022-12-22

Hmm, you're coming from the point of view that the navigation bar is harder to reach when using the iPhone one-handed?

Edit: Anyway, for now I will not remove the swipe-to-delete from iPhone, but fix the current time freeze after using this gesture for all devices.


RE: Testflight access to beta version - amasephy - 2022-12-22

Hi Buschel,

New bug - this time it’s iPad only.

There seems to be some discrepancy in the audio stream list views between iPhone and iPad. iPad in theory should have more space for long strings but in fact it truncates them!

iPhone:

Image

iPad:
Image


RE: Testflight access to beta version - Buschel - 2022-12-23

The dimensions of the action sheets I cannot influence. But I saw from your screenshots that the origins were wrong, I fixed those: https://abload.de/img/bildschirmfoto2022-124mco7.png.


RE: Testflight access to beta version - amasephy - 2022-12-23

Buschel,

Thanks for submitting the bug report to GitHub in the other thread. I now understand how bug submissions should work there.

Regarding the swipe to edit I think I realize what you meant by swiping fast. When you open the playlist view if you swipe immediately on a list item it’s very easy to trigger the swipe to delete. Once you’ve done this once you can easily do it over and over until you trigger the pane swipe animation which is now actually harder to perform. You have to swipe some area of the screen where there are no list items.

Edit: looks like if you physically swipe fast on the record that always reveals the delete button. Interestingly once you’ve revealed the button and then swipe back to hide it, navigating to the remote screen causes the pane to jump over (if you swipe over a little it immediate opens the remote pane) This to me indicates that edit mode is still activated once the delete button is revealed and hidden. This only happens the first time you attempt to swipe to the remote screen. Doing this subsequent times doesn’t trigger the jumpy pane slide.

Edit 2: This might be related to the issue reported related to cellular data reported in the App Store and discussed on this forum.

No idea how to trigger it. I just encountered it with waking up my phone from standby and it immediately popped up.

Image

Have great holiday.


RE: Testflight access to beta version - Buschel - 2022-12-24

1.11.1 build 3680
Release Notes

Merry Christmas and Happy Holidays!


This forum uses Lukasz Tkacz MyBB addons.