Kodi Community Forum
Linux Strange behavior in Party Playlist relating to music videos and or subtitles? - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Video Support (https://forum.kodi.tv/forumdisplay.php?fid=264)
--- Thread: Linux Strange behavior in Party Playlist relating to music videos and or subtitles? (/showthread.php?tid=362998)



Strange behavior in Party Playlist relating to music videos and or subtitles? - bornagainpenguin - 2021-06-06

I am running Kodi via LibreELEC (official) 9.2.6 on a minipc and I checked against this with Kodi 19.1 on Ubuntu 20.04.2 LTS with a new profile on my Lenovo Thinkpad x250 with a clean profile, both demonstrating the same behavior.  Here is a log: https://paste.kodi.tv/ehotuzacay.kodi

I downloaded some videos from YouTube and scraped the subtitles for the songs.  I tested the subs and they display without issue on the videos in VLC.  I copied them to the media directory for my Kodi to use and added them to the library.  Videos add without issue and play without issue.  Even using Party Mode is fine and will play without issue including the subtitles.  Where it gets odd is if you run Party mode in Party mode.

Usually this just ends up with a reordered and more random playlist, however with my subtitles I noticed that running Party mode in Party mode results in the video playing but a complete inability to get subtitles to work.  Can anyone duplicate this?  Is this an actual bug or something resulting from me doing something the system never anticipated?

Thanks in advance for any assistance.


RE: Strange behavior in Party Playlist relating to music videos and or subtitles? - bornagainpenguin - 2021-06-22

Just wondering if anyone has had any time to look into this?


RE: Strange behavior in Party Playlist relating to music videos and or subtitles? - scott967 - 2021-06-24

What format / file extension are your subs?  I guess not .vtt because I don't think Kodi will use these in any situation (except muxed into mp4 at least).

scott s.
.


RE: Strange behavior in Party Playlist relating to music videos and or subtitles? - scott967 - 2021-06-30

(2021-06-24, 01:35)scott967 Wrote: What format / file extension are your subs?  I guess not .vtt because I don't think Kodi will use these in any situation (except muxed into mp4 at least).

scott s.
.
OK I did some testing, and I don't see that external subtitles are picked up regardless of how party mode is started.  I assume that party mode manager takes a slightly different code path than when videos are selected through the library.

scott s.
.


RE: Strange behavior in Party Playlist relating to music videos and or subtitles? - bornagainpenguin - 2021-07-06

(2021-06-24, 01:35)scott967 Wrote: What format / file extension are your subs?  I guess not .vtt because I don't think Kodi will use these in any situation (except muxed into mp4 at least).

scott s.
.

Sorry I missed this response.  The subtitles are in SRT format, from a website that rips subtitles from YouTube.

The funny thing is if I go to the smartplaylist and simply hit play on it with my remote the playlist functions perfectly normally and plays all the videos in random order with their subtitles, just as expected.  But for whatever reason Party Mode does not.


RE: Strange behavior in Party Playlist relating to music videos and or subtitles? - scott967 - 2021-07-08

(2021-07-06, 16:00)bornagainpengui Wrote:
(2021-06-24, 01:35)scott967 Wrote: What format / file extension are your subs?  I guess not .vtt because I don't think Kodi will use these in any situation (except muxed into mp4 at least).

scott s.
.

Sorry I missed this response.  The subtitles are in SRT format, from a website that rips subtitles from YouTube.

The funny thing is if I go to the smartplaylist and simply hit play on it with my remote the playlist functions perfectly normally and plays all the videos in random order with their subtitles, just as expected.  But for whatever reason Party Mode does not.
Yes, I see the same thing, though all my test files also have internal subs.  I see that internal ones but not the external unless I browse in the subtitle settings window while playing when in party mode. So I'm pretty sure it isn't a sub language / settings issue.  My first run through with my crap c++ abilities, I see party mode manager adding MVs to the "now playing" playlist and I don't see offhand why playing the playlist would work differently in party mode, other than I know there are some special things happening due to the possibility of mixed smart playlists.

[As an aside, I use a script to mux .vtt subs into mp4 containers with ffmpeg, and Kodi will find those internal subs.]

scott s.
.


This forum uses Lukasz Tkacz MyBB addons.