Kodi Community Forum
Using extra fanart/poster not working - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Skins Support (https://forum.kodi.tv/forumdisplay.php?fid=67)
+---- Forum: Aeon Nox: Silvo (https://forum.kodi.tv/forumdisplay.php?fid=142)
---- Thread: Using extra fanart/poster not working (/showthread.php?tid=363037)



Using extra fanart/poster not working - emailafvang - 2021-06-09

Dear All,

I'm desperately turning to this forum, because I'm unable to find a solution for my extra poster/fanart problems.

If I understand correctly, using the Aeon Nox Silvo skin, it's possible to use extra fanart.jpg, or poster.jpg, files which will rotate in a set number of seconds.  Filenaming would be posterx.jpg, or fanartx.jpg, where x is an increasing number starting from 1, and depending the implementation in the skin maximum of 6-20 images.  Most interesting for me is the rotating posters, but rotating fanart instead of posters is something I would consider as well.

I've been trying to solve this problem now for more then 8 weeks, but shamingly can't find it.  Tried many new installation, re-installations, removing textures13.db and thumbnails many times.  I've been trying using vmware as well, and kodi installed on a virtual installation, all without results.

I'm using following setup as intended main solution for a mediaplayer option:
-Raspberry Pi 3B+
-OSMC 2020-11-1
-Aeon Nox Silvo skin 7.09
-List view
-Local art, on the used NAS shares
(fanart.jpg/poster.jpg)
-No scrapers, nothing of the kind
-Shares are created under videos in the main menu

NAS shares:
Share -> Series folder => TV Show => Season folders

Under TV Show folder I also created the extrafanart folder containing fanartx.jpg and posterx.jpg files.  In the TV Show itself I have the fanart,jpg and poster.jpg files.

I also tried using the fanartx.jpg and posterx.jpg files in the TV Show folder, but not working as well.

The single fanart.jpg/poster.jpg are working properly, but the extra rotating poster or fanart images, I can't get to work.

For these shares I tried options as containing "Nothing", or containing "Movies".  I've tried "Artwork Beef", Artwork Downloader, and "Toolbox.Script", because in the many threads I've found on the internet, these were suggested as possible solutions, or required for what I'm trying to achieve.  I've tried using an "extrafanart" folder with in it "fanartx.jpg" files.  I've tried "Local Art" as scraper option for the shares themselves.  Everything to no avail.  Left cursor menu under media has the "ExtraFanart" option enabled.

I know this has been asked many many many times, especially looking at all the threads I find on the internet for it.  Nowhere though am I able to find a solution if what I'm trying is at all possible, and if possible, how.

-Can anyone please shed some light on this.
-Is it possible with the above setup description to have local art and rotating poster or fanart?
-If so, can anyone please help me with instructions on how to do this?

Thanks you so much for any, and all, efforts taken/given to help me with this.

Best regards,


RE: Using extra fanart/poster not working - PatK - 2021-06-13

(2021-06-09, 16:17)emailafvang Wrote: -Is it possible with the above setup description to have local art and rotating poster or fanart?
Works for me, didn't have to turn anything on. I do believe that the folder method of extrafanart has been depreciated (although some skins still use it), I have set backgrounds on the home screen for movies & TV shows as random fanart. Of course the video folders must be populated with artwork in the order of ShowName-fanart.jpg, ShowName-fanart1.jpg, ShowName-fanart2.jpg and ShowName-poster.jpg, ShowName-poster1.jpg etc.  of which for Matrix I use 3rd party add-on called 'Artwork Dump' to fetch more artwork. In the target video, information page 'choose art' you can specify the rotation art, unless you already have your artwork lined up. I'm not using a Raspbery Pi b+ for this, suspect it might be a bit more effort that the system will handle and might be your issue. I'm using Aeon Nox Silvo skin 7.6.9 with Matrix and I note: Local art, on the used NAS shares and I'm not sure Networked, Accessed Shares is considered a local path by the skin and might be the stumbling block here.


Using extra fanart/poster not working - mycoolblue - 2021-06-15

Hallo PatK.  Sorry for responding so late.  For some reason I'm not able to access my account anymore, and I also can't get the reset password option to work.  I therefore created this new account.

Thanks you for your reply, very much appreciated, especially since I'm still stumped as to why I can't get it to work.

-I have set backgrounds on the home screen for movies & TV shows as random fanart
I assume you're referring to the main menu settings for the skin.  I had single image there.  If I select random art, I have many choices in the Aeon Nox Silvo skin, varying from random movie/rv-show/other.  It still doess not work though.  The only thing happening is that my background on the home screen is black, empty.

-the video folders must be populated with artwork in the order of ShowName-fanart.jpg, ShowName-fanart1.jpg, ShowName-fanart2.jpg and ShowName-poster.jpg, ShowName-poster1.jpg etc.
I tried that, and again at that point, the background and poster become black when I scroll over that folder in the list view.  Only with fanart.jpg/poster.jpg do I get a background in listview.  I would like to have a rotating poster though in listview.  I also tried it in combination with your mentioned random art option. No go though.

-of which for Matrix I use 3rd party add-on called 'Artwork Dump' to fetch more artwork. In the target video
I assume you're using Kodi Matrix 19.x.  In OSMC it's still 18.9.  I will try to make a vmware setup in windows to see if I can get that to work.

-I'm not sure Networked, Accessed Shares is considered a local path by the skin and might be the stumbling block here.
Could be, although I would gather it strange, as those are the folders where the videos reside.  For me though Kodi/Skins/OSMC are very much a pitch black area in getting things to work.  I can find so little real information or instructiions.  Many things I've found so far is by just trying changing settings and see what happens.  For other settings it's really unclear wht they actually do or change  It's a pity, because it all looks really really nice as a replacement for my old Mede8er media player.  Or maybe I'm just not smart enough to get a grip on it.

Thanks again for the directions, and if someone else has any, I'd be really gratefull


RE: Using extra fanart/poster not working - Karellen - 2021-06-15

TV show artwork is saved as shown in the screenshot here. Your fanart naming you describe above is wrong... https://kodi.wiki/view/TV-Show_artwork#Local_TV_Show_Artwork
The page has not been updated for v19 yet. The only change is that code is not required anymore. All artwork settings are done here... https://kodi.wiki/view/Settings/Media/Videos#Artwork
There are no extrafanart folders in use.

Go to Choose Art in the Information Page of the TV Show and check that multiple fanart and posters have been scanned. Do you see them listed there? If not, probably because the artwork naming is wrong.
Image

Image

Ensure you have set backgrounds to scroll extrafanart...

Image

Image


(2021-06-15, 08:53)mycoolblue Wrote: For some reason I'm not able to access my account anymore, and I also can't get the reset password option to work.  I therefore created this new account.
Ok, I will close your original account.


Using extra fanart/poster not working - mycoolblue - 2021-06-15

(2021-06-15, 09:07)Karellen Wrote: TV show artwork is saved as shown in the screenshot here. Your fanart naming you describe above is wrong... https://kodi.wiki/view/TV-Show_artwork#Local_TV_Show_Artwork
The page has not been updated for v19 yet. The only change is that code is not required anymore. All artwork settings are done here... https://kodi.wiki/view/Settings/Media/Videos#Artwork
There are no extrafanart folders in use.

Go to Choose Art in the Information Page of the TV Show and check that multiple fanart and posters have been scanned. Do you see them listed there? If not, probably because the artwork naming is wrong.




Ensure you have set backgrounds to scroll extrafanart...




 
(2021-06-15, 08:53)mycoolblue Wrote: For some reason I'm not able to access my account anymore, and I also can't get the reset password option to work.  I therefore created this new account.
Ok, I will close your original account.

Hi Karellen,

Haaah, I was just writing a better explanation on what I was trying to achieve.

Thank you so much.  I'm going to try this.  From your description though I think that what I'm trying is not possible.  I'm going to check your suggestions though, so thanks again.

Just for form, see below the extra description.

I use shares on a NAS containing my video media.

NAS => Videos folder => TV-Series folder => e.g. Mork and Mindy folder => Season 01/02/etc. folders

In the Mork and Mindy folder I have the fanart.jpg/poster.jpg files, which work.  In the Season folders I keep DVD cover images as poster.jpg, which also work, no fanart there.

What I would like is when using the list view in the TV-series folder, so scrolling through it, that the posters rotate for the selected series at that time.  As an alternative if posters rotating is not possible, to have fanart rotate.  Everything using artwork locally stored in those folders.  So no scrappers or anything of the kind.


RE: Using extra fanart/poster not working - mycoolblue - 2021-06-24

OK, I've been testing and trying since last, and am a little further now, but am strill not able to get things to work with local art only.

-If I understand correectly now, unless you define content as movies/tv shows, the only art kodi will use are fanart.jpg and poster.jpg, these 2 only and no multiart possible
-To be able to choose art, as shown in Karellens screenshots you MUST set a type of content, either movies or series
-You are now also able to choose views other then the standard 3, list/icon/wall
-You MUST select a database to scrape from, the local information only does not seem to work.
-If the title you're scrapping for is not in the database, kodi will offer a window to change it's name.
-If that name is also not known, I go into an endless circle of seeing that same window again and again, until I enter a name that is in the database used for scraping.
-If I change the used database from point 2 to using local information only, I still get the same thing, kodi will offer a window to change it's name I go into an endless circle of seeing that same window again and again, I can't skip it, only cancel it by long pressing the home button.
-So I'm then never able to press the information button to go select artwork as per Karellens 1st screenshot
-I've also tried creating the advancedsettings.xml file in the kodi/user folder under the users folder in windows, but that also does not seem to pickup created fanartx.jpg or posterx.jpg files
-And I noticed that a file Fanart.jpg is not used, but changing it to fanart.jpg, it will nbe picked up, don't know if that's correct so kodi being casesensitive for this.

In the past 25 years I've recorded and converted many movies/shows/documentaries from TV, for which most are unknown in the selected database from point 2.  So I get stuck in the endless window loop for entering a name.

Any suggestions on this are absolutely asppreciated.

Thanks to all for any input


RE: Using extra fanart/poster not working - Karellen - 2021-06-24

(2021-06-24, 14:32)mycoolblue Wrote: -You MUST select a database to scrape from, the local information only does not seem to work.
No. That is wrong. There must be a problem with your local information.
Judging from your other points, there is a problem with your local information.
Provide the following...
Screenshot of your movie folder so I can clearly see the movie file and all the other contents in the folder.
Post the contents of your NFO file to Kodi Paste Site so I can check the file is correct
Provide a Debug Log which captures this problem and I might see what the problem is.

Make sure your artwork is correctly named. See image here... https://kodi.wiki/view/Movie_artwork


RE: Using extra fanart/poster not working - mycoolblue - 2021-06-28

Thank you again Karellen. 

This may sound stupid, but I'm slowly beginning to understand the way kodi works.  All my previous media players worked using the file hierarchie from the storage device.  I think I now realise that kodi can do that too, but then you can only use the basic fanart.jpg/poster.jpg files.  If you use the options to scrape then also new browsable folders are created under videos, being listings tv-series/movies.  If you select from there there's siubdiviions again, which lead to the scraped content.  Also, not all views support e.g. extra poster images.  Since I was mainly using list view for testing, which I believe doesn't support extra poster images, it of course wouldn't work.

So I'm several steps further again after realising this, and will continue to start testing to see if kodi is what I want to continue with.  It will be much more work with local art and nfo files, but I've already created some macro's which might make that easier for me.

As a last, since my main aim is raspberry pi use, I'm going to make a new test setup using kodi 18.9, because that's what the last release of osmc uses.  Osmc is going to upgrade too, but they've stated that intend in February, and so far no release.  I think the amount of work invested in that though is huge, so not very strange it takes time.


This forum uses Lukasz Tkacz MyBB addons.