Kodi Community Forum
[SOLVED] "Access Denied" on an actor thumbnail download - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (https://forum.kodi.tv/forumdisplay.php?fid=116)
+---- Forum: Ember Media Manager (https://forum.kodi.tv/forumdisplay.php?fid=195)
---- Thread: [SOLVED] "Access Denied" on an actor thumbnail download (/showthread.php?tid=363253)



[SOLVED] "Access Denied" on an actor thumbnail download - nsviper - 2021-06-25

Running EMM v1.10.0 x64

Trying to refresh Season 3 of Tin Star, and its failing - checking the EMM log, its showing:

2021-06-25 09:04:09.4575,EmberAPI.HTTP,EmberAPI.HTTP.DownloadImage,16,ERROR,DownloadImage    <http://thetvdb.com/banners/actors/191601.jpg>,"EXCEPTION OCCURRED:System.Net.WebException: The remote server returned an error: (403) Forbidden.
   at System.Net.HttpWebRequest.GetResponse()
   at EmberAPI.HTTP.DownloadImage()*   at System.Net.HttpWebRequest.GetResponse()
   at EmberAPI.HTTP.DownloadImage()"

testing the image directly : https://thetvdb.com/banners/actors/191601.jpg

<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<RequestId>35XJ2K5HHQXRRQKD</RequestId>
<HostId>3/Ug8sOUB/lmK16AEekFqGF/OcQzLMq/ac1l4/bx5aYfO4JqP+BbkMzTjqkwD2e0mobABBzgVWc=</HostId>
</Error>

Any ideas what to do? do i need to contact TVDB direct? or how can i switch scraper?


RE: "Access Denied" on an actor thumbnail download - DanCooper - 2021-06-25

Maybe TVDb finally switched to the subscription model API. You can use TMDb as scraper instead.


RE: "Access Denied" on an actor thumbnail download - nsviper - 2021-06-25

(2021-06-25, 10:54)DanCooper Wrote: Maybe TVDb finally switched to the subscription model API. You can use TMDb as scraper instead.

Yes, looks like they have...I'm being a bit thick and can't see where to switch scraper?

ImageImage


RE: "Access Denied" on an actor thumbnail download - DanCooper - 2021-06-25

(2021-06-25, 12:34)nsviper Wrote: Yes, looks like they have...I'm being a bit thick and can't see where to switch scraper?
You have a problem with your anti virus because no one of the scraper (external DLLs) has been loaded. The screen should look like that:

Image


RE: "Access Denied" on an actor thumbnail download - nsviper - 2021-06-25

(2021-06-25, 12:48)DanCooper Wrote:
(2021-06-25, 12:34)nsviper Wrote: Yes, looks like they have...I'm being a bit thick and can't see where to switch scraper?
You have a problem with your anti virus because no one of the scraper (external DLLs) has been loaded. The screen should look like that:

Image
ah ok, will look into that, thought it looked a bit weird, cheers Wink


RE: "Access Denied" on an actor thumbnail download - nsviper - 2021-06-25

Reverted to v1.9.2 - even with AV disabled, and a clean re-install, the scrapers would not show up.

1.9.2 seems ok, scrapers all showing up etc.


RE: "Access Denied" on an actor thumbnail download - nsviper - 2021-07-05

Sorted. Seems Windows decided it wanted to block the DLLs loading, not AV, so...

Powershell Prompt and navigate to folder where EMM is installed, then run
Get-ChildItem -Recurse | Unblock-File

EMM now loads up and all scrapers are available.


This forum uses Lukasz Tkacz MyBB addons.