Kodi Community Forum
Kodi boxes not seeing samba shares - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: Kodi boxes not seeing samba shares (/showthread.php?tid=366486)



Kodi boxes not seeing samba shares - jrubenol - 2022-01-13

Hi All -

I have a samba share set up on my Synology drive. I know the share is working because I can access the share on both Linux file browsers (smb://.....), and in Windows Explorer. Yet, in Kodi, I'm not seeing it at all.

When I go to Files -> Add Video Source -> Browse -> Windows Network (SMB) there is no source listed. Additionally if I try to manually enter the share it comes back with an error about share not existing.

This is happening on my laptop (Manjaro), two RPis, and a Shield.

Thanks in advance.


RE: Kodi boxes not seeing samba shares - DarrenHill - 2022-01-13

Browse only works with SMB1, which these days is very much not recommended and is almost certainly switched off.

What you should do is use the add network location option (the bottom one on the add sources list) and in there select SMB, then manually enter the IP address of the Synology plus any user/password requirements.

Doing it that way with explicit entry of the source IP address should get you going.


RE: Kodi boxes not seeing samba shares - oldtvwatcher - 2022-01-13

If you just want a quick (but insecure) fix there is one here.  If you use that, make absolutely certain that your firewall (probably in your router) doesn't allow access to the server or to any of your Kodi boxes from outside your local network.

A better fix would be to configure your Synology to use SMB3 protocol (if it isn't configured that way already) and/or follow DarrenHill's advice.


This forum uses Lukasz Tkacz MyBB addons.