Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



- ashlar - 2009-02-23

THX-UltraII Wrote:Is it also possible to auto-exit XBMC when I selected a movie and my external player starts running?
You could with an automation software, such as EventGhost, but why would you want to do that?


- THX-UltraII - 2009-02-23

ashlar Wrote:You could with an automation software, such as EventGhost, but why would you want to do that?

I assume XBMC sucks up a little RAM and CPU when idle/not active.


- zag - 2009-02-23

THX-UltraII Wrote:I assume XBMC sucks up a little RAM and CPU when idle/not active.

Doubt it will use enough to make any difference to the playback experience.


- ashlar - 2009-02-23

THX-UltraII Wrote:I assume XBMC sucks up a little RAM and CPU when idle/not active.
I could be mistaken, but when the external player starts XBMC should go into "freeze" mode, using 0% CPU. Memory is a different beast. But with the pretty much standard 2GB... hardly a problem.


- BlueSpam - 2009-02-24

ashlar Wrote:I could be mistaken, but when the external player starts XBMC should go into "freeze" mode, using 0% CPU. Memory is a different beast. But with the pretty much standard 2GB... hardly a problem.

My experience has also shown that XBMC still running in the background does suck enough resources on my machine to slow down the external player. It didn't used to be this way in the earlier external player builds, but I installed the latest build last week and still see stuttering if I don't kill XBMC. I use EventGhost to kill XBMC when it detects MPC-HC start (and also switch my remote key bindings to MPC-HC), and restart XBMC after MPC-HC closes (and also switch my key bindings back to XBMC).


- rimmi2002 - 2009-02-26

Hi I am a complete noob to this external player setup. Read through the thread and just wanted to know if I have it right.

1) I copy and paste the settings listed in the first post to my advancedsettings.xml.

2) Download mplayer from this site (was confused by the downloads avaliable on the mplayer main site). They were all out dated and had no *.exe file in them. So I found this downloads for mplayer.

3) Change advancedsettings.xml to point to the directory with the external player.

4) Then things should work with files playing in external player? or do I have to do anything else?


PowerDVD ... booo - MrBasset - 2009-02-26

Hi,

Has anyone had any luck with external player and PowerDVD 7.3?

I'm using it for playback of Blu Ray from disk and whilst PowerDVD starts up fine but I'm having the following problems:
  • it seems to start windowed and then switch to fullscreen (I've tried passing /fullscreen as an arg and also setting the "start fullscreen" option)
  • it doesn't automatically play the disk and no matter what I do it won't actually start playing the disk

Wondered what others had in their advancedsettings.xml?

Cheers,

P.S. I'm mulling on changing out PowerDVD for Zoomplayer or similar, but I'm guessing that DRM is going to make that a lot of fun!


- bobrap - 2009-02-26

Anyone using TotalMedia Theatre successfully? Not working for me, but, I'm not the sharpest knife in the drawer.:confused2:


- ashlar - 2009-02-27

Are there any updates or projected dates as for when this will go back into SVN?


External player not really working like it should :/ - zoso1977 - 2009-02-28

Hi I´ve been trying alot to get the external player option to works but in vain Sad
This is what I do:

I create a file called advancedsettings.xml
The file contains the following:

Code:
<advancedsettings>
<video>
  <defaultplayer>externalplayer</defaultplayer>
</video>
<externalplayer>
  <filename>C:\Program Files\Zoom Player\zplayer.exe</filename>
  <args>/F /Q /LOCKFS /MOUSEOFF</args>
  <forceontop>true</forceontop>
  <hidexbmc>true</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>

I am running this on Windows XP and I place the advancedsettings.xml file in this directory: c:\Documents and Settings\myname\Application Data\XBMC\userdata\advancedsettings.xml

Then I start XBMC and try to start a movie but it seems that xbmc still uses the internal player, or at least that´s what i suspect. None of the hotkeys from zoomplayer work and all the hotkeys of the internal player work so therefor I assume that it doesn´t start zoomplayer. Besides the movie doesn´t play so smoothly as in zoomplayer.

Am I perhaps doing something wrong or are there some settings I need to adjust?

Regards,
Óskar G.


- SlaveUnit - 2009-02-28

Do you have the external player build?


- zoso1977 - 2009-02-28

Do you then mean a special build of xbmc? then I probably don´t have that. I have the default edition which I downloaded from xbmc.org
Are there perhaps binaries available with the external player build ?


- zoso1977 - 2009-02-28

Do you then mean a special build of xbmc? then I probably don´t have that. I have the default edition which I downloaded from xbmc.org
Are there perhaps binaries available with the external player build ?


- zoso1977 - 2009-02-28

I installed now XBMCSetup-Rev17788-jester-ext.exe
Is that the right build ?


- zoso1977 - 2009-02-28

I copied the advancedsettings.xml file to the userdata directory under c:\program files\xbmc and then it all works. Yess I feel like I´m in heaven Smile


This forum uses Lukasz Tkacz MyBB addons.