Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



- Choix - 2009-03-08

I am wondering if anyone has a solution for using Media Player Classic Homecinema.

I am currently using Jesters latest build and the x64 version of MPCHC but when I go to open a file I just get this error:

Image

My advancedsettings.xml are:

Code:
<advancedsettings>
<video>
  <defaultplayer>externalplayer</defaultplayer>
</video>
<externalplayer>
  <filename>c:\program files\mpchd\mplayerc64.exe</filename>
  <args>-fs</args>
  <forceontop>false</forceontop>
  <hidexbmc>true</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>

I can't see what I have done wrong here, any help would be appreciated. Huh


- moby-uk - 2009-03-08

Choix Wrote:I am wondering if anyone has a solution for using Media Player Classic Homecinema.
I can't see what I have done wrong here, any help would be appreciated. Huh
The image quite clearly shows a list of valid switches (args), do you see "-fs" in there anywhere..? Change the "-fs" to "/fullscreen" in your advancedsettings (and probably your hidexbmc to false, you shouldn't need to do this)


- Choix - 2009-03-08

moby-uk Wrote:The image quite clearly shows a list of valid switches (args), do you see "-fs" in there anywhere..? Change the "-fs" to "/fullscreen" in your advancedsettings (and probably your hidexbmc to false, you shouldn't need to do this)

Thanks that worked, sorry for my newbieness I have only just started playing around with XBMC. Laugh

Anyway I have another problem now, no matter what settings I use in the advancedsettings.xml or in MPCHC the video will play but under the XBMC screen.

I have tried forceontop true/false same with hidexbmc. Also in the player I have had it set to start in full screen or not and have the player set to "Always on top" nothing works. Well actually that isn't true it does seem to work like 1/10 tries, which just makes it even more weird.

Does anyone have any ideas?


- LaTropa64 - 2009-03-09

Choix Wrote:Thanks that worked, sorry for my newbieness I have only just started playing around with XBMC. Laugh

Anyway I have another problem now, no matter what settings I use in the advancedsettings.xml or in MPCHC the video will play but under the XBMC screen.

I have tried forceontop true/false same with hidexbmc. Also in the player I have had it set to start in full screen or not and have the player set to "Always on top" nothing works. Well actually that isn't true it does seem to work like 1/10 tries, which just makes it even more weird.

Does anyone have any ideas?

I'm using MPC-HC and it seems to work with this in my advanced settings:

Code:
<advancedsettings>
      <video>
      <defaultplayer>externalplayer</defaultplayer>
    </video>
    <externalplayer>
      <filename>C:\Program Files (x86)\MPC HomeCinema\mplayerc.exe</filename>
      <args>/fullscreen /play /close</args>
      <forceontop>false</forceontop>
      <hideconsole>false</hideconsole>
      <hidecursor>false</hidecursor>
    </externalplayer>
    <videoextensions>
      <add>.hdmov</add>
    </videoextensions>
</advancedsettings>

The only issue I've run into is it will occasionally not return focus to XBMC when it's done playing. XBMC is always showing when you exit MPC-HC, but it just doesn't always have the focus so I have to hit Alt+Tab to get it back.


- Choix - 2009-03-09

LaTropa64 Wrote:I'm using MPC-HC and it seems to work with this in my advanced settings:

The only issue I've run into is it will occasionally not return focus to XBMC when it's done playing. XBMC is always showing when you exit MPC-HC, but it just doesn't always have the focus so I have to hit Alt+Tab to get it back.

Well I tried your advancedsettings.xml and it still didn't work. It's weird it seems to work for the 1st and sometimes even the 2nd video I play after starting XBMC up but not afterwards.

Could it be because I am just testing and my way of closing down MPCHC (Alt+X) is messing it up somehow? How do you close down your videos before they reach the end?


- LaTropa64 - 2009-03-09

Choix Wrote:Well I tried your advancedsettings.xml and it still didn't work. It's weird it seems to work for the 1st and sometimes even the 2nd video I play after starting XBMC up but not afterwards.

Could it be because I am just testing and my way of closing down MPCHC (Alt+X) is messing it up somehow? How do you close down your videos before they reach the end?

I usually use Ctrl+F4 to close MPC. I'm just playing with it on my computer though... I haven't played with it all that much but it seems I've stopped and started more than a couple videos in a row and it worked okay.


- Choix - 2009-03-09

LaTropa64 Wrote:I usually use Ctrl+F4 to close MPC. I'm just playing with it on my computer though... I haven't played with it all that much but it seems I've stopped and started more than a couple videos in a row and it worked okay.

Alt+F4 changes nothing for me, well thanks anyway. One last question are you using Vista, XP or a Linux OS?

If you are using Vista then I guess I am all out of ideas, if anyone else has any more input I would be glad to hear it but for now my HTPC is on hold since I have no other options for playing 1080p content. Sad

Perhaps there is another more effective method of minimizing XBMC automatically that I am not aware of?


- LaTropa64 - 2009-03-09

Vista. I played with it some more, this time in fullscreen, and ran into the problem you were having. Changing <forceontop> to true worked every time.


- moby-uk - 2009-03-09

Choix Wrote:Alt+F4 changes nothing for me, well thanks anyway. One last question are you using Vista, XP or a Linux OS?

If you are using Vista then I guess I am all out of ideas, if anyone else has any more input I would be glad to hear it but for now my HTPC is on hold since I have no other options for playing 1080p content. Sad

Perhaps there is another more effective method of minimizing XBMC automatically that I am not aware of?

Firstly, sorry if I was curt earlier.

Secondly, do you definitely have the right build, you should have XBMCSetup-Rev17788-jester-ext.exe (only Jester's builds with -ext include my latest patch and are any good for externalplayer)

If you definitely have the right build then ...

Try setting MPC-HC to be always on top (View -> On Top -> Always)

If you have Intel graphics, try starting XBMC with the "XBMC (windowed)" shortcut and changing the resolution in settings->screen to match the physical resolution of your display

If you also have slow hardware, try adding <startuptime>10000</startuptime> inside the <externalplayer/> node; his gives the externalplayer a little more time (10s instead of the default 5s) to get it's window ontop before locking the XBMC graphicscontext. i.e.
Code:
<externalplayer>
  <filename>C:\Program Files (x86)\MPC HomeCinema\mplayerc.exe</filename
  <args>/fullscreen /play /close</args>
  ...
  <startuptime>10000</startuptime>
</externalplayer>



- ashlar - 2009-03-09

I kind of hate to be insistent, but I have to ask one more time: why is the awesome work done by moby-uk kept from SVN? There is a feature half broken and somebody coded all the fixes needed, why not merge them?

Again, I do not use the external player myself, but for a lot of people this is a deal breaker in their view of XBMC.


- Choix - 2009-03-09

moby-uk Wrote:Firstly, sorry if I was curt earlier.

Secondly, do you definitely have the right build, you should have XBMCSetup-Rev17788-jester-ext.exe (only Jester's builds with -ext include my latest patch and are any good for externalplayer)

If you definitely have the right build then ...

Try setting MPC-HC to be always on top (View -> On Top -> Always)

If you have Intel graphics, try starting XBMC with the "XBMC (windowed)" shortcut and changing the resolution in settings->screen to match the physical resolution of your display

If you also have slow hardware, try adding <startuptime>10000</startuptime> inside the <externalplayer/> node; his gives the externalplayer a little more time (10s instead of the default 5s) to get it's window ontop before locking the XBMC graphicscontext. i.e.
Code:
<externalplayer>
  <filename>C:\Program Files (x86)\MPC HomeCinema\mplayerc.exe</filename
  <args>/fullscreen /play /close</args>
  ...
  <startuptime>10000</startuptime>
</externalplayer>

Thanks moby it turns out I was using the wrong build, I was using "XBMCSetup-Rev18257-jester.exe". Blush

Anyway it's all working here now, thanks for your patience.


- malkav30 - 2009-03-09

hi
first of all thanks for this great tool. it is very handy for me.
i have a little problem though (the same as steak32 in fact : ac3 passtru on spdif working like a charm in mediaplayer classic alone, no sound when using the same configuration with xbmc+external player).

I tried to look to the patch diff on trac but I don't know anything at xbmc architecture, so it is pretty obscure to me. could it be something in PlayerCoreFactory.cpp (the push-back stuff for example) ? I would like to help and try some stuff but I don't really know where to begin.

any help/explanation much appreciated, thank you for your time


- moby-uk - 2009-03-09

malkav30 Wrote:hi
first of all thanks for this great tool. it is very handy for me.
i have a little problem though (the same as steak32 in fact : ac3 passtru on spdif working like a charm in mediaplayer classic alone, no sound when using the same configuration with xbmc+external player).

I tried to look to the patch diff on trac but I don't know anything at xbmc architecture, so it is pretty obscure to me. could it be something in PlayerCoreFactory.cpp (the push-back stuff for example) ? I would like to help and try some stuff but I don't really know where to begin.

any help/explanation much appreciated, thank you for your time

My latest rev of the patch includes code to ensure that XBMC closes all audio devices before starting the externalplayer. steak32 tested this for me and reported it worked for him. If you got the tools to DIY then pick-up the latest file from http://trac.xbmc.org/ticket/5672 and you can build this yourself, or I can PM you a link to a build.


- taxigps - 2009-03-10

Some user feedback can't use hard decoder when use externalplayer to play moive, but when run the player alone it can do hard decode.


- THX-UltraII - 2009-03-10

I have the exact same problem involding audio silence as mentioned earlier. I use MPC-HC as external player with Kernel Streaming. When playing content directly with MPC-HC without using XBMC (latest Jester -ext build from 26-02) audio is fine. Starting a movie in MPC-HC from XBMC it goes wrong => no sound.

Will Jester build a new version with your patch soon Moby?


This forum uses Lukasz Tkacz MyBB addons.