Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



- jondr13 - 2009-06-08

tiben20 Wrote:I made an application right for the dvd mounting
Image
You have to check the enabled check box.
The Screen capture of the app is exactly how you have to set it for making it work

Your external player settings have to be like this
Code:
<externalplayer>
  <filename>C:\XbmcExternalPlayerController.exe</filename>
  <args></args>
  <forceontop>false</forceontop>
  <hidexbmc>true</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
You have to save the settings before testing the dvdplayer.


The unmounting thing dont work but its not really needed.
Download link here:
XbmcExternalPlayerController.rar

Dont bother with the settings panel its only for testing an external player. Im not done with coding this part.

If some people really liked it ill continue developing it.

Will this enable me to mount my ISO files to Virtual Clone Drive and use TotalMedia Theatre as my external player?

Im able to do that now, only problem is, XBMC is not "hiding" and TMT is playing behind it.

Thanks


- ashlar - 2009-06-08

tiben20, your work is much appreciated. Thank you. Will try this.

Hoping to hear something soon from moby-uk. What he was working behind curtains was awesome.


- tiben20 - 2009-06-08

jordan actually i made this program for the problem you were facing with mounting the iso you only need to replace the daemon tools path.
and replace the arguments for /d=0.
The way the external player is working.
1.its hiding the cursor
2.its making xbmc nottopmost
3.its hiding xbmc
4. launching the process and wait for him to be done
5. reversing step 1 2 and 3

The way you were trying to make it work with a .bat
Right when the .bat was done launching tmt3 xbmc was trying to make xbmc topmost again.
The difference with my application. Its only closing when the external player is closed. So you should have no problem using tmt3 with this. Im also able to make it catch keyboard input for customizing your control over tmt3.


- jondr13 - 2009-06-08

tiben20 Wrote:jordan actually i made this program for the problem you were facing with mounting the iso you only need to replace the daemon tools path.
and replace the arguments for /d=0.
The way the external player is working.
1.its hiding the cursor
2.its making xbmc nottopmost
3.its hiding xbmc
4. launching the process and wait for him to be done
5. reversing step 1 2 and 3

The way you were trying to make it work with a .bat
Right when the .bat was done launching tmt3 xbmc was trying to make xbmc topmost again.
The difference with my application. Its only closing when the external player is closed. So you should have no problem using tmt3 with this. Im also able to make it catch keyboard input for customizing your control over tmt3.

I will have to check this out when I get home. Im really hoping this will fix my problem with TMT3 playing behind XBMC!

Thanks


- tiben20 - 2009-06-08

i just uploaded a new version with more information and fixed some little bugs
XbmcExternalPlayerController_0.1.rar - 0.03MB
had to take zshare mediafire are under maintenance


- jondr13 - 2009-06-08

tiben20 Wrote:i just uploaded a new version with more information and fixed some little bugs
XbmcExternalPlayerController_0.1.rar - 0.03MB
had to take zshare mediafire are under maintenance

tiben20

My advancedsettings.xml <hidexbmc> is set to true and it still does not hide and TMT3 is playing behind it. Just want to confirm that with your app, XBMC will hide and TMT3 will play on top, correct?

Thanks and looking forward to trying this since this is the only road block Im having right now with using the external player.

EDIT: Im home now and tried it just by using the test, and it worked. BUT....here is my problem: after I save the settings, they DONT SAVE! I can click Save, then reopen up the application and it has reverted back to the original settings. Is this supposed to happen??
Not only that, Im having a problem setting Virtual Clone Drive as the DVD Mounting Tool under the Settings tab....it reverts back to Daemon ToolsHuh?


- tiben20 - 2009-06-08

my application dont touch anything in the xbmc config.
The controller i did have is own configuration the config are in the XbmcExternalPlayerController.exe.config file.


- tiben20 - 2009-06-08

yeah your right the mounting tools dont save
ill fix this right away


- jondr13 - 2009-06-08

tiben20 Wrote:yeah your right the mounting tools dont save
ill fix this right away

Thanks.

Also, just to confirm, I should be setting everything under BOTH the Settings and Mounting ISO tabs correct??


- tiben20 - 2009-06-08

http://www.mediafire.com/?dwjmyymwoto
the 0.12
yeah it was a little misstake fixed now


- jondr13 - 2009-06-08

tiben20 Wrote:http://www.mediafire.com/?dwjmyymwoto
the 0.12
yeah it was a little misstake fixed now

Ok, just downloaded it and tried it. The Mounting ISO tab is staying saved, but the Setting tab is not. I should be setting that as well correct....to hide XBMC, etcHuh


- tiben20 - 2009-06-09

The settings tab is useless this is just a project i started and i turned it into the iso thing you wanted ill make it easier for you
http://www.mediafire.com/?sharekey=ce5b32c73c2e00ab75a4fc82078ae6c8edb5919158f5fe5ece018c8114394287
XbmcExternalPlayerController0.03.rar
the advanced settings have to be set this way
Code:
<externalplayer>
  <filename>C:\XbmcExternalPlayerController.exe</filename>
  <args></args>
  <forceontop>false</forceontop>
  <hidexbmc>true</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
XbmcExternalPlayerController.exe is the external player.

If your launching it with an argument its launching the process instead of showing the settings window.
If your taking a look to your xbmc.log you should see executew32 c:\pathto\XbmcExternalPlayerController.exe "c:\pathto.iso"


- jondr13 - 2009-06-09

tiben20 Wrote:The settings tab is useless this is just a project i started and i turned it into the iso thing you wanted ill make it easier for you
http://www.mediafire.com/?sharekey=ce5b32c73c2e00ab75a4fc82078ae6c8edb5919158f5fe5ece018c8114394287
XbmcExternalPlayerController0.03.rar
the advanced settings have to be set this way
Code:
<externalplayer>
  <filename>C:\XbmcExternalPlayerController.exe</filename>
  <args></args>
  <forceontop>false</forceontop>
  <hidexbmc>true</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
XbmcExternalPlayerController.exe is the external player.

If your launching it with an argument its launching the process instead of showing the settings window.
If your taking a look to your xbmc.log you should see executew32 c:\pathto\XbmcExternalPlayerController.exe "c:\pathto.iso"

Edit: I sent you some PM info


- tatoosh - 2009-06-11

what did i wrong - my xbmc freeze by opening external player:

my advancedsettings.xml config:
Code:
<advancedsettings>
<video>
  <defaultplayer>externalplayer</defaultplayer>
</video>
<externalplayer>
  <filename>C:\Portable\MPHC\mplayerc.exe</filename>
  <args>-fs</args>
  <forceontop>true</forceontop>
  <hidexbmc>true</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>
used the newest svn XBMC build.

please help i am frustrated.


- mark007 - 2009-06-11

Hi all,

I am using external player (media player classic homecinema latest version) and see in the latest xbmc svn version that there is a new popup box shown when an external player is open (prompting to click ok to terminate player).

There are two problems
1) I cannot see an OK button anyhere.
2) When I alt-tab from my player back to xbmc or let xbmc get control at all while my external player is open, I can never get my external player to have focus again. Even if I minimize xbmc, clicking the taskbar icon on external player doesn't give me a window. I am in Windows 7 RC and hovering on media player classic icon in taskbar shows the video playing, but clicking it does nothing. xbmc seems to be having a strange effect on it, but even after exiting xbmc, the player will still act in this way. Maybe the external player is being called in a strange manner as both xbmc and player act strangely, like one is blocked waiting for the other. xbmc shouldn't block waiting for the player IMO, instead have a seperate thread that blocks waiting for the player to exit. This will let xbmc be accessible / possible to interact with while player is active.

My settings are

<advancedsettings>
<video>
<defaultplayer>externalplayer</defaultplayer>
<defaultdvdplayer>externalplayer</defaultdvdplayer>
</video>
<externalplayer>
<filename>c:\windows\system32\cmd.exe</filename>
<args>/C E:\MovieStarter\starter.bat</args>
<forceontop>false</forceontop>
<hidexbmc>false</hidexbmc>
<hideconsole>true</hideconsole>
<hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>


This forum uses Lukasz Tkacz MyBB addons.