Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



- kricker - 2009-07-19

rflores2323 Wrote:yes this is the whole point for the coreplayerfactory.xml. read the wiki to find our more info.
Care to link to this? I am interested in this as well, but I am having problems finding anything called coreplayerfactory.xml in the XBMC online manual.

EDIT:
Found it. It's actually called playercorefactory.xml. Wink


- moby-uk - 2009-07-20

mark007 Wrote:Wow I will try it when home from Work. Thanks alot, would be fantastic to get a smooth external player experience. At the moment this isn't the case for alot of people. Cheers for that.

DAMN: Installing this build removed my library, telling it to scan for new content still leaves me with a movies dir that says theres nothing there..... didn't expect that lol

What version were you using before? I have changed anything to do with the library in my builds.


- >>X<< - 2009-07-20

mark007 Wrote:Hi guys,

I am using build 21714 and have just transferred my settings from advancedsettings.xml to the new xml file thats needed.

I start mpc-hc from a .bat file which does some other stuff. I can't however get mpc-hc to start on top of xbmc. I can hear it playing in the background, but xbmc always steals the shows and stays above it. It worked in the past with this line in my bat file.

start "" "C:\Program Files (x86)\MPC\mplayerc.exe" %1 "/play" "/close" "/fullscreen" "/fixedsize" "1920,1080"

I have tried all of xbmc's xml settings like hidexbmc... but none of these work for me. This is turning out to be a nightmare. I could go down the route of killing the xbmc process with my .bat file... but its not a very nice way of doing things.

Any of you got mpc-hc going on top of the latest xbmc, using a .bat file.

Aswell as this, earlier builds, the hide cursor used to move the mouse cursor to the bottom right hand corner of the screen. This doesn't happen now. If this is brought back, it would be great to be able to choose where its put, because bottom right of the screen does two things for me, shows the Windows 7 Desktop... and when mpc-hc starts, it shows the fullscreen GUI (activated when mouse moves to bottom of screen).

Getting player on top is most important though.

Why not use Zoom Player with MPC-HC standalone filter as zoom allows you to configure all those options in its settings then all xbmc needs to do is call the player

I use zoom with advancedsettings method and set all options in zoom not advancedsettings, full screen, always on top, move cursor etc don't even bother hiding XBMC and it all looks seamless cant tell the difference from using XBMC itself


- moby-uk - 2009-07-20

pcjco Wrote:moby-uk, can you have a look at the modification I proposed in #633. And if you think it's useful for using externalplayer from python, could you insert it in your trac system.

Thanks.

Probably useful but doesn't really go far enough, there can now be multiple different externalplayers so that fixed list only gets you to the first one of them.


- moby-uk - 2009-07-20

mark007 Wrote:Hi guys,

I am using build 21714 and have just transferred my settings from advancedsettings.xml to the new xml file thats needed.

I start mpc-hc from a .bat file which does some other stuff. I can't however get mpc-hc to start on top of xbmc. I can hear it playing in the background, but xbmc always steals the shows and stays above it. It worked in the past with this line in my bat file.

start "" "C:\Program Files (x86)\MPC\mplayerc.exe" %1 "/play" "/close" "/fullscreen" "/fixedsize" "1920,1080"

I have tried all of xbmc's xml settings like hidexbmc... but none of these work for me. This is turning out to be a nightmare. I could go down the route of killing the xbmc process with my .bat file... but its not a very nice way of doing things.

Any of you got mpc-hc going on top of the latest xbmc, using a .bat file.

Aswell as this, earlier builds, the hide cursor used to move the mouse cursor to the bottom right hand corner of the screen. This doesn't happen now. If this is brought back, it would be great to be able to choose where its put, because bottom right of the screen does two things for me, shows the Windows 7 Desktop... and when mpc-hc starts, it shows the fullscreen GUI (activated when mouse moves to bottom of screen).

Getting player on top is most important though.

I only just noticed the start, why do you have that in there? That'll mean your initial batch file returns almost immediately leaving MPC-HC running, XBMC doesn't know this and because the batch process ended it assumed playback has finished and brings its window back to the top. Get rid of the start "" and all should be well.


- moby-uk - 2009-07-21

Another new build (21816) in here.

In this build, if the launched application ends within a couple of seconds, but without error, it's assumed to be a launcher process and XBMC will not continue until you manually dismiss the dialog. You can force this by adding <islauncher>true</islauncher> inside the <player/> element and disable it by adding <islauncher>false</islauncher>

Also new, a <warpcursor/> option, which can have the values
  • topleft
  • topright
  • bottomright
  • bottomleft
  • center
Add it in inside the <player/> element, e.g. <warpcursor>topright</warpcursor>

<hidecursor>true</hidecursor> is deprecated but equivalent to <warpcursor>bottomright</warpcursor>


- zag - 2009-07-21

Works great and returns to xbmc much quicker.

Can this be integrated in the main svn at some point so I don't have to keep checking this thread.


- moby-uk - 2009-07-22

zag2me Wrote:Can this be integrated in the main svn at some point so I don't have to keep checking this thread.

That's the intention but I'm trying to get something stable first; I can't commit to SVN and I'm trying to avoid raising lots and lots of trac tickets for incremental changes.


- spiff - 2009-07-22

actually i prefer many small rather than one big


- moby-uk - 2009-07-22

spiff Wrote:actually i prefer many small rather than one big

OK, noted, but I'm sure you don't want many small that don't really work right Smile


- spiff - 2009-07-22

correct Smile


- cloverfield - 2009-07-22

I use XBMC (Windows) 9.04.1 with this advancedconfig.xml and ffdshow/ac3filter

Code:
<advancedsettings>
<video>
  <defaultplayer>externalplayer</defaultplayer>
</video>
<audio>
  <defaultplayer>externalplayer</defaultplayer>
</audio>
<externalplayer>
  <filename>E:\Documents\Programs\MPC Home Cinema\mplayerc.exe</filename>
  <args>/monitor 2 /fullscreen /close</args>
  <forceontop>true</forceontop>
  <hidexbmc>false</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>

I loaded up a WMV (VC-1) 1080p file with this config, mpc-hc loads up ok.
XBMC play: bad, audio stutters every 3 seconds and repeating bits of audio.
mpc-hc play: seems fine, no stutters (and lower cpu usage).

I loaded up a MKV (AVC) 1080p file.
xbmc play: ok
mpc-hc play: video stutters.

I loaded up a MKV tv serie (AVC) 1080p.
xbmc play: same as first: stutters and repeats.
mpc-hc play: crash of mpc-hc (after a long loading).

What do I do? I can't seem to find the problem.
And also... how to easily switch back to xbmc (i have the iphone remote). Stopping (with . on my keyboad) wont return to xbmc Sad


- moby-uk - 2009-07-24

cloverfield Wrote:I use XBMC (Windows) 9.04.1 with this advancedconfig.xml and ffdshow/ac3filter

I loaded up a WMV (VC-1) 1080p file with this config, mpc-hc loads up ok.
XBMC play: bad, audio stutters every 3 seconds and repeating bits of audio.
mpc-hc play: seems fine, no stutters (and lower cpu usage).

I loaded up a MKV (AVC) 1080p file.
xbmc play: ok
mpc-hc play: video stutters.

I loaded up a MKV tv serie (AVC) 1080p.
xbmc play: same as first: stutters and repeats.
mpc-hc play: crash of mpc-hc (after a long loading).

What do I do? I can't seem to find the problem.
And also... how to easily switch back to xbmc (i have the iphone remote). Stopping (with . on my keyboad) wont return to xbmc Sad

I can't speak to whether the stuttering you're seeing is down to hardware, encoding or playback but I can suggest you try a later XBMC build, if you try my latest build there are some external player changes in there that should make the process of launching the external player work better (even if it doesn't fix the stuttering problem).

You'll need to create a new file called playercorefactory.xml (in the same folder as the advancedsettings.xml you already have), the following content will match the setup you currently have

Code:
<playercorefactory>
  <players>
    <player name="externalplayer" type="ExternalPlayer" audio="true" video="true">
      <filename>E:\Documents\Programs\MPC Home Cinema\mplayerc.exe</filename>
      <args>/monitor 2 /fullscreen /close</args>
    </player>
  </players>
</playercorefactory>



PowerDVD Launching - ThickHead - 2009-07-25

Hi,
Been following this thread and now I have something that works pretty good for launching PowerDVD to run DVD's and ISO files... and they play stutter free!

I use mainstream SVN builds, not moby-uk's unique ones' yet, so hopefully his added features will make it work even better. First, This is my playercorefactory.xml

<playercorefactory>
<players>
<player name="PowerDVD1" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Documents and Settings\Don\Application Data\XBMC\userdata\PDVD_ISO.exe</filename>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<hidecursor>false</hidecursor>
</player>
<player name="PowerDVD2" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Documents and Settings\Don\Application Data\XBMC\userdata\PDVD_DVD.exe</filename>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<hidecursor>false</hidecursor>
</player>
</players>
<rules action="prepend">
<rule dvd="true" player="PowerDVD2" />
<rule dvdimage="true" player="PowerDVD1" />
</rules>
</playercorefactory>

This calls a different batch file based on whether chosing the DVD drive or a DVDImage. The batches for each case are compiled using the freeware utility "Bat_to_Exe_Converter" available here www.f2ko.de

Here's PDVD_DVD.bat...

@echo OFF
taskkill /F /IM XBMC.EXE
START /MAX /WAIT C:\PROGRA~1\CYBERL~1\POWERDVD\PowerDVD.exe L:
"C:\Program Files\XBMC\XBMC.exe" -fs
EXIT

...and PDVD_ISO.bat which uses Daemon Tools Lite to mount the image

@echo OFF
START /MIN /WAIT C:\PROGRA~1\DAEMON~1\daemon.exe -mount 0,%1
taskkill /F /IM XBMC.EXE
START /MAX /WAIT C:\PROGRA~1\CYBERL~1\POWERDVD\PowerDVD.exe M:
START /MIN /WAIT C:\PROGRA~1\DAEMON~1\daemon.exe -unmount 0
"C:\Program Files\XBMC\XBMC.exe" -fs
EXIT

I found that killing XBMC was how to get stutter free playback. The only thing I would like to improve is the transitions. This has about 5 secs of the windows desktop showing before the movie starts to play, and a few secs again after closing PowerDVD and loading XBMC. Hope this helps.

ThickHead


- der.supertusse - 2009-07-25

Sorry to bump this up, but does anyone have any idea with regards to passing the .rar to the external player?

der.supertusse Wrote:Hello

I've got XBMC set up properly to play videos with Zoom Player. However, all my video files are in RAR'ed format, so I installed the RARFileSource directshow plugin to enable Zoom Player to play without unrar'ing, like XBMC.

My problem now is this: How do I get XBMC to pass the .rar file to the external player? I've added .rar as a valid video filetype extension, and disabled transparent RAR archives. Though still, when I navigate to the rar-file I want to send to zoom player, it doesn't work.

- Selecting the rar file will only open it for browsing (showing the .avi inside) in the xbmc browser, and selecting this file will fire up zoom player, which will obviously fail
- Right clicking on the rar file and selecting play gives the same error

Here's an example error message trying to play the rar-file. It is the same message I get when trying to play the .avi inside the .rar (I'm accessing a network share via drive letter Y: instead of using XBMC's samba client, as the resulting filenames passed to Zoom Player didn't work):

Unable to play [//y%3a%5cVideo%5cIncoming%5cTV%5cDark%2eBlue%2eS01E01%2eHDTV%2eXviD%2dSYS%5cdark%2eblue%2e101%2ehdtv%2exvid%2dsys%2erar/dark.blue.101.hdtv.xvid-sys.avi]
This may be due to a corrupt file, missing filters, filter conflicts, or hardware rel...

Here's hoping someone knows how to pass the .rar file to the external player, or can add the capability to XBMC.

Supertusse.



This forum uses Lukasz Tkacz MyBB addons.