Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



My desured defaukt is anything but... - GeekInOhio - 2009-08-08

All,

I am running XBMC v9.04.1 on Windows XP Home.

All of my movies are ripped to ISO format, and whilst the internal player will play them, it does so in a rather hurkey-jerkey fashion due to the age of my hardware. VLC on the other hand does a lovely job, so I would like to make it my default player.

Using the instructions in this thread, I created an advancedsettings.xml and placed it in my userdata directory. Contents below:

Code:
<advancedsettings>
<video>
<defaultplayer>externalplayer</defaultplayer>
</video>
<externalplayer>
<filename>C:\Program Files\VideoLAN\VLC\vlc.exe</filename>
<args>--play-and-exit --video-on-top --fullscreen --extraintf=rc --rc-host=localhost:1234 -rc-quiet --rc-shows</args>
<forceontop>false</forceontop>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>

(The extra arguments are in relation to my remote control)

My problem is that when I am in the Movie menu, and I select a move, it is still playing in the XBMC player rather than VLC. I know that I can select to play it in VLC through the context menu, but I'd really like to make VLC the true defualt player. (This thing needs to be wife and kid friendly.)

Am I missing something, or is this functioning as designed?


- der.supertusse - 2009-08-08

GeekInOhio Wrote:All,

[...]

Using the instructions in this thread, I created an advancedsettings.xml and placed it in my userdata directory. Contents below:

[...]

You'll need a playercorefactory.xml aswell (or instead? - I dunno, but you'll need one).

See http://www.xbmc.org/wiki/?title=HOW-TO_use_an_external_player

Tusse


- moby-uk - 2009-08-08

der.supertusse Wrote:You'll need a playercorefactory.xml aswell (or instead? - I dunno, but you'll need one).

See http://www.xbmc.org/wiki/?title=HOW-TO_use_an_external_player

Tusse

For 9.04 it's advancedsettings.xml not playercorefactory.xml, but a debug log would help


- GeekInOhio - 2009-08-08

moby-uk Wrote:For 9.04 it's advancedsettings.xml not playercorefactory.xml, but a debug log would help

http://pastebin.com/m6c49de9a

I appreciate you taking a look!


- torva - 2009-08-09

Dont know what im doning wrong, but when im trying to play with external player in xbmc nothing hapens? Ive put the advancedsettings.xml file in the user/appdata/roming/xbmc folder and pasted in this code:

Code:
<advancedsettings>
<video>
  <defaultplayer>externalplayer</defaultplayer>
</video>
<externalplayer>
  <filename>c:\Program\MPC HomeCinema\mplayerc.exe</filename>
  <args></args>
  <forceontop>false</forceontop>
  <hidexbmc>true</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>

What have I done wrong? Ive put the codes in via windows txt program.


- moby-uk - 2009-08-09

GeekInOhio Wrote:http://pastebin.com/m6c49de9a

I appreciate you taking a look!

I didn't pick up on the fact they were ISOs, if you want ISO to play with an externalplayer by default you'll need to add

<defaultdvdplayer>externalplayer</defaultdvdplayer>

to your existing <defaultplayer> setting.


Multiple player launcher script - skaymakca - 2009-08-10

I've written a script with hopefully lots of functionality. I created a new thread for it:

http://www.xbmc.org/forum/showpost.php?p=384325&postcount=1


- GeekInOhio - 2009-08-11

moby-uk Wrote:I didn't pick up on the fact they were ISOs, if you want ISO to play with an externalplayer by default you'll need to add

<defaultdvdplayer>externalplayer</defaultdvdplayer>

to your existing <defaultplayer> setting.

I was just thinking about that on the drive home today. Made the change, works like a charm!

Thanks!


- torva - 2009-08-16

torva Wrote:Dont know what im doning wrong, but when im trying to play with external player in xbmc nothing hapens? Ive put the advancedsettings.xml file in the user/appdata/roming/xbmc folder and pasted in this code:

Code:
<advancedsettings>
<video>
  <defaultplayer>externalplayer</defaultplayer>
</video>
<externalplayer>
  <filename>c:\Program\MPC HomeCinema\mplayerc.exe</filename>
  <args></args>
  <forceontop>false</forceontop>
  <hidexbmc>true</hidexbmc>
  <hideconsole>false</hideconsole>
  <hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>

What have I done wrong? Ive put the codes in via windows txt program.

Can someone please help me with this? Really need this to work cus the standard player dosnt work very well =/
Xbmc now finds my settings, but when i choose external player xbmc just flash for a sec and then nothing hapens. tryed diffrent players but its the same resaults.


- patkhoo - 2009-08-16

torva Wrote:Can someone please help me with this? Really need this to work cus the standard player dosnt work very well =/
Xbmc now finds my settings, but when i choose external player xbmc just flash for a sec and then nothing hapens. tryed diffrent players but its the same resaults.

Use a new SVN version of XBMC, and use the playercorefactory.xml instead.

Code:
<playercorefactory>
  <players>
    <player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
      <filename>D:\Apps\MPC HC\mplayerc.exe</filename>
      <args>/play /fullscreen /close /fixedsize 19200,10800</args>
      <hidexbmc>false</hidexbmc>
      <hideconsole>false</hideconsole>
      <hidecursor>false</hidecursor>
    </player>
  </players>
  <rules>
    <rule video="true" player="MPC-HC">
    </rule>
  </rules>
</playercorefactory>



- ashlar - 2009-08-16

torva,have you tried looking at the wiki?


- torva - 2009-08-16

patkhoo Wrote:Use a new SVN version of XBMC, and use the playercorefactory.xml instead.
Did it and now the diffrence is that it says play with mpc-hc instead of play with external, nothing hapens anyway =/

ashlar Wrote:torva,have you tried looking at the wiki?
yes Ive looked at it and it didnt help more than get me to were im now =/

Edit: Got it working now! Changed my c:\Program\MPC HomeCinema\mplayerc.exe to c:\Program Files\MPC HomeCinema\mplayerc.exe
Guess that did it Smile Thanx alot for the help!


- Livin - 2009-08-16

torva Wrote:Edit: Got it working now! Changed my c:\Program\MPC HomeCinema\mplayerc.exe to c:\Program Files\MPC HomeCinema\mplayerc.exe
Guess that did it Smile Thanx alot for the help!

this is funny... I read your post via the email notification and that was the first thing I thought of... "That is probably not his actual path"

glad you found it.


- zag - 2009-08-18

Is this now part of the latest XBMC SVN?

I installed the latest one last night and setting the watched tag seems to be broken again.


- Fascix - 2009-08-19

Okey i want to use MPC-HC at the external player but what arguments should i start it with?
I cant find a list of all the arguments/command line switches for MPC-HC
i have tried google and on the MPC-HC forums (and homepage)

anyone knows??


This forum uses Lukasz Tkacz MyBB addons.