Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



- marfa - 2009-08-30

Hi everyone,

Thanks again for this amazing software. I am trying for several days to get the external player option works with my XBMC but there is no way. The log says:
"Error loading special://profile/playercorefactory.xml, Line 2 (Error reading end tag.)".

My playercorefactory file is as follows:

<playercorefactory>
</players>
<player name="MPC HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Archivos de programa\Mplayer HC\mplayerc.exe</filename>
<args>/fullscreen /close</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<hidecursor>false</hidecursor>
</player>
</players>
<rules action="prepend">
<rule filetypes="mkv|avi|divx|wmv" filename=".*1080.*" player="Powerdvd"/>
</rules>
</playercorefactory>

So, please, if anyone knows what is wrong with it...Confused

Thanks in advance,


- Amra - 2009-08-30

I think you need to take the "/" out from "</players>" on line two.


- moby-uk - 2009-08-30

marfa Wrote:Hi everyone,

Thanks again for this amazing software. I am trying for several days to get the external player option works with my XBMC but there is no way. The log says:
"Error loading special://profile/playercorefactory.xml, Line 2 (Error reading end tag.)".

My playercorefactory file is as follows:

<playercorefactory>
</players>
<player name="MPC HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Archivos de programa\Mplayer HC\mplayerc.exe</filename>
<args>/fullscreen /close</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<hidecursor>false</hidecursor>
</player>
</players>
<rules action="prepend">
<rule filetypes="mkv|avi|divx|wmv" filename=".*1080.*" player="Powerdvd"/>
</rules>
</playercorefactory>

So, please, if anyone knows what is wrong with it...Confused

Thanks in advance,

Two things
1) the first </players> should be <players>
2) your rule says player="Powerdvd" but you've only defined a player called "MPC HC"


- zoing - 2009-08-30

moby-uk Wrote:a debug log would be handy please.

hi moby-uk,

here is the debug log.
http://pastebin.com/m74079118

I have used the latest svn 22503 version.

I have observed when i press on the remote "forward", then the flashing appaers immediately, otherwise it takes some time. But when I press the "pause" or "play" button the flashing does not appear instantly.

I have configured my remote with Event-Ghost.

I hope this helps!
thanks zoing


- THX-UltraII - 2009-08-31

Been away for a while and installed the latest (non-official) version of MPC-HC last night. I always used the following advancedsettings.xml file in my userdata directoy, but now my external player won t start up anymore. What could be the problem? Here my advancedsettings.xml file:

Quote:<advancedsettings>
<video>
<defaultplayer>externalplayer</defaultplayer>
<defaultdvdplayer>externalplayer</defaultdvdplayer>
</video>
<externalplayer>
<filename>C:\Program Files\MPC HomeCinema\mplayerc.exe</filename>
<args>/fullscreen /close</args>
<forceontop>false</forceontop>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<hidecursor>false</hidecursor>
</externalplayer>
</advancedsettings>

@maybe the others here have valuable information for me


- spiff - 2009-08-31

you must apparently be missing the means to read


- THX-UltraII - 2009-08-31

spiff Wrote:you must apparently be missing the means to read

you must apparently be missing the means of a forum


- spiff - 2009-08-31

?? the "means" of a forum is NOT to repeat the same things over and over and over and over and over again. it's described in this very thread. several times


- THX-UltraII - 2009-08-31

spiff Wrote:?? the "means" of a forum is NOT to repeat the same things over and over and over and over and over again. it's described in this very thread. several times


EVERY SINGLE thread someone posts has an answer already in some post or somewhere on the forum. I ask a fair and plain question and explained enough good information. Your next reply will be 'use the search function' or something, so I m not going to bother with you stupid replies anymore.

edit: the thing you want to hear probably is that you know EVERYTHING.


- THX-UltraII - 2009-08-31

@moderator: please clean up the not relative answers from SPIFF


- spiff - 2009-08-31

nah, i'm not gonna answer that. you're obviously a bit on the dull side so i'm not gonna waste resources.


- zoing - 2009-08-31

THX-UltraII Wrote:Been away for a while and installed the latest (non-official) version of MPC-HC last night. I always used the following advancedsettings.xml file in my userdata directoy, but now my external player won t start up anymore. What could be the problem? Here my advancedsettings.xml file:



@maybe the others here have valuable information for me

Hi,

when you have the latest version of the MPC-HC the name of the exe file has changed. The new name is mpc-hc.exe.
Maybe you should check this.


advancedsettings.xml latest non official version - guyf - 2009-08-31

Hi THX-ULTRA

you could look for the answer....I always look like this in google
( external player in site:http://www.xbmc.org )this way you only get answers from the site xbmc.org.

I don't think advancedsettings.xml is the right place for this anymore they use something else called playercorefactory.xml now.

Stay nice, this is free software you shouldn't wast your and developpers time...
Greetings from Antwerp
Guy


- THX-UltraII - 2009-08-31

guyf Wrote:Hi THX-ULTRA

you could look for the answer....I always look like this in google
( external player in site:http://www.xbmc.org )this way you only get answers from the site xbmc.org.

I don't think advancedsettings.xml is the right place for this anymore they use something else called playercorefactory.xml now.

Stay nice, this is free software you shouldn't wast your and developpers time...
Greetings from Antwerp
Guy


Even in geheimtaal Smile : Wil best aardig blijven maar heb je gezien hoe die kerel reageerde? Sloeg werkelijk helemaal nergens op. Jij gaat nu tenminste inhoudelijk in op mijn vraag. Hij heeft al eerlijk moeilijk gedaan trouwens hoor. Hij misbruikt trouwens wel zijn positie door meteen een waarschuwing te geven. Beetje triest allemaal.....


- spiff - 2009-08-31

abused my position? i told you in a fairly polite way that you don't get special treatment. you answer with personal insults.


This forum uses Lukasz Tkacz MyBB addons.