Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



- kepke - 2011-06-17

Did anybody tried using jriver with madvr as external player?
i did, and i really like the result.

Still, I have a small problem.
I configured jriver to run in display mode, and the first movie i run from xbmc everything works fine, but after the first video finishes or stopped it doesn’t play another one.

Does anyone have any idea how to resolve this issue?


- gav1577 - 2011-06-19

eskro Wrote:Hi guys!

I've been able to set MPC-HC as External Player

But, when i select a movie to watch,

XBMC minimizes and then MPC-HC launches and the movie starts playing...

My question is,

is there a way to prevent/stop XBMC from minimizing??

i just want it to stay where it is.......

i dont like to see my desktop even if its for a second Tongue



thanks!!!

Hi I have kind of figured out a way to solve this problem using EventGhost.
My xbmc setting are, use a fullscreen window rather than true fullscreen "enabled". This allows me not to have to hide xbmc in playercorefactory like bellow. This stops the desktop showing when i press play. I use MPC-HC
which i have set to d3d fullscreen.

<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="true" video="true">
<filename>C:\Program Files\Media Player Classic - Home Cinema\mpc-hc.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>bottomleft</warpcursor>
</player>
</players>
<rules action="prepend">
<rule filetypes="mkv" player="MPC-HC"/>
</rules>
</playercorefactory>

So far i get no show of the desktop when pressing play, the only time i see it flash is when i press stop, so my workaround was to use event ghost to load a blank black picture the "exact" same size as my desktop when the stop button was pressed. This fixed the problem. Smile

Here is a pic of my eventghost settings for my stop button
Image


at wits end - aasenb - 2011-07-02

Hello anyone who is reading this. I registered for this forum after losing all my patience trying to get an ExternalPlayer set up on win 7. Basically I want every video to play through MPC-HC, and nothing else.

Here is my playerfactory.xml within the userdata folder on my 2nd pc.

Quote:<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false"

video="true">
<filename>C:\Program Files\Media Player Classic - Home Cinema\mpc-hc.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule video="true" player="MPC-HC"/>
</rules>
</playercorefactory>

When I am in XBMC, trying to select a TV show to watch, clicking enter/ok on my remote does nothing, just makes the clicking noise. I can hit the context button, and select 'play using' MPC-HC(default), however that brings up an error from MPC-HC about 'switches'.

this is the error:
Image

Can someone please help me understand what is going wrong?


- steelman1991 - 2011-07-02

You need a 'play' switch - the external player needs to launch and play.

Change <args>"{1}" /fullscreen /close</args> to <args>"{1}" /fullscreen /play /close</args> - should be good to go.


- aasenb - 2011-07-02

Thanks for the reply, I tried that and it brings up the same error message.


- aasenb - 2011-07-02

I think I understand what is going on now, and it has to do with the fact I store my media on a network location. MPC is looking for " / " switches, and the very first " / " in the command line is the network smb share.


- jabberwockie - 2011-07-03

Grangey. Wrote:Well, managed to sort this myself by uninstalling and reinstalling xbmc and copying a TMT5 (3d) playerconfig used in another thread and tweeking it- this seemed to work 90% of the function, so I can only assume there was some form of typing problem in mine that I couldnt see.

Anyway, my new playerconfig does what I ask it too- launch all bluray disc image rips in TMT3. The only issue I have now is that it launches TMT (great), but not the actual movie! So the TMT will open over xbmc, but no file has been sent to it.

It also never opens in full screen despite the args telling it to (and the setting in it saying to always launch in full screen).

Im going to re-install TMT incase theres some strange issue with that which a fresh install would sort, but if anyone has any idea why it would launch TMT without it actually sending the film to it, id be greatful.

Grangey.

Hello - do you mind posting your playercorefactory.xml file and exactly where you placed it. I too am trying to TMT5 to play. spent 4 hours going through this and other threads and have had no luck.


Problem trying to use external player for specific file type - gcdlz - 2011-07-22

I am trying to get playercorefactory set up so I can play DRM files using Windows Media Center as an external player. I want to play those specific files only with WMC and all others through XBMC default player. I have my DRM files named as Movie1_DRM.wmv etc.
Here are two playercorefactory files I have tried with an explanation of the results I obtained. I must be overlooking something.

With this all videos regardless of file type or name are played using WMC, XBMC default player is never used.

1. <playercorefactory>
<players>
<player name="Media Center" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Windows\ehome\ehshell.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule filename="*_DRM*" player="Media Center" />
</rules>
</playercorefactory>

With this one all videos with .wmv extension are played using WMC regardless of file name, and all others are played using XBMC default player.

2. <playercorefactory>
<players>
<player name="Media Center" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Windows\ehome\ehshell.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule filetypes="wmv" filename="*_DRM*" player="Media Center" />
</rules>
</playercorefactory>

Any suggestion on how to change this to play only files named with _DRM.wmv at the end.


- Knight026 - 2011-07-30

The latest XBMC player has been updated, what else can MPC-HC do that the internal player can't in terms of greatly improving the picture?


- jhsrennie - 2011-07-30

@gcdlz: I think the file name is a regular expression, so "*_DRM*" doesn't do what you think. Try ".*_DRM.*" instead.

JR


- Nescio - 2011-08-06

Can MPC-HC bring the solution for my DTS issue?

For some reason I’m not getting surround sound when playing movies in XBMC under Windows XP (only front rear and left) while with Power DVD this is no problem. (Sound card Creative Soundblaster X-FI Xtreme connected via optical to Marantz SR8300 AV Receiver)

As I’m not able to find a solution for above issue (googling already for 2 days) I’m hoping if I force XBMC to use MPC-HC as player I have sound over all my speakers.

If this will work which rule do I need to enter in Playercorefactory.xml to let it been used for all my movie files (ISO, Video_TS, MKV, …etc)

Hope somebody can guide me to the right solution for my problem as I’m a complete noob in respect to this.
Confused


- muxadil - 2011-09-22

Nescio Wrote:Can MPC-HC bring the solution for my DTS issue?

For some reason I’m not getting surround sound when playing movies in XBMC under Windows XP (only front rear and left) while with Power DVD this is no problem. (Sound card Creative Soundblaster X-FI Xtreme connected via optical to Marantz SR8300 AV Receiver)

As I’m not able to find a solution for above issue (googling already for 2 days) I’m hoping if I force XBMC to use MPC-HC as player I have sound over all my speakers.

If this will work which rule do I need to enter in Playercorefactory.xml to let it been used for all my movie files (ISO, Video_TS, MKV, …etc)

Hope somebody can guide me to the right solution for my problem as I’m a complete noob in respect to this.
Confused
any decision on thisHuh?


- ArieS - 2011-09-27

Hello, I'm trying to use the external player function. It works but it sends the video to my primary display which is my PC instead of my secondary display which is my TV. And that with either players.
How do I make it go to my TV?
Here's my playercorefactory if that helps:

<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files\Media Player Classic - Home Cinema\mpc-hc64.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
<player name="VLC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\VideoLAN\VLC\VLC.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
</playercorefactory>

Thanks!


- Grangey. - 2011-09-28

Can someone tell me the "Rules" to make the external player default for all video files?? or does this setting not exsist?


- jhsrennie - 2011-09-28

Grangey. Wrote:Can someone tell me the "Rules" to make the external player default for all video files?? or does this setting not exsist?

<rule name="AllVideo" video="true" player="MPC-HC" />

JR


This forum uses Lukasz Tkacz MyBB addons.