Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



- scudlee - 2012-03-07

I knew I'd forget something... My blu-ray drive is on a different machine, so I was typing it from memory. Good catch.


- rossf87 - 2012-03-07

scudlee Wrote:If you're using Dharma, you can get away with protocols="bd". (The s is important, otherwise everything will match it, as you've seen.)

As far as I'm aware, though, the bd protocol no longer works in Eden. You had the right idea with the filename, it just needs to be a regexp - try using filename="D:\\.*", that should match anything on a disc. If you want it for blu-rays specifically, you could use it with filetypes="bdmv" (again, mind the s). So,

<rule filetypes="bdmv" filename="D:\\.*" player="whatever you called the player">

should work just for blu-ray discs. It does for me.

(To include DVDs in the same rule, you could use filetypes="bdmv|ifo".)

pkscuot Wrote:Just FYI, this is not valid XML and will result in the playercorefactory not loading at all. It should be:

<rule filetypes="bdmv" filename="D:\\.*" player="whatever you called the player" />

Cheers guys, will give this a go when I get home. I am using Eden RC2 and had to drop the s on protcols for it to even do anything in the first place which is where I have obviously started to run into issues.


- bluray - 2012-03-07

@rossf87- you can try the codes below:

<playercorefactory>
<players>
<player name="Disc_Player" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\CyberLink\PowerDVD11\PDVDLaunchPolicy.exe</filename>
<args>"{D:}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>

</player>
</players>
<rules action="prepend">


<!-- Bluray-->
<rule name="Blu-Ray" protocol="bd" player="Disc_Player"/>
</rules>
</playercorefactory>



- rossf87 - 2012-03-08

scudlee Wrote:If you're using Dharma, you can get away with protocols="bd". (The s is important, otherwise everything will match it, as you've seen.)

As far as I'm aware, though, the bd protocol no longer works in Eden. You had the right idea with the filename, it just needs to be a regexp - try using filename="D:\\.*", that should match anything on a disc. If you want it for blu-rays specifically, you could use it with filetypes="bdmv" (again, mind the s). So,

<rule filetypes="bdmv" filename="D:\\.*" player="whatever you called the player">

should work just for blu-ray discs. It does for me.

(To include DVDs in the same rule, you could use filetypes="bdmv|ifo".)

pkscuot Wrote:Just FYI, this is not valid XML and will result in the playercorefactory not loading at all. It should be:

<rule filetypes="bdmv" filename="D:\\.*" player="whatever you called the player" />

Thanks a lot to both you guys, went in and changed my playercore factory to filetypes="bdmv" and it worked perfectly first time! Cheers


- bluray - 2012-03-08

rossf87 Wrote:Thanks a lot to both you guys, went in and changed my playercore factory to filetypes="bdmv" and it worked perfectly first time! Cheers
This rule (<rule filetypes="bdmv" filename="D:\\.*" player="whatever you called the player" />) doesn't make sense. If you want to playback blu-ray disc with XBMC "Play Disc" option, why do you have to link it to .bdmv? If you want to playback index.bdmv in blu-ray disc folder, it make sense. To playback blu-ray disc on BD-ROM, it should be rule similar to this (<rule name="Blu-Ray" protocol="bd" player="Disc_Player"/>). Just a thought! Smile


- scudlee - 2012-03-08

In Dharma, when you pressed "play disc", XBMC would determine what type of disc you were trying to play (based on the folder structure), if it was a blu-ray disc it would then use the filename "bd://1" (for DVDs it would use "dvd://1"). This meant you could use protocols="bd" (again, the s matters) to refer to a blu-ray disc in your playercorefactory.xml.

In Eden, the filename used is "D:\BDMV\index.bdmv" (or whatever your drive letter is), so whatever rule you use has to match against that.


- crimsonfury - 2012-03-08

Ok well....

How do you get MPC-HC to behave now?! It plays for a couple seconds fine then stutters then fine then stutters! Very annoying. I set up the playercorefactory and put it in the xbmc userdata folder.

Also I can't get mpc to pop up automatically! I have to right click and say play with:.....

Why is this not a part of the GUI?! It should be easy to add an external player!

SO far I love the full GUI of xbmc but hate the player support for internal and external....


Please help!


- bluray - 2012-03-08

scudlee Wrote:In Eden, the filename used is "D:\BDMV\index.bdmv" (or whatever your drive letter is), so whatever rule you use has to match against that.
It works fine in my HTPC's and others using this (<rule name="Blu-Ray" protocol="bd" player="Disc_Player"/>) with Beta 3 and RC2. TMT5 works fine with or without "S" at the end of "protocol", but PDVD11/12 works without the "S" only! Huh


- snader - 2012-03-09

i have my tmt5 perfectly as external player using ' protocol="bd" player="Disc_Player"/>', but somehow xbmc is now also using tmt5 player for video_ts folders and dvd's. Why is that?

I just found out that when I start XBMC on my windows machine, it correctly plays any VIDEO_TS folder with the internal player. When I insert a Blu-Ray disc into the machine, it plays correctly with the TMT5 player! But when I start a VIDEO_TS folder after that, it starts the external player (tmt5) again...

update. I got it working by using filename="E://.*" instead of protocol="bd"


RE: [WINDOWS] External Player Support Thread - Soujirou Seta - 2012-03-12

Can someone help to use PotPlayer in ALL my movies and series at XBMC, except to DVDISO and BlurayISO (this formats, potplayer cannot playing)

I need a playercorefactory with this parameters, i don't understand nothing about these parameters.....Sad

Extra Tk.

Soujirou Seta.


RE: [WINDOWS] External Player Support Thread - DavidT99 - 2012-03-16

I am having issues with PowerDVD9 and bluray disc playback, I can launch the application from within XBMC ok but the playback is jerky even when in the menu of the disc. I am using the latest Eden build. Below is my playercorefactory.xml settings.

<playercorefactory>
<players>
<player name="Disc_Player" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\CyberLink\PowerDVD9\PDVDLaunchPolicy.exe</filename>
<args>"{E:}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule name="Blu-Ray" protocol="bd" player="Disc_Player"/>
</rules>
</playercorefactory>

Any ideas?

Thanks

David

EDIT: I am also having the issue where every movie I play from any source now launches the external player.


RE: [WINDOWS] External Player Support Thread - Soujirou Seta - 2012-03-17

(2012-03-12, 15:49)Soujirou Seta Wrote: Can someone help to use PotPlayer in ALL my movies and series at XBMC, except to DVDISO and BlurayISO (this formats, potplayer cannot playing)

I need a playercorefactory with this parameters, i don't understand nothing about these parameters.....Sad

Extra Tk.

Soujirou Seta.

No one?



RE: [WINDOWS] External Player Support Thread - bluray - 2012-03-18

@David- If you have Intel HDxxxx iPGU, I'm suggesting un-check (disable) DXVA2 and "sync to display" options and check (enable) "match refresh rate to source" option. It might get rid of jerky...

If it AMD GPU, you can check DXVA option....

To playback only BD-ROM with external player, you might want to use this rule instead (<rule filename=".*bdmv.*" player="Disc_Player"/>)


RE: [WINDOWS] External Player Support Thread - DavidT99 - 2012-03-18

(2012-03-18, 04:56)bluray Wrote: @David- If you have Intel HDxxxx iPGU, I'm suggesting un-check (disable) DXVA2 and "sync to display" options and check (enable) "match refresh rate to source" option. It might get rid of jerky...

If it AMD GPU, you can check DXVA option....

To playback only BD-ROM with external player, you might want to use this rule instead (<rule filename=".*bdmv.*" player="Disc_Player"/>)

I have an AMD 5450 GPU with DXVA enabled as well match refresh rate to source. I have also updated the graphics drivers to v12.3.

The issue with the external player being invoked for all video is now fixed.

Thanks


RE: [WINDOWS] External Player Support Thread - bluray - 2012-03-18

(2012-03-18, 18:47)DavidT99 Wrote:
(2012-03-18, 04:56)bluray Wrote: @David- If you have Intel HDxxxx iPGU, I'm suggesting un-check (disable) DXVA2 and "sync to display" options and check (enable) "match refresh rate to source" option. It might get rid of jerky...

If it AMD GPU, you can check DXVA option....

To playback only BD-ROM with external player, you might want to use this rule instead (<rule filename=".*bdmv.*" player="Disc_Player"/>)

I have an AMD 5450 GPU with DXVA enabled as well match refresh rate to source. I have also updated the graphics drivers to v12.3.
Did you try to disable "Sync Playback to Display"? And you can try "<hideconsole>false</hideconsole>" instead of "<hideconsole>true</hideconsole>".....If you have a less than powerful CPU, you can try to select "high performance" in Windows 7 power option too....

Oh, one other thing....maybe, you have too many programs running in the background while XBMC is running. You can disable some of it in "MSCONFIG" Startup options...

(2012-03-18, 18:47)DavidT99 Wrote: The issue with the external player being invoked for all video is now fixed.

Thanks
Good job...




This forum uses Lukasz Tkacz MyBB addons.