Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



RE: [WINDOWS] External Player Support Thread - salithus - 2012-03-19

oddly enough - I've got a 5450 too I'm trying to get working... I ran into a few issues so far - stuttering audio in TMT5-only was ultimately caused by the receiver I'm using (HDMI straight to TV works fine), but I'm still getting stuttering if I launch TMT5 from XBMC. If I kill the XBMC process in the background, TMT5 catches up and runs just fine. Anything I can do other than what's in this FAQ entry?


RE: [WINDOWS] External Player Support Thread - bluray - 2012-03-19

(2012-03-19, 05:04)salithus Wrote: oddly enough - I've got a 5450 too I'm trying to get working... I ran into a few issues so far - stuttering audio in TMT5-only was ultimately caused by the receiver I'm using (HDMI straight to TV works fine), but I'm still getting stuttering if I launch TMT5 from XBMC. If I kill the XBMC process in the background, TMT5 catches up and runs just fine. Anything I can do other than what's in this FAQ entry?
Since you have your system connected HTPC-->AVR-->HDTV via HDMI cables, you might want to set AVR to pass-thru video and configure XBMC external player codes as below:

<playercorefactory>
<players>
<player name="TMT5" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 5\uTotalMediaTheatre5.exe</filename>
<args>"{E:}" /fullscreen</args>
<hidexbmc>true</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>false</warpcursor>
</player>
</players>
<rules action="prepend">

<!-- Bluray Disc -->
<rule filename=".*bdmv.*" player="TMT5"/>
</rules>
</playercorefactory>


RE: [WINDOWS] External Player Support Thread - salithus - 2012-03-19

the <hidexbmc> option seems to have done the trick - thanks!


RE: [WINDOWS] External Player Support Thread - bluray - 2012-03-19

(2012-03-19, 14:16)salithus Wrote: the <hidexbmc> option seems to have done the trick - thanks!
I'm glad that it work....




RE: [WINDOWS] External Player Support Thread - starkos - 2012-03-19

I hope someone can help me with my playercorefactory.xml because it's driving me crazy lol! Basically I want it so that all video files play with MPC-HC, except my bluray rips (VC-1 codec) and anything that streams eg iPlayer (they can use the default DVDPlayer).

I can get it so that xbmc will default to MPC-HC for certain file extensions but have problems when it comes to the codec. This is what I have at the moment:

<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\Media Player Classic - Home Cinema\mpc-hc.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule filetypes="avi" player="MPC-HC"/>
<rule filetypes="mp4" player="MPC-HC"/>
<rule filetypes="m2ts" player="MPC-HC"/>
<rule filetypes="mkv" videocodec="h264" player="MPC-HC"/>
</rules>
</playercorefactory>

Avi, mp4, m2ts default to MPC-HC, but all mkv default to DVDPlayer?

I'm on win7 Eden RC2. Any hep to achieve what I want will be appreciated..


RE: [WINDOWS] External Player Support Thread - scudlee - 2012-03-19

@starkos, I just tested your code and it worked exactly as you expected it should... But I did notice an oddity - it didn't work when I tried to play a file from the recentlyadded widget (the one that displays videos directly on the home screen, not the separate submenu option). If I navigate to the file in the library or file view, it plays in MPC-HC, but play it from the home screen, dvdplayer. Weird. Could be a bug. (I imagine the video codec isn't getting checked somewhere.)

Anyway, any chance you only tested files on the home screen? Because your code works fine otherwise.

(You can simplify it a bit by using filetypes="avi|mp4|m2ts" to match all three in one rule.)


RE: [WINDOWS] External Player Support Thread - starkos - 2012-03-19

(2012-03-19, 19:07)scudlee Wrote: @starkos, I just tested your code and it worked exactly as you expected it should... But I did notice an oddity - it didn't work when I tried to play a file from the recentlyadded widget (the one that displays videos directly on the home screen, not the separate submenu option). If I navigate to the file in the library or file view, it plays in MPC-HC, but play it from the home screen, dvdplayer. Weird. Could be a bug. (I imagine the video codec isn't getting checked somewhere.)

Anyway, any chance you only tested files on the home screen? Because your code works fine otherwise.

(You can simplify it a bit by using filetypes="avi|mp4|m2ts" to match all three in one rule.)

Hi, thanks for testing! I've been accessing/testing files through Video/Files/etc. I'm starting to think I'm using the wrong codec lol, how do I find the exact codec that xbmc would be using as the trigger?

Edit: Okay, it seems the rules will only get triggered if the source folder had been allocated something in "Directory Contains" such as TV Shows (can't leave it as none). Also seems as though the directory has to be picked up by a scraper and added to the relevant library ie actually show up in TV Shows library!

Is there no way of having the rules also apply when you just have a video source folder added to video files without actually allocating it a type and adding it to a library?

Ps. I can confirm the bug of the rules not working when starting the video file from the Recent window.

Edit 2: Seems like the problem of rules not working for files only in file mode (not in any library) only applies to the videocodec rule above. The rule for filetype .avi still works, so must be something to do with a difference in how the videocodec info is read in file and library mode? (Which probably also explains the the rules not working in the Recent window as mentioned above)


RE: [WINDOWS] External Player Support Thread - Soujirou Seta - 2012-03-19

(2012-03-17, 17:00)Soujirou Seta Wrote:
(2012-03-12, 15:49)Soujirou Seta Wrote: Can someone help to use PotPlayer in ALL my movies and series at XBMC, except to DVDISO and BlurayISO (this formats, potplayer cannot playing)

I need a playercorefactory with this parameters, i don't understand nothing about these parameters.....Sad

Extra Tk.

Soujirou Seta.

No one?

Anybody..help!



RE: [WINDOWS] External Player Support Thread - bluray - 2012-03-19

(2012-03-19, 22:00)Soujirou Seta Wrote:
(2012-03-17, 17:00)Soujirou Seta Wrote:
(2012-03-12, 15:49)Soujirou Seta Wrote: Can someone help to use PotPlayer in ALL my movies and series at XBMC, except to DVDISO and BlurayISO (this formats, potplayer cannot playing)

I need a playercorefactory with this parameters, i don't understand nothing about these parameters.....Sad

Extra Tk.

Soujirou Seta.

No one?

Anybody..help!
What is the file type for your movies and serries?




RE: [WINDOWS] External Player Support Thread - Soujirou Seta - 2012-03-20

(2012-03-19, 22:15)bluray Wrote:
(2012-03-19, 22:00)Soujirou Seta Wrote:
(2012-03-17, 17:00)Soujirou Seta Wrote: No one?

Anybody..help!
What is the file type for your movies and serries?

Many thanks: AVI / MKV / MP4 / OGM / TS / TS.IFO / DIVX

I like playing all these movies (and series) using my favorite player (potplayer), but i don't find a playercorefactory with this.

Thanks again!

Soujirou Seta






RE: [WINDOWS] External Player Support Thread - bluray - 2012-03-20

(2012-03-20, 01:08)Soujirou Seta Wrote:
(2012-03-19, 22:15)bluray Wrote:
(2012-03-19, 22:00)Soujirou Seta Wrote: Anybody..help!
What is the file type for your movies and serries?

Many thanks: AVI / MKV / MP4 / OGM / TS / TS.IFO / DIVX

I like playing all these movies (and series) using my favorite player (potplayer), but i don't find a playercorefactory with this.

Thanks again!

Soujirou Seta
Download this "playercorefactory.xml" and save it to "\AppData\Roaming\XBMC\userdata" folder. If you're using Windows 7 64x, everything should work "As Is"....




RE: [WINDOWS] External Player Support Thread - Soujirou Seta - 2012-03-20

(2012-03-20, 04:21)bluray Wrote:
(2012-03-20, 01:08)Soujirou Seta Wrote:
(2012-03-19, 22:15)bluray Wrote: What is the file type for your movies and serries?

Many thanks: AVI / MKV / MP4 / OGM / TS / TS.IFO / DIVX

I like playing all these movies (and series) using my favorite player (potplayer), but i don't find a playercorefactory with this.

Thanks again!

Soujirou Seta
Download this "playercorefactory.xml" and save it to "\AppData\Roaming\XBMC\userdata" folder. If you're using Windows 7 64x, everything should work "As Is"....

Thanks so much!




RE: [WINDOWS] External Player Support Thread - claymic - 2012-04-04

Hi, i have a little challenge.
I am using a htpc with a xbmc, but i have a mediaplayer Hdi
Dune and since Dune can receive control by ip i want to navigate
through the xbmc in the htcp but when push a button the movie will
play in dune. Works nice if i put the path of the movie (for play in
Dune) in the trailer field (xbmc), but this is a lot of work because
i have to do this for all movies.
I am sorry for my bad english but i will try to put a sample here:
- suppose we have this movie in the HD :
D:\Movie\MoviesHD\Title of the movie (2011).mkv
- The client will select and play the movie in xbmc.
- Then i need to create a external player for Dune.
- this is the path for play the movie in Dune (http)
Code:
http://192.168.0.104/cgi-bin/do?cmd=start_file_playback&media_url=storage_name://Clayton2tb5/Movie/
MoviesHD/Title of the movie (2011).mkv
The 192.168.0.104 is the Dune ip.
Clayton2tb5 is the name of my HD (DSmile, i have to put the label.
So, can someone help me to create a external player who will work for this ? is There a way to in the args change the file path ?
I realy sorry about my bad english.
Thanks


RE: [WINDOWS] External Player Support Thread - shenlong55 - 2012-04-15

Is there any way to get an external player working to play CDs and not MP3s? I've tried using the rules...

CD="true"
filetypes="cda"
protocols="CD"
mimetypes="application/x-cdf"
filename="*.cda"
audio="true" filename="d://*.*"

and probably a few other combinations that I'm forgetting. They all either never use the external player or use it when playing CDs and when playing MP3s both.


RE: [WINDOWS] External Player Support Thread - BlackJack1 - 2012-04-15

Quote:Download this "playercorefactory.xml" and save it to "\AppData\Roaming\XBMC\userdata" folder. If you're using Windows 7 64x, everything should work "As Is"....

Hello, I used this file for PotPlayer (thank you Smile) and it works but... after the movie ends it only stops but not go back to XBMC.
I used before KMPlayer and no problem with this.
Any advice please... mayby any line in playcorefactory.xml file?
Regards Smile




This forum uses Lukasz Tkacz MyBB addons.