Kodi Community Forum
[WINDOWS] External Player Support Thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: [WINDOWS] External Player Support Thread (/showthread.php?tid=43511)



Rtmp or MMS HELP - Besir - 2012-10-01

Hi, can someone please tell me how to get rtmp or mms for live tv channel or what i need to get rtmp or mms from live tv channels. I have tried orpit and urlhelper and many more that i cant remember. but non of them work.
So please


RE: [WINDOWS] External Player Support Thread - natasa1111 - 2012-10-08

Im new to this forum, so i epolagize in advance if this question is not relevent to this category. Sad

My problem is that from this newest version 11.0, my media player wile working with UPNP which uses XMBC database can no longer display subtitles.
On earlier versions this was not a problem.

Can someone help me?



RE: [WINDOWS] External Player Support Thread - wildchild22 - 2012-10-18

Hi all I am trying to get xbmc to launch an iso on my media player ( A neotv 550)
same idea as this thread
http://forum.xbmc.org/showthread.php?tid=123648

I have it working in a batch file but xbmc does not launch it. Any ideas what I am doing wrong?

Here is the the working batch file.

@echo off
pushd
"C:\Users\htpc\AppData\Roaming\XBMC\userdata\sjcmd.exe" 192.168.123.101 -q CREATESESSION /TYPE=2 /NAME=\"videolist\" /TARGET=\"WILDCHILD22\" /TARGETDEV=\"TV\" /DEVICE=\"fileConfusedmb://:@TOWER2/disk12/testfile.mkv\" /FLAGS=0x2


What do I need to do in a batch file to get xbmc to fill in the file name from my mkv directory and start the .bat? I have seen posts using %1 but no sure how to do it.

Any help would be greatly apprecited.


RE: [WINDOWS] External Player Support Thread - THX-UltraII - 2012-10-21

Anyone knows if it is possible with the latest nightlies build to get BDMV folder played by external player? According to user BluRay (who really seems to know EVERYTHING about external player support!!!) BDMV folder playback by external player is only possible with the stable version of EDEN but I need the latest nightlies because of a specific bugfix that I need for my setup.


RE: [WINDOWS] External Player Support Thread - Ghostdivision - 2012-10-24

THX-Ultra I am having the same issue, I wonder what changed, I think the person doing the bluray work might not be aware of it. Have you found out anything? Maybe I should start a ticket.


RE: [WINDOWS] External Player Support Thread - nebrunner - 2012-10-24

newbie here, I finally have xbmc configured the way I would like it but I have issues with the built in player when I try to watch things at 24p. MPC-HC stand alone with madvr works great at 24p though (go figure), but opening the program and launching movies on that is a pain as I'm in a dedicated theater room with a projector. It seems like using xbmc to launch the mpc-hc would be perfect but I think I'm going to lose some of my functionality that I really love in xbmc, please let me know -

- Using xbmc android remote app via IP to control xbmc, see now playing, jump around in movies, etc. None of that would work if I went with external player, correct? (I'm addicted to this app now)

- Using a plugin called cinema experience, it plays trailers and stuff before the movie launches, would that work with an external player?


RE: [WINDOWS] External Player Support Thread - bluray - 2012-10-24

(2012-10-24, 18:30)nebrunner Wrote: - Using xbmc android remote app via IP to control xbmc, see now playing, jump around in movies, etc. None of that would work if I went with external player, correct? (I'm addicted to this app now)
You can configure MPC-HC keys as shown in my screen shot below:

Image





RE: [WINDOWS] External Player Support Thread - der-andi79 - 2012-10-29

Hello,
I just downloaded the newest XBMC for Windows 7, 64 Bit

I try to playback video files externaly with the VLC Player.
I have read the following: http://wiki.xbmc.org/index.php?title=External_players

Worked out the code in the playercorefactory.xml like this:

Quote:<playercorefactory>
<players>
<player name="VLC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\VideoLAN\VLC\vlc.exe</filename>
<args>"{1}" -f</args>
<hidexbmc>true</hidexbmc>
</player>
</players>
<rules action="prepend">
<rule filetypes="avi" filename=".*avi.*" player="VLC"/>
</rules>
</playercorefactory>

But everytime i start a video, its still playbacked by the internal video player.

What I am doing wrong?
The Path to vlc.exe is correct

Thanks a lot Smile


RE: [WINDOWS] External Player Support Thread - bluray - 2012-10-29

(2012-10-29, 14:31)der-andi79 Wrote:
Quote:<playercorefactory>
<players>
<player name="VLC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\VideoLAN\VLC\vlc.exe</filename>
<args>"{1}" -f</args>
<hidexbmc>true</hidexbmc>
</player>
</players>
<rules action="prepend">
<rule filetypes="avi" filename=".*avi.*" player="VLC"/>
</rules>
</playercorefactory>

But everytime i start a video, its still playbacked by the internal video player.

What I am doing wrong?
The Path to vlc.exe is correct

Thanks a lot Smile
Where did you saved your playercorefactory file? You can try this simple rule too- <rule filetypes="avi" player="VLC"/>





RE: [WINDOWS] External Player Support Thread - mahoneychops - 2012-11-08

Hello. I recently tried out XBMC and love the interface/look of the program it really is wonderful for a film library. Unfortunately the player is very choppy on my system. Through VLC player video's work fine. Could someone link me to/or post a full script so I'd be able to set XBMC to use the VLC player as the default for all video formats?

Is it just a case of copy and pasting the info into the playercorefactory.xml file? Sorry if this is a daft question but I'm not very good with these things.


Audiochannels - doubleJ - 2012-11-10

Hello...
I'm trying to do something that I thought was simple, but it is proving to be otherwise.
Specifically, I want to play anything that is AAC 5.1 channels in Media Player Classic (everything else in the built-in player).

Code:
<playercorefactory>
    <players>
        <player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
            <filename>C:\Program Files (x86)\Combined Community Codec Pack\MPC\mpc-hc.exe</filename>
            <args>"{1}" /fullscreen /close</args>
            <hidexbmc>false</hidexbmc>
            <hideconsole>false</hideconsole>
            <warpcursor>none</warpcursor>
        </player>
    </players>
    <rules action="prepend">
        <rule audiochannels="6" player="MPC-HC"/>
    </rules>
</playercorefactory>
My first test was to send all 5.1 channel audio to MPC, but it sent everything to MPC (even a movie with MP3 audio).
My second test was to send all AAC to MPC and that worked, but it is sending AAC 2.0 as well.
I want to combine audiocodec="aac" and audiochannels="6", but my computer doesn't seem to like the audiochannels="6" part.
Is there something wrong with my code or what's up?
JJ


RE: [WINDOWS] External Player Support Thread - scudlee - 2012-11-10

Nothing wrong with your code, it's XBMC who's at fault...

In PlayerSelectionRule.cpp, you can see that the audiochannels rule is picked up (line 61), but then nothing is done with it! Lines 131-139 cover the testing of the other four available stream details rules (audiocodec, videocodec, videoresolution, and videoaspect), but audiochannels isn't among them... Odd.

Hopefully an easy fix for someone who knows how.


RE: [WINDOWS] External Player Support Thread - doubleJ - 2012-11-10

(2012-11-10, 21:58)scudlee Wrote: Nothing wrong with your code, it's XBMC who's at fault...
Thanks for the info...
This has been annoying me for quite some time.
I wonder if a bug needs to be submitted.
JJ


RE: [WINDOWS] External Player Support Thread - scudlee - 2012-11-11

(2012-11-10, 23:13)doubleJ Wrote: I wonder if a bug needs to be submitted.
Probably the quickest way to get it fixed.



RE: [WINDOWS] External Player Support Thread - aexl - 2012-12-11

I'm having some trouble here and can't seem to find anyone who's found a solution yet!
I'm setting up MPC-HC as my external player - all is fine and well, XBMC hides, MPC-HC launches - but then I get the "failed to render file" message in the bottom left.
All my videos are set up on an SMB share with a username/password - the share looks like SMB:\\username:[email protected]\folder\file.
MPC-HC can't read that file name (I gather) and therefore can't render it. I've tried setting up my playercorefactory with {0}, {1} and {2} - no luck.
Anyone have any ideas?


This forum uses Lukasz Tkacz MyBB addons.