Kodi Community Forum
[LINUX] HOW-TO install XBMC for Linux on Ubuntu 8.04 (Hardy) and 8.10 (Intrepid) - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
+---- Thread: [LINUX] HOW-TO install XBMC for Linux on Ubuntu 8.04 (Hardy) and 8.10 (Intrepid) (/showthread.php?tid=44019)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44


- rodercot - 2009-02-25

majorheadache Wrote:OK, thanks for this informative post Nod

I've gone through it as carefully as I can but I'm still having an issue. First let me backup. If I plug the projector directly into the XBMC HTPC, then the image is perfect. Presumably the projector is able to correctly transmit it's EDID, so it goes to the right resolution. I haven't confirmed it, but I suspect that in the previous case it was spitting out a lower resolution that the projector was upscaling. But this isn't a practical solution since it precludes me from using other sources and HDMI audio.

So, using the technique on the ubuntu forum, I was able to get the output to xlog.txt. I have it posted here:

http://www.majorheadache.com/xlog.txt

But here is an excerpt and the first mode:

Code:
(II) NVIDIA(0): --- Building ModePool for Mitsubishi HC5000-HDMI (DFP-0) ---
(II) NVIDIA(0):   Validating Mode "1920x1080":
(II) NVIDIA(0):     1920 x 1080 @ 60 Hz
(II) NVIDIA(0):     For use as DFP backend.
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):       Pixel Clock      : 148.50 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1920, 2008
(II) NVIDIA(0):       HSyncEnd, HTotal : 2052, 2200
(II) NVIDIA(0):       VRes, VSyncStart : 1080, 1084
(II) NVIDIA(0):       VSyncEnd, VTotal : 1089, 1125
(II) NVIDIA(0):       H/V Polarity     : +/+
(II) NVIDIA(0):     Mode is valid.

and another low resolution mode:

Code:
(II) NVIDIA(0):   Validating Mode "720x480":
(II) NVIDIA(0):     720 x 480 @ 60 Hz
(II) NVIDIA(0):     For use as DFP backend.
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):       Pixel Clock      : 27.00 MHz
(II) NVIDIA(0):       HRes, HSyncStart :  720,  736
(II) NVIDIA(0):       HSyncEnd, HTotal :  798,  858
(II) NVIDIA(0):       VRes, VSyncStart :  480,  489
(II) NVIDIA(0):       VSyncEnd, VTotal :  495,  525
(II) NVIDIA(0):       H/V Polarity     : -/-
(II) NVIDIA(0):     Mode is valid.

so based on those two modes, I created the following two "modelines":

Code:
modeline "1920x1080" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    modeline "720x480" 27.00 720 736 798 858 480 489 495 525 -hsync -vsync
According to the post, I first tested it on the low resolution modeline with this statement:

Modes "720x480"

which did display a low resolution image. But when I change that to

Modes "1920x1080"

My projector just throws a totally scrambled image. I'm puzzled because it is listed as a valid mode, I know it can handle 1920 x 1080P. Can anyone see any mistake I've made?

Well you are still using EDID for your mode population by the look of it, the whole point of that post is to get rid of Edid all together and then use the custom modelines you prepared of which you can tailor each one be 1080, 50 ,60 ,24 for perfect fit. Post your xorg.conf file and let me look at it please.

You need to add

Option "ModeValidation" "NoEdidModes"

To your screen section of your xorg.conf file and by the looks of it you are still loading the native resolution option and you need to remove that now as you will not be scanning edid at all, This does not affect "DPMS" at all.

here is a copy of my LG 32" 1080p monitor. It currently only has the 1080p 60 line configured, I am still working on the 50 and 24.

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  ([email protected])  Tue Jan  6 10:03:02 PST 2009


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "LGHDTV"
    VendorName     "LG"
    ModelName      "32LG70"
    HorizSync       31.0 - 100.0
    VertRefresh     48.0 - 88.0
    ModeLine       "1920x1080" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    Option         "DPMS"
    Option         "ExactModeTimingsDVI" "True"
EndSection

Section "Device"
    Identifier     "9300GT"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "9300GT"
    Monitor        "LGHDTV"
    DefaultDepth    24
    Option         "NvAGP" "1"
    Option         "NoLogo" "True"
    Option         "ModeValidation" "NoEdidModes"
    Option         "TripleBuffer" "True"
    Option         "UseEvents" "True"
    Option         "DynamicTwinView" "False"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Depth       24
        Modes      "1920x1080"
    EndSubSection
EndSection



- majorheadache - 2009-02-25

Sorry this is going so painfully, I can only hope that eventually it will help someone else.

olympia Wrote:Actually you only have to change the default resolution and refresh rate at settings/appearance/screen/resolution. Change it until you see [email protected], then reboot.
To be able to display movies with other refresh rates properly, enable autorefresh at settings/video settings/player/auto refresh.

With resolution on Auto, it defaulted to 24Hz (according to my projectors info screen. When I forced it to 1920 x 1080 @ 60Hz, it did in fact display at 60Hz, but the image was only about 2/3 of the screen size.

smallish screen

I'm going to see what happens when I remove the two non 60Hz resolutions from my xorg.conf file.

@rodercot
rodercot Wrote:Well you are still using EDID for your mode population by the look of it, the whole point of that post is to get rid of Edid all together and then use the custom modelines you prepared of which you can tailor each one be 1080, 50 ,60 ,24 for perfect fit. Post your xorg.conf file and let me look at it please.

You need to add

Option "ModeValidation" "NoEdidModes"

To your screen section of your xorg.conf file and by the looks of it you are still loading the native resolution option and you need to remove that now as you will not be scanning edid at all, This does not affect "DPMS" at all.

here is a copy of my LG 32" 1080p monitor. It currently only has the 1080p 60 line configured, I am still working on the 50 and 24.

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  ([email protected])  Tue Jan  6 10:03:02 PST 2009


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "LGHDTV"
    VendorName     "LG"
    ModelName      "32LG70"
    HorizSync       31.0 - 100.0
    VertRefresh     48.0 - 88.0
    ModeLine       "1920x1080" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    Option         "DPMS"
    Option         "ExactModeTimingsDVI" "True"
EndSection

Section "Device"
    Identifier     "9300GT"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "9300GT"
    Monitor        "LGHDTV"
    DefaultDepth    24
    Option         "NvAGP" "1"
    Option         "NoLogo" "True"
    Option         "ModeValidation" "NoEdidModes"
    Option         "TripleBuffer" "True"
    Option         "UseEvents" "True"
    Option         "DynamicTwinView" "False"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Depth       24
        Modes      "1920x1080"
    EndSubSection
EndSection

I did out that, but I see now that I had it under "Device" instead of "Screen". However, it did seem to be following the conf file instead of EDID -- I say that because when I wrote "720 x 480" under Modes, it did display that resolution. However, I will move that line to the right place and see what happens.


- olympia - 2009-02-25

majorheadache Wrote:Sorry this is going so painfully, I can only hope that eventually it will help someone else.



With resolution on Auto, it defaulted to 24Hz (according to my projectors info screen. When I forced it to 1920 x 1080 @ 60Hz, it did in fact display at 60Hz, but the image was only about 2/3 of the screen size.

smallish screen

I'm going to see what happens when I remove the two non 60Hz resolutions from my xorg.conf file.

Easy task Wink
Don't remove those lines!
Just use the screen calibration! ...and enjoy! Smile


- majorheadache - 2009-02-26

olympia Wrote:Easy task Wink
Don't remove those lines!
Just use the screen calibration! ...and enjoy! Smile

Well, I didn't think it would be that easy, but YES!

Many Many Thanks!

While I'm at it, let me answer a few of my previous questions that may help some other noobs like me.

majorheadache Wrote:When I stop XBMC I do not have a proper prompt. There is no blinking cursor, no text saying what user/folder I am in. The keyboard works -- I can type letters etc, but nothing executes. Is this normal?.

Press Alt-F2 to get a bash(?) prompt. Then you can run your commands.

majorheadache Wrote:I tried to start XBMC (which I admit, I'm not exactly sure how to do.) I went to my XBMC folder and typed xbmc ENTER. .

From the prompt, Ctrl-d works for me. I've seen a few other methods I haven't tried, but this is working for me right now.

majorheadache Wrote:I have tried setting the S/PDIF to HDMI but then I get no sound at all.

I finally have this sorted and I think my problems were three-fold. First, I had to change the audio output to HDMI in the BIOS. Next, and I think this may be projector specific, I had to have the option

Code:
Option         "ModeValidation" "NoEdidModes"

in the Screens section of my xorg.conf file. I think EDID was telling the PC not to send sound because the projector can't process it. Further, you don't want to simply use

Code:
Option "UseEDID" "FALSE"

because that also disables HDMI audio, from what I read.

Once I had all that, I had to go through one more round of

Code:
# rename /etc/init.d/alsa-utils
sudo mv /etc/init.d/alsa-utils /etc/init.d/alsa-utils.x
# reboot your system
reboot
# rename /etc/init.d/alsa-utils.x back to /etc/init.d/alsa-utils
sudo mv /etc/init.d/alsa-utils.x /etc/init.d/alsa-utils
#start the alsamixer and activate iec958 output
alsamixer

which I got from the sound no longer working thread.


- danillll - 2009-02-26

I think I gave up on this one and I need your help.
With hardy minimal version, I followed the steps for the usplash and I noticed after
sudo apt-get -y install usplash libusplash-dev

that I still don't have /usr/lib/usplash directory so obviously the next step would fail, sudo wget http://217.20.138.65/xbmc/spinner-blue/usplash-theme-ubuntu.so -O /usr/lib/usplash/usplash-theme-ubuntu.so

I tried to create the directory and finishing the steps, but still no workie.
Any ideas? Do I need to edit grub?

Thanks,


- olympia - 2009-02-26

danillll Wrote:I think I gave up on this one and I need your help.
With hardy minimal version, I followed the steps for the usplash and I noticed after
sudo apt-get -y install usplash libusplash-dev

that I still don't have /usr/lib/usplash directory so obviously the next step would fail, sudo wget http://217.20.138.65/xbmc/spinner-blue/usplash-theme-ubuntu.so -O /usr/lib/usplash/usplash-theme-ubuntu.so

I tried to create the directory and finishing the steps, but still no workie.
Any ideas? Do I need to edit grub?

Thanks,

Yes, I am aware that the steps should be extended for hardy (are OK for Intrepid). I have to comment it in the guide until I figure this out. Unfortunately I have no Hardy installation at the moment.

But try:

Code:
# sudo apt-get -y install usplash-theme-ubuntu xubuntu-artwork-usplash libgd2-xpm-dev

and than continue from the wget part of the guide.


- danillll - 2009-02-26

Quote:# sudo apt-get -y install usplash-theme-ubuntu xubuntu-artwork-usplash libgd2-xpm-dev

@olympia
the above packages did create the usr/lib/usplash dir. I redid the steps with no errors, however the restart didn't show the splash, I still get text.

Then I looked at /boot/grub/menu.lst and noticed that no vga option was defined, so I added it and rebooted.
Now the boot text is gone, however, I see a weird picture (it's like a color calibration image with a progress bar in it ), it's not even positioned correctly.
Didn't have time to troubleshoot, had to leave and get my ass to work, but it looks like a progress.
Any suggestion?

Thanks


- danillll - 2009-02-27

I finally got it working, here is what I did:

- I started fresh with a new hardy minimal install ( I just wanted to undo all the trials and extra packages I loaded during my initial troubleshooting)

- ran the suggested command which created the usr/lib/usplash dir along with two files (I can't remember I installed libgd2-xpm-dev, so you can try it without it)
sudo apt-get -y install usplash-theme-ubuntu xubuntu-artwork-usplash

- Rebooted and got the xubuntu splash

- finished the remaining steps in the guide, but it wasn't working

- so I downloaded the splash zip from dudukes website

- unzip it and compiled

- copied the image and overwrote the xubunty splash (usplash-theme-xubuntu.so) in /usr/lib/usplash

- I made sure that usplash-theme-xubuntu.so is still selected by running
sudo update-alternatives --config usplash-artwork.so

- edit etc/usplash.conf according to the guide
- and then run
sudo update-initramfs -u

So the main difference is that I had to recompile the splash and not use the one linked in the guide, which still wouldn't work


- slacker666 - 2009-02-28

there's an error regarding autostarting XBMC in the wiki.

It should be .bash_login (not .bash_profile) with this code:
Code:
if [ -z "$DISPLAY" ] && [ $(tty) == /dev/tty2 ]; then

startx
fi

and it should be named ".Xsession" (without ") with this line:
Code:
xbmc --standalone

and nothing else in .Xsession


- SpaceMonkey - 2009-02-28

I followed the wiki but when trying to launch XBMC i get this

Quote:Cannot get root display. Is X11 running and is your DISPLAY variable set?
CRITSEC[0x8c6c8c4]: Trying to enter destroyed section.
CRITSEC[0x8c6c8c4]: Trying to leave destroyed section.

echo $DISPLAY returns a blank line

I've tried with original xorg.conf created by Nvidia installer, and the modified one from the wiki.

I used 8.04 and instead of compiling XBMC manually i grabbed precompiled one from svn ppa.


- pyrates - 2009-03-01

I followed the guide and noticed there was a change in it. It seems that aron's patch and how to apply it has been removed. Is there a reason for this because the patch did work for me?


- SpaceMonkey - 2009-03-01

Any suggestions to my problem? I know it's hardly an optimal way to simply copy&paste commands and have Linux installed that way but i'd like to atleast see how fast&well it works with that setup.
I can't even launch xclock so the problem obviously is with xorg, not XBMC.


- harryzimm - 2009-03-01

What hardware are you running?


- SpaceMonkey - 2009-03-01

Abit i-n73hd (Geforce 7100, nforce 630i chipset, Realtek ALC888). Picture over hdmi, sound over spdif.


- majorheadache - 2009-03-01

Anybody else can probably help you better than I can, but for what it's worth, while I was searching for that error, (which I had a few pages ago) I did find this thread which included a solution.