Kodi Community Forum
[LINUX] HOW-TO install XBMC for Linux on Ubuntu 8.04 (Hardy) and 8.10 (Intrepid) - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (https://forum.kodi.tv/forumdisplay.php?fid=52)
+---- Thread: [LINUX] HOW-TO install XBMC for Linux on Ubuntu 8.04 (Hardy) and 8.10 (Intrepid) (/showthread.php?tid=44019)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44


- olympia - 2009-04-29

My board has nvidia 9300, so it's different. Although there was somebody, who reported to work with 9400, so I really don't know where can be the culprit.

I will try the hardy way later Smile
You mean be reversed, that you reinstall again every packages you just removed?


- olympia - 2009-04-29

F*ck... Angry

xserver-xorg-dev was missing and that cause the problem.

I assume previously on Hardy and Intrepid it was pulled automatically by Xorg package, but not in Jaunty.

But then it's still a question why it was working for some people... Huh


- rodercot - 2009-04-30

olympia Wrote:F*ck... Angry

xserver-xorg-dev was missing and that cause the problem.

I assume previously on Hardy and Intrepid it was pulled automatically by Xorg package, but not in Jaunty.

But then it's still a question why it was working for some people... Huh

Bence,

I really do not think it is working at all without installing that package, i am testing live 9.04 and having the same issues, I am trying to install 185.19 and I have to install the driver on every boot up or remove it and head back to 180.44 and it boots everytime, I did get the exact same error as you did.

I have install the dev package but the problem still exists and it will not load the new driver up a reboot.

Dave


- rodercot - 2009-04-30

I am starting to think this is a permissions bug. I just got them to load on Live 9.04. I had to sudo su and delete the exsiting nvidia.ko file and then reinstall the drivers again following that to recreate the module and voila they are running and loading on reboot. here is what I did on XBMCLive clean HDD install.

ssh into the live machine
copied a clean xorg.conf to /etc/X11 - xbmc will launch as soon as this is in place - no input from user.
exit xbmc
added the keyserver to fix apt-get update keyring error
installed wget
installed build essential linux-headers
installed xserver-xorg-dev
reboot
exit xbmc
get the nvidia driver you want to install other than 180.44 (I use 185.19 on all my machines)
sudo su
sudo rm /lib/modules/2.6.28-11-generic/updates/dkms/nvidia.ko
exit root and log back into std console
sudo sh NVIDIA-Linux-x86-version-pkg1.run (install the driver and let it overwrite your xorg.conf) Again XBMC will autolaunch automagically on the next attempt X makes to load the module and voila.

These are just the steps I did, do not try and copy and paste these commands please and what I meant about permissions, is that I could not get into that directory even to browse it via console or putty without being root so I am thinking that maybe even though the driver is saying it is installing OK, it is not able to write to the kernel module to infact update it. I could be way off here, but it looks that way to me.

Dave


- olympia - 2009-04-30

Hey Dave,

On the minimal install, simply installing xserver-xorg-dev package solve the issue. It still gives the warnings during driver installation, but it works fine after all.


- rodercot - 2009-04-30

olympia Wrote:Hey Dave,

On the minimal install, simply installing xserver-xorg-dev package solve the issue. It still gives the warnings during driver installation, but it works fine after all.

If you reboot after install the xserver and then install your driver the errors should go away, mine did.

Dave


Alsa errors : fixed in Jaunty - tom123 - 2009-05-05

Hi All,

I wonder if upgrading to Jaunty will fix my alsa error.

The error is : "GetDelay - snd_pcm_delay, alsa error: -32 - Broken pipe"
It makes me cry when listening to radio steams because of small "gap" in the sound. Thread : http://forum.xbmc.org/showthread.php?tid=50325

So do you advise me to upgrade or to search another solution ?

Thanks,

Tom


- pyrates - 2009-05-05

Try going back to 8.04 minimal and follow the guide. That's the version I'm using and it works just fine for me.


Fixed : alsa error gone with resample to 48000 - tom123 - 2009-05-06

Hi Pyrates,

BillyBig gave a solution which works and is really simple.
It is about adding a resample parameter in the avandedsettings file.

Full detail here : http://forum.xbmc.org/showpost.php?p=330394&postcount=2

Regards,
Tom


- Cissou - 2009-05-06

I wanna do a very proper install on my pchc
I will patitionnize my hdd
one for / and
another for /home/

so I wanted to know how much I put for / (the rest of the hdd is for /home/)


- Deanjo - 2009-05-07

No longer compiles on openSUSE

make[2]: Leaving directory `/home/dean/linuxport/XBMC/xbmc/lib/libPython/Python'
cc -shared -o ../../../../system/python/python24-x86_64-linux.so -Wl,--whole-archive ../Python/libpython2.4.a \
-Wl,--no-whole-archive `cat wrapper_python.def` wrapper_python.o \
`cat ../../../cores/DllLoader/exports/wrapper.def` \
../../../cores/DllLoader/exports/wrapper.o
make ../../../../system/python/python24.zip
make[2]: Entering directory `/home/dean/linuxport/XBMC/xbmc/lib/libPython/linux'
make[2]: `../../../../system/python/python24.zip' is up to date.
make[2]: Leaving directory `/home/dean/linuxport/XBMC/xbmc/lib/libPython/linux'
make[1]: Leaving directory `/home/dean/linuxport/XBMC/xbmc/lib/libPython/linux'
make -C xbmc/visualizations/OpenGLSpectrum
make[1]: Entering directory `/home/dean/linuxport/XBMC/xbmc/visualizations/OpenGLSpectrum'
make[1]: `../../../visualisations/opengl_spectrum.vis' is up to date.
make[1]: Leaving directory `/home/dean/linuxport/XBMC/xbmc/visualizations/OpenGLSpectrum'
make -C xbmc/visualizations/WaveForm
make[1]: Entering directory `/home/dean/linuxport/XBMC/xbmc/visualizations/WaveForm'
make[1]: `../../../visualisations/Waveform.vis' is up to date.
make[1]: Leaving directory `/home/dean/linuxport/XBMC/xbmc/visualizations/WaveForm'
make -C xbmc/visualizations/XBMCProjectM
make[1]: Entering directory `/home/dean/linuxport/XBMC/xbmc/visualizations/XBMCProjectM'
/usr/bin/ccache g++ -MD -c -O3 -g -fPIC -O2 -DNDEBUG=1 -D_LINUX -D_FILE_DEFINED -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DINSTALL_PATH="\"/usr/share/xbmc\"" -DHAS_PCRE -D'SVN_REV="20020M"' -DDLL_PATH_LIBCURL="\"/usr/lib64/libcurl.so\"" -I. -I.. -I../../linux -I../../ -I../../../guilib -I../../../visualisations -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/hal -I/usr/include/lzo Main.cpp -o Main.o
In file included from Main.cpp:38:
../../../visualisations/xbmc_vis.h: In function ‘int htoi(const char*)’:
../../../visualisations/xbmc_vis.h:32: error: ‘isdigit’ was not declared in this scope
../../../visualisations/xbmc_vis.h:35: error: ‘tolower’ was not declared in this scope
make[1]: *** [Main.o] Error 1
make[1]: Leaving directory `/home/dean/linuxport/XBMC/xbmc/visualizations/XBMCProjectM'
make: *** [visualizations] Error 2


- fasteddy - 2009-05-07

Yeah, same errors on a fresh install of Ubunty Jaunty. Looks like you'll need to use an older revision till it's fixed.


- davewantsmoore - 2009-05-07

New SVN checkin
Working now
:-D


- Cissou - 2009-05-09

I'm trying to follow the guide, but i have a problem

I'm using the Jaunty mini AMD64 iso, so when I install all the packages, there is one that's not available for the 64 architecture : libsdl-stretch-dev.

So what can I do?


- pyrates - 2009-05-09

Install the 32-bit version of Ubuntu. There's problems with compiling it as 64-bit right now.