Kodi Community Forum
Scripts & Plug-in Trouble = Python? - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: Scripts & Plug-in Trouble = Python? (/showthread.php?tid=44713)



Scripts & Plug-in Trouble = Python? - kiteoregon - 2009-02-01

I followed the install in intrepid / ATI guide (great job), the base install is working great. I can't however seem to get plug-ins or scripts to run. From xbmc i just get running status and nothing. I can see from the error that i am missing modules, i would have thought that everything for xbmc was downloaded from SVN when i did a checkout. I am sure this is simple, i appreciate the help.

Here is the error log when running SVN Repo Installer:

14:51:26 T:3069314864 M:2920239104 ERROR: Unable to load: /home/xbmc/.xbmc/plugins/programs/SVN Repo Installer/resources/settings.xml, Line 0
Failed to open file
14:51:26 T:2925308816 M:2920239104 NOTICE: -->Python Interpreter Initialized<--
14:51:26 T:2925308816 M:2920239104 NOTICE:
14:51:26 T:2925308816 M:2920239104 NOTICE: Traceback (most recent call last):
14:51:26 T:2925308816 M:2920239104 NOTICE: File "/home/xbmc/.xbmc/plugins/programs/SVN Repo Installer/default.py", line 21, in ?
14:51:26 T:2925308816 M:2920239104 NOTICE:
14:51:26 T:2925308816 M:2920239104 NOTICE: from installerAPI import xbmcplugin_list as plugin
14:51:26 T:2925308816 M:2920239104 NOTICE: File "/home/xbmc/.xbmc/plugins/programs/SVN Repo Installer/installerAPI/xbmcplugin_list.py", line 9, in ?
14:51:26 T:2925308816 M:2920239104 NOTICE:
14:51:26 T:2925308816 M:2920239104 NOTICE: import os
14:51:26 T:2925308816 M:2920239104 NOTICE: ImportError
14:51:26 T:2925308816 M:2920239104 NOTICE: :
14:51:26 T:2925308816 M:2920239104 NOTICE: No module named os
14:51:26 T:2925308816 M:2920239104 NOTICE:
14:51:26 T:2925308816 M:2920239104 ERROR: Scriptresult: Error
14:51:26 T:2925308816 M:2920239104 NOTICE: Traceback (most recent call last):
14:51:26 T:2925308816 M:2920239104 NOTICE: File "<string>", line 1, in ?
14:51:26 T:2925308816 M:2920239104 NOTICE: ImportError
14:51:26 T:2925308816 M:2920239104 NOTICE: :
14:51:26 T:2925308816 M:2920239104 NOTICE: No module named threading
14:51:26 T:2925308816 M:2920239104 NOTICE:
14:51:27 T:3069314864 M:2920239104 ERROR: GetDirectory - Error getting plugin://programs/SVN Repo Installer/
14:51:27 T:3069314864 M:2920239104 ERROR: CGUIMediaWindow::GetDirectory(plugin://programs/SVN Repo Installer/) failed

Thanks for the help.....


- blittan - 2009-02-01

might be a problem with your python installation .. or the xbmc installation.. try and reinstall both once again..

os is a python module so you know and isn't part of xbmc


- kiteoregon - 2009-02-01

So i removed xbmc, and python reinstalled python and installed xbmc from the repo, seems scripts are working, now to test everything else.

thanks


- kiteoregon - 2009-02-01

ok, so installing the repo version did not get me very far, it seemed to crash when opening videos or file shares. I am downloading the latest version from svn, i will install on top of repo version and see if that fixes the python problems.

the repo version: the python scripts and add-ins worked great, but that's about it.

8 to 10 hours later i will get this figured out.... so much easier on the xbox.


This forum uses Lukasz Tkacz MyBB addons.