Kodi Community Forum
[Linux] Video driver does not support OpenGL 2.0 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: OS independent / Other (https://forum.kodi.tv/forumdisplay.php?fid=228)
---- Thread: [Linux] Video driver does not support OpenGL 2.0 (/showthread.php?tid=53005)



[Linux] Video driver does not support OpenGL 2.0 - pguru - 2009-06-17

I am posting in a couple forums, so I just wanted to see if I could get specific information here. Here is my system:

Distribution; Mint 7 (based on Ubuntu Jaunty 9.04)
Architecture: x86
Install Method: PPA
log: http://pastebin.com/m15b64cf7
Video Card: VIA Tech CX700/VX700
I am unaware of the version of xbmc that I have, as I will explain later, but downloaded it off of the PPA from the Jaunty repository

The Problem:
When I start up XBMC, it starts in a window and displays a clipped version of the xbmc logo. Then there is just a white screen. Some yellow text scrolls across that is illegible. I cannot do anything at this point.

The solution?
I looked up some info about opengl 2.0 and xbmc, After some research (glxinfo), I found out that I have version 1.2. Now here is my question: one, does anyone here happen to know of how I could get my video drivers updated so that I could run xbmc. Right now, in my xorg.conf, it lists no driver for my video card. Don't know about this. Otherwise, is there a way that I could get xbmc ( a past version) running with a lower version of xbmc or something. Any help is appreciated, thanks.


- tslayer - 2009-06-17

VIA isn't supported I don't think.


- althekiller - 2009-06-17

Last I checked no combo of VIA HW/drivers supports enough openGL to run XBMC. Some (search forums) have got it to launch, but performance was extremely poor (read unusable) due to GL stuff happening in SW.


This forum uses Lukasz Tkacz MyBB addons.