Kodi Community Forum
VDPAU problem - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: VDPAU problem (/showthread.php?tid=54568)

Pages: 1 2

VDPAU problem - tsint - 2009-07-13

I've used VDPAU for quite some time now, and I never had any problem with any movie.

However, now I found three movies that cause same problem. It shows some green errorblocks on the screen and I can hear the audio for a couple of seconds. After that XBMC seems to freeze, and it does not respond to any key.

I've also noticed that XBMC and compiz.real is consuming lot of CPU time

4603 xbmc      20   0  271m  89m  41m D  101  4.5   1:10.94 xbmc.bin
4004 xbmc      20   0 79356  43m  19m R   98  2.2   0:34.97 compiz.real

SVN (build 21648)
Ubuntu 9.04 32bit with default nvidia drivers (180.44?)

Pastebin: http://pastebin.com/m61ce70ec

- Haggy - 2009-07-13

You should disable compiz and the composite extension. Doesn't play nicely with VDPAU.

- tsint - 2009-07-13

I've tried that but it does not help.

- mkortstiege - 2009-07-13

You might also want to play with the vsync options in your driver and XBMC.

- tsint - 2009-07-13

I played around with the settings and I think I narrowed down the problem a little bit. It seems to be related to "Adjust refresh rate" in combination with "Sync playback to display (Audio clock)". if I enable both I get this problem, but I've only seen it on three x264 releases.

- Haggy - 2009-07-13

This could be interesting for bobo. Did you try changing sync method to video clock (resampling or dupe/drop) ? Also could you provide a short snippet from the file?

- tsint - 2009-07-13

After some more testing I think the problem is only related to the "Adjust refresh rate" option. Other [email protected] releases works fine... probably tested >100.

- elupus - 2009-07-13

vdpau and auto refreshrate changes will always cause problems. normally the broken display should correct itself after a few seconds.

it shouldn't lock up thou.

- motd2k - 2009-07-13

If you get chance and you're willing, it might be useful to have you run some debugging traces on your XBMC build. Give me a shout in #xbmc-linux whenever you've got a spare 30 mins or so.

- tsint - 2009-07-13

Ok, will send you a msg.

Mediainfo output: http://pastebin.com/m7b764d5a

- Clodo - 2009-07-27

Hi to all, i have the same problem.

I use VDPAU on a Acer Revo (ION), Ubuntu Jaunty, XBMC unstable from repository, HDMI, [email protected]

I see many videos codec with h264, but i have two or three h264 that aren't playback correctly.
On video are showed green errorblocks. But XBMC work very well, doesn't freeze.
If i disable the VDPAU (so, i use "Automatic"), the same video without acceleration hardware are showed correctly without any problems.

I think if is a format that XBMC can't accellerate via hardware, XBMC need to show it at least without acceleration.

I put a link on a 84MB video that have this problem : direct link.

p.s. is an Anime Music Video, this. I don't know if can be considered a copyrighted material.

Thanks for any suggestion!

- motd2k - 2009-07-28

I tried the first link with VDPAU (attack.mp4) and it was okay. What card are you using, and how much memory does it have?


- Clodo - 2009-07-29

XBMC pre9.10 r21866 (Compiled: Jul 26 2009)

NVidia drivers: 180.44 (lastest, installed from NVidia website)

Linux htpczz 2.6.28-13-generic #45-Ubuntu SMP Tue Jun 30 19:49:51 UTC 2009 i686 GNU/Linux

Hardware: AspireRevo R3600 (specs)

Screenshot of the problem:

Debug log: http://pastebin.com/m3f8efb39

Every version of XBMC i tested (this and also the lastest stable from repository) have the same problem.
I downloaded the same link of my previous post to capture the screenshot.
If i disable VDPAU and set to "Automatic", the video are showed correctly.

I don't now what type of other informations i can tell to you to help. What i can test?

Edit: memory ram: 512MB. Are selectable from bios, but change it to "Auto" or "256mb" doesn't affect the problem.

- Haggy - 2009-07-29

You should upgrade your nvidia driver to 185.18.19 or even 190.18

- Clodo - 2009-07-29

Haggy Wrote:You should upgrade your nvidia driver to 185.18.19 or even 190.18

- 190.18 (beta drivers) installed. apt-get update/upgrade etc. Nothing changed.
- Changing resolution and refresh rate don't change anything.
- "Vertical blank sync" don't change anything.

A newbie question: in "Hardware/Proprietary drivers" of ubuntu, NVidia are not showed. But "NVidia Settings" works, resolution 1920x1080 are ok, and XBMC play with hardware acceleration other H264 (also 1080p) videos. I have only 2 or 3 video that give the problem above.

Edit: Exists a Revo/XBMC user that show with VDPAU the video linked above? Just to understand if is a hardware problem or a software/configuration problem.. thanks!

This forum uses Lukasz Tkacz MyBB addons.