Kodi Community Forum
[RELEASE] Home Theater Experience (Script) - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=151)
+---- Thread: [RELEASE] Home Theater Experience (Script) (/showthread.php?tid=55628)

- mcborzu - 2010-12-12

Very cool guys! "Night" and "The Carmichael" will have this in tonights update...Enable via Settings->Skin->General

- rflores2323 - 2010-12-12

yes im going to try this out. thanks

- htpc guy - 2010-12-12

[Ubuntu 10.4/Dharma RC2]

So I'm wondering if anyone can help me out with my issue. I can get this setup beautifully with my windows 7 test system but I'm having issues with my Linux machine.

With the windows machine I have the following working:
Special video set as an intro
Trailer Intro
2 Trailers streamed from Apple Trailers Lite
THX/DTS Intros mapped to the audio folder
Ratings mapped to the Ratings Folder
Feature Presentation Intro

I set this up through the context menu in the addon menu and it works very well.
I'm launching it from Night with the Cinima button created on the Info Screen.

On the Linux (ubuntu 10.4) machine I cannot use the addon menu to configure it. When I try it kills XBMC.

To get around this I have copied the settings file from my Windows machine and used it on the linux machine. I have changed the paths on the Linux Settings.xml file to reflect the SMB share locations. This should work but I only get the trailers and the THX/DTS video to play.

The following are sections of the settings.xml file for both the windows and Linux machines.

<setting id="audio_videos_folder" value="G:\Cinima Experience\Audio\" />
    <setting id="cav_intro" value="1" />
    <setting id="cav_intro_file" value="G:\Cinima Experience\Coming Attractions\Coming Attractions.mp4" />

<setting id="audio_videos_folder" value="smb://matt-epic-pc/g/Cinima%20Experience/Audio/" />
    <setting id="cav_intro" value="1" />
    <setting id="cav_intro_file" value="smb://matt-epic-pc/g/Cinima%20Experience/Coming%20Attractions/Coming Attractions.mp4" />

I'm fairly certain that its not an issue with path names because I copied them from Nautilus (pressed ctrl+L so I could copy the paths). Also I have the folders enabled for sharing and full control so I can't be a permissions issue either.

Any help on this would be great.

pastebin of debug log:

- giftie - 2010-12-12

You can now download through Nuka's Addon Repo. -- http://xbmc-addons.googlecode.com/svn/packages/repository.googlecode.xbmc-addons.zip

The Following does work:
- adjust the settings from XBMC - though not sure of the music playlist
- Trivia
- Intro's And Outro's
- Coming Attraction
- DTS/DD/THX Audio Videos
- Local Trailers - Not sure why I could not get the streaming or AMT DB working - I may have Borked something...
- And of course, it does play the movie too...

- Nuka1195 - 2010-12-12

good job giftie. you got alot done.

htpc guy is it really Cinima%20Experience? Cinema

also i'm not familar with linux, but, those %20 are spaces, i wonder why linux is doing that. if changing them to spaces fails, try escaping them with \ "Cinima\ Experience"

mac version of xbmc - home theatre - sting2010 - 2010-12-12

first, thanks very much for enabling the home theatre script. I cannot get this to work with my mac mini using xbmc 10.0.0rc1. I have downloaded both the carmichael skin and night - i do no see the option in night to enable the home theatre button - help please - when I try to configure the home cinema script, xbmc crashes

- SlaveUnit - 2010-12-12

Whats weird is that once you enable a playlist for the trivia...the playlist will play but nothing else after. It just returns to the XBMC interface.

Even without music enabled I don't get any trivia slides. Maybe I am missing something.

- giftie - 2010-12-12

Sting2010 - Download the new version from the repo and it will not crash while setting up the settings

SlaveUnit - I just completely uninstalled the one on my HTPC(deleted the folder in addons) and then downloaded it through the repo. It did look like it was not doing anything(though my router was showing data transfer) once I moved off the heading(just moved up) the download count changed to about 80%. then it completed the download.. Not sure where the problem lies(maybe a bug in XBMC's code or in the repo coding)

It should download though...

Nuka - thanks for the kind words.. and thanks for letting us update the script so it functions on Dharma...

- htpc guy - 2010-12-12

@ Nuka1195
I copied the locations verbatim from Natalus. I guess that's just how Linux handles spaces? I'm more of a windows guy myself but the Linux install came at the right price if you know what I mean. Anyway, I'm learning it.

I downloaded the latest version through your repository and got it working. The configuration menu works in Linux now and I copied the HTPC files (intro vides/ratings/DTS-THX stuff to my Linux machine and used the local paths. Everything works great.

There is only one remaining problem that I have found. Whenever I stop the movie my Linux Machine locks up and I have to go into the terminal (ctrl+alt+f1) and initiate a reboot. Let me know if you need a debug log. Its a bit late and I'm off to bed.

Again, thanks for all of the work that you guys have done (Nuka and giftie). And Nuka, its nice to see you around.

- giftie - 2010-12-12

htpc-guy - A debug log is always helpful(don't forget to use pastebin ) Strange that you are having a problem when stopping the movie, I us my linux htpc to test all my scripts(including this one, though it is running the most recent code from the trunk(svn))

but yes.. please post the xbmc.log file...

We'll find a solution..

- giftie - 2010-12-12

htpc-guy - and Linux Command line requires the escape coding for spaces(\ before the space) which I believe is the way XBMC interacts with Linux.

- macshield - 2010-12-12

answered my own question

- quebert - 2010-12-12

This addon's AWESOME, question though I'm looking at the settings.xml trying to figure out what I need to change to have the trivia only play for 2 minutes, and am stuck. Any help here?

- Ilia - 2010-12-12

Awesome work on getting the settings screen fixed, have been trying to fix that myself, but nothing I did worked.

This worked fine when I install this through the plugin repo, may I ask what you did?


- Tomkun - 2010-12-12

The script is creating the playlists perfectly, but it won't start playing it. I have to go into 'now playing' and start it manually. Anyone else having this trouble?