Kodi Community Forum
HQ OpenGL HW (GPU) upscalers from Bobo1on1? - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Kodi Application (https://forum.kodi.tv/forumdisplay.php?fid=93)
+--- Thread: HQ OpenGL HW (GPU) upscalers from Bobo1on1? (/showthread.php?tid=67486)

Pages: 1 2 3 4

- dinozzo - 2010-03-23

[email protected]:~# ls -la /usr/lib/libGL.so*
lrwxrwxrwx 1 root root 27 2010-03-04 09:20 /usr/lib/libGL.so -> /usr/lib/libGL.so.195.36.03
lrwxrwxrwx 1 root root 18 2010-03-23 18:56 /usr/lib/libGL.so.1 -> libGL.so.195.36.15
-rw-r--r-- 1 root root 742880 2010-03-16 03:14 /usr/lib/libGL.so.195.36.15

- Kali - 2010-03-23

wrong simlink, Nvidia Vdpau Team PPA ?

ln -fs /usr/lib/libGL.so.195.36.15 /usr/lib/libGL.so

- dinozzo - 2010-03-23

well theres good news and bad news! Smile Thanks kali you fixed the lGL issue. I did what you said and then ran the ls -la /usr/lib/libGL.so* command again. The first line that was red is now cyan so I ran ./configure --prefix=/usr again and we have success!

checking for main in -lGL... yes

now the bad news Sad

checking for main in -lGLEW... no


Does this help?

[email protected]:~# ls -la /usr/lib/libGL*
lrwxrwxrwx 1 root root 22 2010-03-23 18:56 /usr/lib/libGLcore.so.1 -> libGLcore.so.195.36.15
-rw-r--r-- 1 root root 23085696 2010-03-16 03:14 /usr/lib/libGLcore.so.195.36.15
lrwxrwxrwx 1 root root 16 2010-03-04 09:18 /usr/lib/libGLEW.so.1.5 -> libGLEW.so.1.5.1
-rw-r--r-- 1 root root 267532 2009-06-05 21:59 /usr/lib/libGLEW.so.1.5.1
lrwxrwxrwx 1 root root 27 2010-03-23 20:19 /usr/lib/libGL.so -> /usr/lib/libGL.so.195.36.15
lrwxrwxrwx 1 root root 18 2010-03-23 18:56 /usr/lib/libGL.so.1 -> libGL.so.195.36.15
-rw-r--r-- 1 root root 742880 2010-03-16 03:14 /usr/lib/libGL.so.195.36.15
lrwxrwxrwx 1 root root 20 2010-03-04 09:18 /usr/lib/libGLU.so.1 -> libGLU.so.1.3.070600
-rw-r--r-- 1 root root 456380 2009-10-13 23:08 /usr/lib/libGLU.so.1.3.070600

No red parts here

Is there an easy fix for this as I can see this happening over and over again with different libraries and me posting here asking how to fix each one. Is there anyway to remove everything and install it the right way?

- Kali - 2010-03-24

install libglew1.5-dev

- bobo1on1 - 2010-03-24

You know the README.ubuntu has that aptitude line right?

- ext23 - 2010-03-27

guys i am a total linux n00b but i really need to install this as i have about 1TB worth of SD videos!

i have root access via SFTP but when it comes to command line stuff i have no idea what i'm doing.

can somebody post a step-by-step as to how to install these custom shaders?

- mikkle - 2010-04-08


I have an Asrock ION 330 and I just can't get it to perform with the new scalers.
I've tested on svn trunk from a couple of hours ago, and I've tested with AlanWWW's method (Camelot + his patch). Same result.
When testing performance with Bobo1on1's method (no vblanc sync, play sd content (PAL DVD) pause, codec info, change between scalers) I constantly get something like:
Nearest Neighbor: 100-ish fps
Bilinear: 100-ish fps
Bicubic: 28-ish fps
Lanczos 2/3: 24-ish fps
Lanczos3 optimized 38-ish fps.

When choosing anything apart from bilinear/nearest neighbor, one of my CPUs max out at 100% - seems like the hard work never goes to the GPU...

Running Ubuntu Jaunty with nvidia drivers 195.36.15 from nvidia-ppa.

Could someone who has actually got this working be persuaded to publish his/her xorg.conf, so I can see if there's something obvious I've missed?

For the record, stuff in the BIOS is all set up properly.

How about related settings inside xbmc? I have render method set to auto. vblank sync is disabled, and currently I have disabled audio-sync (doesn't seem to influence this at all, though).

Also, what about stuff that can be set with nvidia-settings? - there are som scaling options in there, some opengl performance settings, etc. are they relevant at all?

Any suggestions?

Yours desperate truly
:O) Mikkle

- cbrunhaver - 2010-04-12

re-read the thread and corrected my response.

I have the same setup (Asrock 330) and will try this out as well (with the patch for camelot).


- liq456 - 2010-07-17

Is this built into the new versions of XBMC?

- spiff - 2010-07-17