Kodi Community Forum
XBMC live won't auto mount USB hard drive NTFS, please help! - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: XBMC live won't auto mount USB hard drive NTFS, please help! (/showthread.php?tid=73048)

XBMC live won't auto mount USB hard drive NTFS, please help! - rgboza - 2010-05-01

I have got the xbmc live on ubuntu karmic installed on my acer revo r3600 using the guide from this site. It is a fresh install (reinstalled a few times now just to make sure I didn't miss anything). I bought a WD Passport 500G USB drive (NTFS) and it didn't auto mount when I plug it in. I have since repartitioned it so that I now have 2 partitions, VOL1 250G fat32 and VOL2 250G NTFS. VOL1 with the fat32 formatting does auto mount but the VOL2 with the NTFS partition does not.

The frustrating part about it is that a friend of mine has the exact same setup (I bought everything the same and loaded everything using the same instructions) but his works fine and he also has a couple of 1TB USB drives that just plug in and work with NTFS.

Even more frustrating is that I've been looking round the forums for a couple of weeks now and still can't see any direct answers to my problem. I see lots of posts and links to other ubuntu problems which explain how to mount (mostly internal) drives but none with xbmc-live and how to get auto mount USB drives to work with NTFS partitions.

It should be possible as my friends setup works and according to him he never had to make any changes it just worked. Is there anyone out there that can help out here please?

Apologies in advance if I've missed a post about this somewhere.

- vikjon0 - 2010-05-01

if you have a "clean" xbmclive 911repack all you have to do is to format it as ntfs and plugin it in.
If you have not installed anyting else then I dont know what the problem is.
You could try to post the debug log (as per the instructions in the sticky)

I don't have a revo but perhaps you should flash the bios and check for any usb related settings.

I have an asrock 330, a 320G wd usb disk and a 620G samsung usb disk. It works fine with xbmclive. As long as I dont add any gnome stuff.

- talon95 - 2010-05-01

I've had this problem when the NTFS partition was not unmounted cleanly.
Windows will mount it but Linux won’t.
Try connecting the drive to a Windows computer and “Safely Remove Hardware”

Alternatively, you could try mounting the drive manually. There is help doing that in the Ubuntu forums.


- rgboza - 2010-05-03

Thanks talon95, indirectly that link helped me fathom out that the problem was with the USB hard drive, I got this message when trying to manually mount it:

Failed to read last sector (478624480): Invalid argument
or it was not setup correctly (e.g. by not using mdadm --build...),
or a wrong device is tried to be mounted,
or the partition table is crrupt (partition is smaller than NTFS),
or the NTFS boot sector is crrupt (NTFS size is not valid).
Failed to mount '/dev/sdb2': Invalid argument
The device '/dev/sdb2 doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

This was a brand new USB hard drive and didn't work out of the box so I used swissnife to repartition and format it as it didn't work in the first place, it did however work on windows after this and could see both the Fat32 and the NTFS drive so I didn't think there was a problem with the drive.

After seeing the above message I decided to look into formatting again and followed this guide on how to format USB hard drives for NTFS using windows:


I went back to having one partition again (that's how I wanted it in the first place) and after using the above guide I plugged in my USB hard drive and it now works fine.

So thanks very much and hope this might help anyone else that has USB hard drive NTFS problems.

This forum uses Lukasz Tkacz MyBB addons.