Kodi Community Forum
[LIVE] Complete EMUs/ROMs in Live (Acer Revo) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: [LIVE] Complete EMUs/ROMs in Live (Acer Revo) (/showthread.php?tid=73428)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15


- Izod517 - 2010-05-11

grassmunk Wrote:Last step: Using my game controller in XBMC. Any hints?

So I just switched to the Logitech Wireless Rumblepad 2, and it works great in games - but unlike the two wired Logitech controllers I was using, it is sending commands to XBMC. I'm in a different boat, I don't want it sending anything to XBMC! I think I'm going to have to rewrite keymap.xml to essentially ignore the gamepad?

EDIT:
Yup just added this to keymap.xml to disable the gamepad / joystick completely in XBMC.
Code:
<joystick name="Logitech Logitech Cordless RumblePad 2">
    </joystick>
Where the name of said joystick was found from xbmc.log

So I'm going to assume you can easily set up the joystick to work in XBMC by simply editing keymap.xml - but of course you're going to be sending commands to XBMC while you play the games... Unless I'm mistaken - anyways this worked for me for disabling.

Grass did you ever figure out a quickexit via gamepad for Gens? I've looked high and low with no results. I think Gerbils version of Gens can do it, but I don't see myself compiling another version of Gens for that when this one is working 100%. Your mednafen solution was brilliant.

Now I've just got to go through and do the boxart thing... Also I need to find a copy of MJ Moonwalker! Ha!


- henwy - 2010-05-11

TheDuffMan Wrote:Yea, unfortunately I can't help then short of modding a whole view, which I haven't learned to do.

I'm thinking the Revo can't handle mupen64plus, unless the secret is in using the audio plugins. But, I can't figure out how to setup and use the plugins. I think I also need a controller one because I don't get any keyboard response. Does anyone have a working n64 setup?

With Mupen64Plus I also have sluggish audio while XBMC runs on the background. Also it's playing much slower then it should. With XBMC closed and running Mupen64Plus from fluxbox audio is normal and everything is running much smoother (even getting owned by my GF in smash bros Sad). This is on an Asrock ION330 (2GB RAM).

So now I'm looking for a way to start Mupen64 (within fluxbox?) from the launcher plugin and have it close XBMC and restart afterwards it afterwards. Any thoughts on this?

PS In what repository is 'gens', package can't be found in my Live install.


- Izod517 - 2010-05-11

That's weird, I got my gens from the standard ubuntu repo. sudo apt-get update and sudo apt-get install gens was all it took for me.


- grassmunk - 2010-05-11

henwy Wrote:PS In what repository is 'gens', package can't be found in my Live install.

Neither could I!

The trick for me was installing mupen64plus then download the 8.04 .deb from the GENS/GS website and using dpkg -i to install it. It will tell you it's missing a package. apt-get install that package and it should work.


- Izod517 - 2010-05-11

That's so damn weird lol. I dunno maybe I did the same but I could have sworn to everything holy I got it right from the ubuntu repo. I've done so much command line in the past week it's hard keeping it all straight.


- TheDuffMan - 2010-05-11

I think i installed one of the emus from a download and not the repo. I think it was gens.


- Izod517 - 2010-05-12

Tried to edit OP for a correction on Gens but post is too long. Nod Oh well hopefully anyone needing this will read the entire thread as it's full of great contributions from Duff and Grass.


- thatjoshguy - 2010-05-12

This is probably a stupid question, I apologize ahead of time if it is. Followed this tutorial and was able to get ZSNES installed and the launcher working properly. Awesome work here folks!

My only problem is this: ZSNES will ONLY work in video modes 1-4. Anything else and it won't load either from the launcher or via command line. Don't get me wrong, 640x480 isn't the worst resolution ever for SNES games, but it isn't great either. I'd be happy with 800X600 at this point.

Acer Revo with minimal Ubuntu installation, XBMC installed via XCI, connected to my LCD TV. TV supports up to 1080i, but I've yet to get that to work (even in XBMC, so it's probably a related issue...). Best I've gotten to work in XBMC is 720p


- Izod517 - 2010-05-12

That's really odd - you should still be able to get ~720p working for ZSNES if you can get XBMC in 720p. Did you try setting a custom resolution in the cfg and using -v 22? What other arguments are you using?


- TheDuffMan - 2010-05-13

grassmunk Wrote:http://www.ressurectionxtras.net/

and

http://forums.xbox-scene.com/index.php?showtopic=660135

If you get the resurrection package from UG its really easy to make the covers show up. Just copy all the individual rom folders (or just the roms you want, I took US Licensed and Translated) and then copy over ALL the images to the same folder. Launcher will pick them all up no problem!

Oh boy... this post is a gold mine. You mean I don't have to find boxes manually? Big Grin

Unfortunately it looks like I'm just a bit late to the party on this and it's gone private. I have found boxes for snes online and will give it a shot tomorrow. If this works... it will be awesome. Now I just need to find the cover art for the other systems. All links seem to be down.


- djvj - 2010-05-13

TheDuffMan Wrote:Oh boy... this post is a gold mine. You mean I don't have to find boxes manually? Big Grin

Unfortunately it looks like I'm just a bit late to the party on this and it's gone private. I have found boxes for snes online and will give it a shot tomorrow. If this works... it will be awesome. Now I just need to find the cover art for the other systems. All links seem to be down.

I have invites on UG if you need an account to d/l the sets. But you do need to build up credit first.


- Izod517 - 2010-05-13

TheDuffMan Wrote:Oh boy... this post is a gold mine. You mean I don't have to find boxes manually? Big Grin

Yeah if someone would host just the covers package I would be very very VERY happy.


- djvj - 2010-05-13

Izod517 Wrote:Yeah if someone would host just the covers package I would be very very VERY happy.

The torrents don't work like that, they have 1-3 torrents for each system. They would all need to be d/l'd and covers combined into 1 zip.

I'll d/l some artwork and see how big they are.

edit: It would be about 2.4Gb for nes/snes/gen


- Izod517 - 2010-05-13

Damn.


- TheCooK - 2010-05-13

Hallo guys,

thanks for the nice guide and espescially for the patched Launcher scripts!

I followed all instructions and got zsnes running Super Mario Kart really nice.... But...

When i start a rom through the launcher it looks like its not the windows that gets the input... i can even use my MCE Remote control to navigate on XBMC - with znes running in front. Any idea what i can do to get xbmc going to background?

My Setup: XBMCFreak linux live installed, Acer Revo 3660, Mitsubishi HC1100 beamer (1280x720 max).

Thanks in advance,

CooK


This forum uses Lukasz Tkacz MyBB addons.