Kodi Community Forum
[LIVE] Complete EMUs/ROMs in Live (Acer Revo) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: [LIVE] Complete EMUs/ROMs in Live (Acer Revo) (/showthread.php?tid=73428)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15


- wolffmart - 2010-06-18

NEUR0M4NCER Wrote:Sorry, what I mean was it wasn't working through Launcher, so I started it through Terminal to try to get an idea of what was going on (if you catch my drift).

The framebuffer errors you are getting are due to Live lacking a windowing environment. You will not be able to run zsnes via terminal.

What errors are you getting when trying to run it with Launcher?
Have you modified your launcher_plugin.py as mentioned here?
http://forum.xbmc.org/showthread.php?tid=72441


- NEUR0M4NCER - 2010-06-18

Stupid me edited launcher_plugin.py incorrectly - games load up now, but I'm still left without sound... however considering what a daft mistake I made previously, I'll check everything again, to make sure.

Thanks for the help.


- joeshmoe - 2010-06-19

No sound for me either. Are you creating .asoundrc in home/xbmc/?


Something from me, PSX emulator in xbmc:) - scalpel - 2010-06-19

I have full ubuntu desktop so everything is clickable for me, if it will be needed i will do full console tutorial.

1. First need to install some libs to get emulator run.
1.1: libglib1.2ldbl_1.2.10-19_i386.deb
1.2: libgtk1.2-common_1.2.10-18.1_all.deb
1.3: libgtk1.2_1.2.10-18.1_i386.deb

2. Download psx emulator(epsxe) and unpack in your home folder: click

3. Type this syntax(change xxx to your login) in console, after that emulator should be working:
cd /home/xxx/epsxe160lin/
chmod +x epsxe
4. Look in internet for psx bios file(SCPH1001.BIN), and copy it to
/home/xxx/epsxe160lin/bios/
5. Look in internet for plugins to work emulator http://www.ngemu.com/plugins.php?cat=1&os=linux
files which in names have "libs, so" put into
/home/xxx/epsxe160lin/plugins/
files which in names have cfg put into
/home/xxx/epsxe160lin/cfg/
you can install all plugins and check everyone how works.
6. If you have full desktop you can run epsxe with double click and configure bios, plugins and run downloaded game(iso or bin) but if you want to do it from xbmc read next step.
Now need to get it work from xbmc, if you read this thread i think you have launcher in your xbmc. If not look on forum how to install it.

7. Run launcher and add new launcher:
If you want to configure emulator add standalone launcher to /home/yourlogin/epsxe160lin/epsxe
If you want to have all psx games automatically run from xbmc add file launcher(game emulator) to /home/yourlogin/epsxe160lin/epsxe
in arguments type "-nogui -sound -xasound -audiocd -loadiso"
select files path (for me its /home/mylogin/epsxe160lin/epsxe/patches/)
type extensions files to be auto findable should be just like in example: "iso|bin"
8. On the added launcher click right mouse button, or "c" on keyboard and select "import files from patch".
9. Run launcher and chose game and enjoy Big Grin


Tested on Ubuntu 10.04 Lucid Lynx.
Image

Image


- NEUR0M4NCER - 2010-06-19

.asoundrc is there...

While I think about it, does anyone else find home/xbmc/ very confusing? Using xbmc as the username is not the smartest move, in my opinion (which is why my username is 'revo', but then I have to do a double take on everything I read to make sure it's right).


- TheDuffMan - 2010-06-19

Did you run
Code:
sudo apt-get install libsdl1.2-alsa

That definitely had helped me.

Also, those PSX screenshots look awesome! I'd love to have that.


- NEUR0M4NCER - 2010-06-19

libsdl1.2-alsa returns "E: Couldn't find package libsdl1.2-alsa", so I tried -all which had no effect. Trying -esd now...

Nope. No sound in XBMC menu system either now. Great.


- TheDuffMan - 2010-06-19

Try libsdl1.2debian-all.


- NEUR0M4NCER - 2010-06-19

Thanks - I figured out the 'debian' suffix, so just going back to -alsa to make sure it works (and it does, I just heard the Alaska boot tinkle). Still no sound in zsnes with this, and I'm pretty sure that when I tried -all it picked up debian-all anyway, but I'll give it another go just to be sure.

*edit*

Nope, still no zsnes sound. Is there anything else I could try?


- NEUR0M4NCER - 2010-06-19

I am the WORST at this... For whatever reason, the .asoundrc had reverted to a previous state... so I have sound now - YAY! Thanks for your help and patience. One final question: Is there a way to assign a remote button to exit zsnes (as in if I edit the keymap so that in Program view '0' counts as Esc or '/')? Or perhaps use a joypad button - I'm using a Saitek PC PS2-Style... perhaps one of those extra shoulder buttons?


- NEUR0M4NCER - 2010-06-19

Has anybody had a look at Kega-Fusion which covers ALL Sega systems up to 32X (inc. Master System)? This is supposed to be a very good emu.


- m3g4tr0n - 2010-06-19

@scalpel - are you running the psx emu on a revo?


- scalpel - 2010-06-19

No on, asrock 330ht and notebook, why you ask? Maybe i post in bad thread bad this thread inspired me to check this out and i think it will be good to have instruction all emulators together.


- m3g4tr0n - 2010-06-19

i just didn't think the ION330 was powerful enough to run the PSX emu. can you post a console tutorial for those who have a live install.


- scalpel - 2010-06-19

man, i have fps limited in configuration if not it is too fast to play, were talking about psx not playstation 2 Smile it's have 16 year oldSmile please check it and post your problems, i tested it on a netbook with atom n270 and intel gma 950 graphics and it is really playable.

console tutorial will be, just need time to wrote.


This forum uses Lukasz Tkacz MyBB addons.