Kodi Community Forum
[LIVE] Complete EMUs/ROMs in Live (Acer Revo) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: [LIVE] Complete EMUs/ROMs in Live (Acer Revo) (/showthread.php?tid=73428)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15


- TheDuffMan - 2010-06-20

I'm surprised it runs smoothly on the ion330 too... i still don't think it's worth trying on my revo though. maybe with that launcher script that stops xbmc to free up resources. anyone give it a shot?


- magimog - 2010-06-23

There is something I am seriously not getting, every time the script gets done loading I crash out of X and restart XBMC. I'm running XBMC Live installed to hard disk. Could someone comb over my files to see what I'm missing?

Judging by the crash log Launcher isn't seeing my roms, but they are all .smc files and the games are recognized in the dialog box before the crash.

Heres how my two edits look in launcher_plugin.py, assuming I followed directions completely.
First (already done as per instructions):
Code:
elif (sys.platform.startswith('linux')):
                    #this minimizes xbmc some apps seems to need it
                    xbmc.executehttpapi("Action(199)")
                    os.system("%s %s" % (launcher["application"], launcher["args"]))
                    #this brings xbmc back
                    xbmc.executehttpapi("Action(199)")
Second:
Code:
elif (sys.platform.startswith('linux')):
                        xbmc.executehttpapi("Action(199)")
                        os.system("\"%s\" %s \"%s\"" % (launcher["application"], launcher["args"], rom["filename"]))
                        xbmc.executehttpapi("Action(199)")

Launchers.xml :
Code:
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<launchers>
        <launcher>
                <name>Zsnes</name>
                <application>/usr/bin/zsnes</application>
                <args>-m -s</args>
                <rompath>/mnt/emu/snes/roms/</rompath>
                <romext>smc</romext>
                <thumb></thumb>
                <wait>true</wait>
                <roms></roms>
       </launcher>
</launchers>

And my XBMC crash log

Any direction at all would help me make up for hours of lost sleep Sad

Just tested all the other emulators, exact same problem. What am I missing?


- wolffmart - 2010-06-24

Have you tried to manually add some roms to your launchers.xml?


- magimog - 2010-06-24

wolffmart Wrote:Have you tried to manually add some roms to your launchers.xml?

Ehh I got it. I honestly dont know WHAT, but after the 3rd time reinstalling the plugin and wrapping the two lines it got going.

OP I think you should edit your post with fcorbier's launcher.sh modification. The resources freed should trump any sound issues across the board, and allow for more emulators (mupen64) to be added. The fact that it sleeps XBMC and snaps back mid-playback is mind blowing!

I'm looking into how to setup xboxdrv (for XB360 controllers) to be loaded and shut down when the emu is closed.

I had it originally to run xboxdrv, then sleep for 2s, run fcorbiers params, and then attempt to kill the process when XBMC loads again. There is probably a more graceful way of accomplishing this (it barely works). Does anyone have any ideas?


- teeedubb - 2010-07-01

I found some nice transparent icons for use with XBMC. They can be found here:

http://www.rotheblog.com/2008/02/arcade/gaming-console-icons-for-mame/

Theres also some liniks to other icon sets at the bottom of the page.


- TheDuffMan - 2010-07-02

Thanks for sharing. These look really good.


- NEUR0M4NCER - 2010-07-04

I'm in the process of trying it on my Revo 1600, so I'll let you know how it woks out.


- teeedubb - 2010-07-04

Although Ive switched my xbmc machine from the dual core atom running live to a quad core desktop pc running windows, Ive come across some useful links which Ill post here because it relates to the topic:

Hyperspin A front end for launching roms, theres heaps of cover art, system icons and other goodies here. You need to register but its worth it. Also on this site is the Hyperlist section, this contains .dat files for use with clrmamepro, which is a handy app that renames and catalogs your roms to the No-Intro style naming convention/database. No-intro are the new GoodTools.
To match up cover art to the rom name I found an app called fuzzyrename, its a mega time saver, although i have noticed it has troubles with sequels so you sometimes end up with a few games with the same covers as others. (I had alot more troubles renaming the ressurection extras coverart as they are named with goodtools, while my roms were named with no-intro data)
Theres also cdcovers.cc which is handy for more recent covers and both snesorama and emuparadise have great communities.

EDIT: Maybe someone can help me out with this.... Im looking for some software that can rename entries within certain tags in a .xml file. Id like to rename all the roms in my collection in launchers.xml to capitals, currently the launcher plugin only capitalizes the first letter of the rom name, regardless of the roms filename. Although its nothing major, it just bugs me Smile Ive tried with notepad++ but I couldnt seem to find the option I was looking for...


- bmfrosty - 2010-07-05

No gens on 10.4. DGEN though. It seems to run, but I haven't figured out how to configure the joypads. Any ideas?


- TheDuffMan - 2010-07-18

I wanted to learn git and decided to create a fork with the changes I made on page 1 here for Alaska.

So, if you go to http://github.com/nmunson/Alaska, you can now grab Alaska with the necessary changes made to the Programs section to allow for the Panel view like the screenshots in the OP.


- laukarlueng - 2010-07-19

I've followed the directions here as best as I can tell, but I have a problem when I say "Ok" to Launcher asking if I want to import files (ROMS) from path. XBMC locks up and won't respond to many keystrokes. I can use the keys CTRL + ALT + F1 to go to terminal and reboot, but no other keystrokes seem to have any response.

Any ideas about what I've done wrong?

My user name isn't "xbmc". Could that be throwing anything off?

Any help is appreciated. Smile


- teeedubb - 2010-07-23

laukarlueng: I had the same problem, and having an empty launchers.xml file causes this(or maybe there was no launchers.xml file, I cant remember right now, but it doesnt really matter). Manually add your first launcher to the .xml file and the rest will be addable through the GUI.


- ShadeBlack - 2010-08-08

i have the exact same problem as laukarlueng.

the launcher asks to scan for roms, but when i click ok xbmc seems to crash and end up at the login terminal.

I decided to start everything again and followed the instructions of this thread and the others but i end up with the same problem.

my launchers.xml looks like this:

Code:
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<launchers>
        <launcher>
                <name>Super Nintendo</name>
                <application>/usr/bin/zsnes</application>
                <args>-m -s -v 15 </args>
                <rompath>/home/xbmc/roms/snes/</rompath>
                <romext>smc</romext>
                <thumb>/home/xbmc/roms/snes/thumb.jpg</thumb>
                <wait>true</wait>
                <roms></roms>
       </launcher>
</launchers>

changing the arguments do nothing as it never seems to load the application.
the folder paths are correct and tripple checked for case sensitivity. The roms do not have spaces in them. Manually adding the roms in the <roms></roms> tags does nothing to help either.

I checked the permissions of the launchers.xml in putty and corrected them using:
Code:
sudo chown xbmc:xbmc luanchers.xml
&
sudo chmod 666 launchers.xml
~both worked but do not change the outcome of my problem.

I just don't see what's wrong really.

for reference, I am using:
the patched launcher,
the "Acer Aspire Revo model: R3610".
using HDMI out to a bose media hub.

any help on this would be most appreciative.


- starcitysecrets - 2010-08-20

anyone found a handy way of exiting out of mednafen and mupen64plus via the gamepad as of yet?

im so thrilled I managed to get all these emulators working perfectly. this has made my media center so much better.

great tutorial!


- dark0n3 - 2010-08-20

Not using the gamepad for exit but a button on my remote, calling a script with killall, its brutal, but it works Big Grin


This forum uses Lukasz Tkacz MyBB addons.