Kodi Community Forum
[RELEASE] Logo Downloader Script - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=151)
+---- Thread: [RELEASE] Logo Downloader Script (/showthread.php?tid=74912)

- Reginald - 2010-09-01

You can always install a skin (for now) that allows you to run the script. Night and Shade both allow you to do this. Or like ppic said you can add it to the skin yourself. Hope that helps!

- thezoggy - 2010-09-24

I am using windows xbmc dharma2 beta with confluence skin as default.
I came across your plugin and have been v1.3 without any problems (I did the tv show logo mod for confluence to make logo's appear in the view I want). The script worked great but there were a few tv shows it was having a problem finding logos for, so I decided to look into upgrading.

I noticed that you are up to v2.0 and that it is part of the offical repo now.
I removed the old 1.3 logo downloader plugin via xbmc and made sure the directory was gone in my roaming profile/xbmc/addons location.
I used the add-on repo in xbmc to try and d/l the latest version but it never appeared that it worked. (not confirmation that addon was installed). I went and found the downloaded addon package in my roaming/xbmc/addons/packages/script.logo-downloader-2.0.0.zip and tried installing in xbmc via file. I showed that it extracted the folder to my addon directory but I never got any notification that the plugin installed.
I looked over the post and saw that I need to modify my addon.xml.
There are a bit of addon.xml files but I infer that the one I should be modifying for the skin I'm using is:
c:\Program Files (x86)\XBMC\addons\skin.confluence\addon.xml
After modifying this file so that my required section shows:
Quote: <requires>
<import addon="xbmc.gui" version="2.11"/>
<import addon="script.recentlyadded" version="1.0.4"/>
<import addon="script.logo-downloader" version="2.0.0"/>
I restarted xbmc but no change. I have tried uninstalling and reinstalling the addon but nothing seems to matter.

How do I check to see if it really is installed and have it check for new logos?
I miss being able to just go to programs>tv logo downloader and have it search.
Is this previous script functionality been replaced by having to run the bulk search command? And if so, how do I add it under programs or make it run remotely?

- thezoggy - 2010-09-25

Okay I figured it out, so the addon that I used to know (1.3 days) is really nothing more than just a script now.. that you have to execute manually -- but you have to add to the skin gui since it really is not an addon anymore.

One thing I do not like about the 2.0 of this script is the lack of a summary when it completes running. It just runs and quits... you don't know if it really found anything or not (if it does find something it downloads it so quick that its gone before you can read anything).

I added the logo downloader to my Home screen under the "TV Shows" section in the confluence skin. Note that I only have it download the logo and set everything else to false.

For anyone else that cares, here is my confluence tutorial below.

Go to your XBMC installed directory and open the file:
search for the line:
add this right after:
Quote: <control type="button" id="90170">
<label>Check for Logos</label>

Now when you go to TV Shows >
you should see;
Check for Logos
Recently Added

-- enjoy.

- ppic - 2010-09-25

thezoggy Wrote:One thing I do not like about the 2.0 of this script is the lack of a summary when it completes running. It just runs and quits... you don't know if it really found anything or not (if it does find something it downloads it so quick that its gone before you can read anything).

i can change that

- thezoggy - 2010-09-25

ppic Wrote:i can change that

That would be awesome. Possibly give it another argument that the user can set when calling the script (showSummary=true) so those that want the summary can have it and those that dont can disable it.

I liked the 1.3 summary (showed how many tv shows completed and if anything was downloaded)
thanks again for your time and efforts Smile

- prae5 - 2010-09-29

I had this working without any issues in the past, I've just reinstalled box a linux box and my mac and tried to use it and it is failing in the same way on box platforms. Looking at it it seems to have problem with string encodings...?

10:48:41 T:2765015920 M:759242752   ERROR: Error Type: <type 'exceptions.SyntaxError'>
10:48:41 T:2765015920 M:759242752   ERROR: Error Contents: ("Non-ASCII character '\\xe9' in file /storage/.xbmc/addons/script.logo-downloader/default.py on line 173, but no encoding declared; see [url]http://www.python.org/peps/pep-0263.html[/url] for details", ('/storage/.xbmc/addons/script.logo-downloader/default.py', 173, 0, None))
10:48:41 T:2765015920 M:759242752   ERROR: SyntaxError: ("Non-ASCII character '\\xe9' in file /storage/.xbmc/addons/script.logo-downloader/default.py on line 173, but no encoding declared; see [url]http://www.python.org/peps/pep-0263.html[/url] for details", ('/storage/.xbmc/addons/script.logo-downloader/default.py', 173, 0, None))

Is this a know issue with the current release?

- ppic - 2010-09-29

that's not what make the script fails, i've got some hardcoded sting using "é" which is causing the message but it's non blocking.

- spiff - 2010-09-29

even if it's not a deal breaker, that is nasty.

- prae5 - 2010-09-29

OK, if it's not that can you give me some pointers on how to debug this.

Here's a debug of it running under osx http://pastebin.com/LbktLG0y and the same for my linux box http://paste.pocoo.org/show/268950/

Just tested on a windows box under beta1 and beta2 and everything works as expected, however under osx and linux its a no go. Is this a known issue - is there anything i can do to help debug this?

- ppic - 2010-09-29

spiff Wrote:even if it's not a deal breaker, that is nasty.

how can i handle that other than suppress my caracters?

Prae5, i've checked your logs

for the linux box, my opinion is the script doesn't found your tvshows:

13:25:20 T:2953850880 M:1003429888  NOTICE: ### Start Bulk Mode
13:25:20 T:2953850880 M:1003429888  NOTICE: ### get tvshow list
13:25:20 T:2953850880 M:1003429888    INFO: Loading skin file: DialogProgress.xml
13:25:20 T:2953850880 M:1003429888   DEBUG: Load DialogProgress.xml: 18.62ms
13:25:20 T:2953850880 M:1003429888   DEBUG: DialogProgress::StartModal called
13:25:20 T:2953850880 M:1003429888   DEBUG: ------ Window Init (DialogProgress.xml) ------
13:25:20 T:2953850880 M:1003425792   DEBUG: Alloc resources: 1.67ms (0.01 ms skin load)
13:25:20 T:2689393920 M:1001127936   DEBUG: HttpApi Start command: QueryVideoDatabase  paras: QueryVideoDatabase; select tvshow.c00 , tvshow.c12 , path.strPath from tvshow , path , tvshowlinkpath where path.idPath = tvshowlinkpath.idPath AND tvshow.idShow = tvshowlinkpath.idShow
13:25:20 T:2953850880 M:1001058304  NOTICE: ### xml data:
seems that he gets nothing from httpapi.
just to be sure, you have some tvshow in librairy?

for the mac log, my script is simply not starting but really don't know why,
well maybe that encoding there... don't know about mac so much, i'll try to suppress that encoding error and get you a version to test.
the first line that should appear when launching the script is :
NOTICE: ### Logo Downloader starting ...

- spiff - 2010-09-29

ppic, you're probably treating a utf-8 string with a different locale, or you're treating a non-unicode string as unicode. simplest fix is probably to use the u prefix in python.

u"foo" = a unicode string
"foo" = a string in the configured locale.

- ppic - 2010-09-29

ok, i'll try that, thx

- prae5 - 2010-09-29

Have done a little more testing, and have partly resolved this.

1. OSX - completely resolved. Web server was disabled on this box. Enabling it fixed things - i didn't actually realise this was a requirement for the script to run. It should give an error about this in the log. Verified working with both local and mysql database.

2. Linux - going to do a little more checking and will post back soon.

- prae5 - 2010-09-29

OK have checked web server is running on the linux box and it is.

Tried running script and failed, tried to download a single logo too and that failed.


- ppic - 2010-09-29

ok i thought that local webserver was always on Sad
i'll see if i can check that.

the behaviour you have in linux is strange, script doesn't seems to launch too here !