Kodi Community Forum
CouchPotato - Automatic Movie Downloader via NZB & Torrents - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (https://forum.kodi.tv/forumdisplay.php?fid=116)
+--- Thread: CouchPotato - Automatic Movie Downloader via NZB & Torrents (/showthread.php?tid=75960)

- DejaVu - 2010-07-10

I know I'm not the only one thinking this, but this excellent program needs to integrated into XBMC.

I know it's still early days, but are there plans for a XBMC script to be made for this?

BTW, the logo descriptions for quality's, I can make some small pixel logo's up if you like to show up instead.

- RuudBurger - 2010-07-10

I have no idea what is needed, to integrate it in xbmc. And what you expect from it. So no plans yet.

Some pixel logos would be awesome. Just make sure they can form a nice little block. As I want the unused still be in there but greyed out.

- mwkurt - 2010-07-10

I got it working last night...finally! But I guess I have a stupid question for you. After a computer restart, or shutting down the browser, how do I go about getting the interface back in Firefox?
I tried calling http://localhost:5000, but that didn't work. I also tried double clicking on the moviemanager.exe file, and that didn't work. What do I do?


- RuudBurger - 2010-07-10

You have to run the .exe file and then go to localhost:5000 Big Grin.
So if you want to always keep it running, put a shortcut to it, in your startup folder.

- mwkurt - 2010-07-10

Thanks, but I tried that and it didn't work, so I deleted everything and reloaded the program and got it back.

A couple of thoughts:

I added a film "Murder (1930)", It is 815 days old on NZBs.org. Anyway, MM came back with 7 different movies, the first being "Who Framed Roger Rabbit". That wasn't the problem though. It seems that when MM doesn't come back with your movie, but a list of movies instead, you have to add one of the wrong movies to your queue to be able to add a new movie to search. The entry list thingy doesn't reset for a new entry.

Also, I added a list of 16 movies to my queue. The first 2 I did a "force check" to go and pick up the nzbs to transfer to SAB, which it did. The remaining 14 films in my queue will not go out to grab the nzb file no matter whether I try "force check" at the bottom of the page or "force search" in the movie listing. The page just reloads and no search occurs.

You said to put a shorcut to it in the startup folder? Is that a shortcut to "Moviemanager.exe"? Will that start Movie Manager in the browser or will that just start the service, or does it not matter?
I am using Movie Manager r8.

Thanks for all your help!

- Mrkennedy - 2010-07-10

Yes the .exe file in start up. It will just start the service. If you want to load the browser either add it to your tabs when you open firefox/ie or add it as a shortcut on the toolbar in firefox

- DejaVu - 2010-07-11

Loading on Startup isnt a probem. Can you implement a /s switch for silent? So the browser does load as well?

I havent tried it yet, but can see that happening (does it?) will look now! Smile

- darkscout - 2010-07-11

RuudBurger Wrote:What is the problem with "The Girl with the Dragon Tattoo"? I can add that one, or the original title.

Ill add the blackhole on my todo list.

When I add it from the IMDB userscript it adds "Män som hatar kvinnor", probably something to do with the API or scraper grabbing that title and not the english one.

- Flomaster - 2010-07-11

I am running ubuntu and I am very noobish with little linux know how.

can some one hold my hand and walk me through the install process because I was unable to figure it out on my own reading the GITHUB website.


Install Python 2.6 or higherYES, I have this
Git clone/extract MM wherever you like I have no idea what, where, or how, to do this
Run "python MovieManager.py -d" to start in deamon modeif I knew how to install I could do this
Set your username & password in the settings if you want.if I knew how to install I could do this
Fill in all the config stuffif I knew how to install I could do this
Ubuntu (init.d script):

Copy "initd" to /etc/init.d/moviemanager - > "sudo cp initd /etc/init.d/moviemanager"
If you want, change "RUN_AS=root" to another user.
Make executable "sudo chmod a+x /etc/init.d/moviemanager"
Start "sudo /etc/init.d/moviemanager start"


- RuudBurger - 2010-07-11

In settings Wink

Ah, didn't check the IMDB script yet. I'll see what I can do. In the main time, add foreign movies via MM itself. It should give you more languages.

sudo apt-get install git-core
cd /usr/local/sbin/
git clone git://github.com/RuudBurger/Movie-Manager.git moviemanager
cd moviemanager
from here, run the .py script. or run MM via the init.d script.

- Flomaster - 2010-07-11

RuudBurger, thanks I got it installed and working flawlessly or so I think.

I just ready every post and have a couple questions
should this be adding nfo files or thumb1.jpg thumb2.jp
if not is there a Ubutu program to scan my movies and add this info much like Sickbeard does?

I am not sure if it worked correctly for me.

I have my SABNZBD setup like this..

Download to /mnt/1TB/unsorted.media/complete

then in the category field for movies I have:
scriptBig Grinefault
folder paths: /mnt/1TB/Movies

so as you can see I have I sab move my movies from the complete folder to my movies folder.

but when I just downloaded Toy Story I ended up with a folder name of:

and a file name of:

my settings for MM for renaming are:
I have enable ticked
download folder is: /mnt/1TB/unsorted.media/complete
Move destination: /mnt/1TB/Movies
folder naming:<namethe> (<year>)
file naming:<thename><cd>.<ext>

do I have the wrong settings, because Sab is moving my finished movie to /mnt/1TB/Movies should I have that set as my download folder and leave the move destination blank?


- RuudBurger - 2010-07-11

You have to keep the movies in the download folder, MM will do the renaming and move the file to the directory you have set in Settings.

- Flomaster - 2010-07-12

EDITConfusedo I changed SAB to leave my download in the complete folder and MM took care of renaming and moving the file to my movies dir. YUS!

ok not a problem I'll change that up in Sabnzb


- darkscout - 2010-07-12

I tried the trick with adding the english name from the search box.
The Girl with the Dragon Tatoo worked.

However The lives of others didn't and keeps resolving to Das Leben der Anderen

Also, when ever I add a movie, I get this error:
500 Internal Server Error

The server encountered an unexpected condition which prevented it from fulfilling the request.

Traceback (most recent call last):
  File "/home/downloader/Movie-Manager/cherrypy/_cprequest.py", line 606, in respond
    cherrypy.response.body = self.handler()
  File "/home/downloader/Movie-Manager/app/config/render.py", line 13, in __call__
  File "/home/downloader/Movie-Manager/cherrypy/_cpdispatch.py", line 25, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "/home/downloader/Movie-Manager/app/controllers/movie.py", line 20, in index
    movies = qMovie.order_by(Movie.name).filter(or_(Movie.status == u'want', Movie.status == u'waiting')).all()
  File "/home/downloader/Movie-Manager/library/sqlalchemy/orm/query.py", line 1422, in all
    return list(self)
  File "/home/downloader/Movie-Manager/library/sqlalchemy/orm/query.py", line 1534, in __iter__
    return self._execute_and_instances(context)
  File "/home/downloader/Movie-Manager/library/sqlalchemy/orm/query.py", line 1539, in _execute_and_instances
  File "/home/downloader/Movie-Manager/library/sqlalchemy/orm/session.py", line 734, in execute
    return self._connection_for_bind(engine, close_with_result=True).execute(
  File "/home/downloader/Movie-Manager/library/sqlalchemy/orm/session.py", line 699, in _connection_for_bind
    return self.transaction._connection_for_bind(engine)
  File "/home/downloader/Movie-Manager/library/sqlalchemy/orm/session.py", line 298, in _connection_for_bind
  File "/home/downloader/Movie-Manager/library/sqlalchemy/orm/session.py", line 233, in _assert_is_active
    "The transaction is inactive due to a rollback in a "
InvalidRequestError: The transaction is inactive due to a rollback in a subtransaction.  Issue rollback() to cancel the transaction.

If I hit refresh I get back to the home page and the movie is added though.

Latest git (as of 5 minutes ago)

- Flomaster - 2010-07-13

I am having problems getting this to autostart, once I rebooted it was no longer working. I have to type in the bit to get it started. I have done the init.d thing, I have changed user=root to user=jason I have no idea.

I am running Ubuntu 10.04