Kodi Community Forum
CouchPotato - Automatic Movie Downloader via NZB & Torrents - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (https://forum.kodi.tv/forumdisplay.php?fid=116)
+--- Thread: CouchPotato - Automatic Movie Downloader via NZB & Torrents (/showthread.php?tid=75960)

- RuudBurger - 2010-11-05

Yeah the git updater was working for me to, but it gave to much problems for others.

- gugahoi - 2010-11-05

Any updates? Just got the latest version from git and I can't even access CP. I get a bunch of error on OS X.

- RuudBurger - 2010-11-05

Why dont you post those errors. So i can do something about them Wink

- hotlobster - 2010-11-05

Something occured since latests updates.

Few days ago, i was accessing my couchpotato behind apache with http://host/couchpotato/

My apache is configured to proxy to couchpotato like this:

[HTML]ProxyPreserveHost On
<Location /couchpotato>
ProxyPass http://localhost:5000
ProxyPassReverse http://localhost:5000

and couchpotato have urlbase = couchpotato

Since the update, now if i use http://host/couchpotato , it redirects to http://host/movie and not http://host/couchpotato/movie ( this one is working directly ).

This was not the case few days ago.

If i revert this commit it works again: https://github.com/RuudBurger/CouchPotato/commit/70f2abe9eca0c963b4e6ff3ae5b06c991eb257b3


- smithr99 - 2010-11-05

please could we see an option to always show details on the wanted screen ? I like seeing the movie pictures - plain text bores me!!

Also, (this may just be my opinion!), when scrolling down, the menu at the top isn't as opaque as I would like it - the overlapping text gets a bit awkward imho. Any chance of upping the opacity on it ?

Many thanks for the awesome app!

- cosmicr - 2010-11-05

couple of requests:

could we get a test message to xbmc to make sure the connection is working

and also the ability to change the quality setting for a movie once it's added to the list.

thanks! keep up the great work!

- RuudBurger - 2010-11-05

Just wanted to ask, if the updater is working like it should for you guys?

I changed the mod_proxy stuff a bit, PreserveHost isn't needed anymore. Could you try and see if it happens without it?

It should save the setting in a cookie.. Could you make a ticket for this on Github? It seems to fail..

For requests, please make a ticket on github Big Grin

- RuudBurger - 2010-11-05

nvm, fixed it Wink

- smithr99 - 2010-11-05

RuudBurger Wrote:@smithr99
nvm, fixed it Wink


any thoughts on the title opacity ?

- hotlobster - 2010-11-05

I changed the mod_proxy stuff a bit, PreserveHost isn't needed anymore. Could you try and see if it happens without it?

Ah removed it and it works effectively.


- battletux - 2010-11-05

Having been aware of CouchPotato for ages I've finally managed to find the time to get around to installing it. However I've hit a snag and was wondering if anyone could help me out.
Not having used git before I'm following a guide here but on checking out I get an error (using the following url for the git repo http://github.com/RuudBurger/CouchPotato.git):
walk 6e1e6ff3cf9dc5135ca4efd86a9d41341a58ebbc
Warning: Remote HEAD refers to nonexistent ref, unable to checkout.

I tried both yesterday and again this evening to no avail. Each time I have retried I've rm -r'd the couchpotato folder so to have a 'clean' slate.

I have also tried to use the https repo (as on RuudBurger's git page) but I get this error:

/usr/local/sbin$ sudo git clone https://github.com/RuudBurger/CouchPotato.git
Initialized empty Git repository in /usr/local/sbin/CouchPotato/.git/
Cannot get remote repository information.
Perhaps git-update-server-info needs to be run there?

I'm installing on an old Ubuntu derivitive (I forget which) that is based on Hardy.

Hopeing someone could point out what I'm doing wrong. Thanks.

- RuudBurger - 2010-11-06

Maybe there was something wrong with github, but it seems to work fine here.

elmo:Python Ruud$ git clone http://github.com/RuudBurger/CouchPotato.git test
Cloning into test...
remote: Counting objects: 5688, done.
remote: Compressing objects: 100% (2102/2102), done.
remote: Total 5688 (delta 3684), reused 5435 (delta 3498)
Receiving objects: 100% (5688/5688), 3.50 MiB | 1.48 MiB/s, done.
Resolving deltas: 100% (3684/3684), done.

- Diekund - 2010-11-06

hrmm my couchpotato doesnt seem to have been working for a few days since i last updated. cant load up in the browser or anything

- RuudBurger - 2010-11-06

Without more info, I can't help you...

- MikeBuzz - 2010-11-06

One quick question

I have setup CP to download using sabnzbd, and have the options set that CP moves and renames the download, but on the wanted page the movies are still listed at snatched and not downloaded, any ideas??