Kodi Community Forum
AudioEngine branch - DO NOT REQUEST BINARY BUILDS - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Kodi Application (https://forum.kodi.tv/forumdisplay.php?fid=93)
+--- Thread: AudioEngine branch - DO NOT REQUEST BINARY BUILDS (/showthread.php?tid=78289)



- Callek - 2012-01-10

rakker Wrote:If you're on *nix u can try the GT210 (or maybe also GT220) if u still have those. I tried DTS-HD and TrueHD passthrough on the GT210 (Asus) which worked.

Interesting! I have the same card (well an Asus GT210 anyway), running OpenElec latest nightly.

Could you give me some pointers how to get it working? (PM, perhaps so we don't let this topic go more OT...)


- rakker - 2012-01-10

Callek Wrote:Interesting! I have the same card (well an Asus GT210 anyway), running OpenElec latest nightly.

Could you give me some pointers how to get it working? (PM, perhaps so we don't let this topic go more OT...)

Pretty easy actually. Most of the info i used came from this thread or http://wiki.xbmc.org/index.php?title=HOW-TO:Setup_HDMI_audio_on_GeForce_GT210,_GT220,_or_GT240

I Used a minimal install of ubuntu 11.10,
  • apt-get build-dep xbmc to get all build dependency's
  • apt-get install nvidia-common
  • build EA branche (with --disable-pulse --enable-alsa)

As for the card config

I used probe_mask=0xfff2 and configured hdmi as output in XBMC (If u have onboard audio then it's easiest to disable that in bios).

After that it worked like a breeze Smile.

I guess getting the correct audio output dev for also for XBMC config can be a bit tricky. U could probably also get it to work without the probe mask and using the hdmi: alsa string from aplay -L that corresponds to device 7
i.e. for a gt520 i configured a custom throughput device with "hdmi:CARD=NVidia,DEV=1"

U might need to play a bit to get the correct device with or without the netmask.

I guess that as long as you're dmesg output says something like :
Code:
[   24.865571] HDMI: supports coding type E-AC-3/DD+ (Dolby Digital Plus): channels = 8, rates = 44100 48000
[   24.865574] HDMI: supports coding type DTS-HD: channels = 8, rates = 44100 48000 96000 176400 192000 384000
[   24.865577] HDMI: supports coding type MLP (Dolby TrueHD): channels = 8

It should (eventually) work.

btw: I am using an Onkyo 606 receiver

EDIT:

And if you're lazy (as i am) also install xbmc and xbmc-live.

After that edit
Code:
/usr/bin/xbmc-standalone

and change the line "XBMC=" to the location of xbmc.bin you just compiled
i.e.
Code:
XBMC="/home/xbmc/xbmc/xbmc.bin $@"

Now you're self compiled xbmc also auto starts on boot
And every once in a while
Code:
git pull
make



- cmonpellier - 2012-01-11

I was excited with Eden cause I thought it would bring bit-streaming. Although it is a nice release I think it is really missing... Sad


- Balthazar2k4 - 2012-01-12

cmonpellier Wrote:I was excited with Eden cause I thought it would bring bit-streaming. Although it is a nice release I think it is really missing... Sad

I agree. I believe the lack of HD audio bitstreaming is a huge oversight in this day-and-age. Blu-Ray is going on five years old and yet XBMC still cannot handle the audio properly without an external player. I don't really care if you don't see the value in lossless audio. I have a very significant investment in my home theater and want to get every pennies worth. I detest the GUI of my Netgear NeoTV 550, but at least it plays all of my movies without issue in full 1080p/24 with HD audio bitstreaming reliably.


- GreenEyez - 2012-01-12

Balthazar2k4 Wrote:I agree. I believe the lack of HD audio bitstreaming is a huge oversight in this day-and-age. Blu-Ray is going on five years old and yet XBMC still cannot handle the audio properly without an external player. I don't really care if you don't see the value in lossless audio. I have a very significant investment in my home theater and want to get every pennies worth. I detest the GUI of my Netgear NeoTV 550, but at least it plays all of my movies without issue in full 1080p/24 with HD audio bitstreaming reliably.

If you`re on Windows, you can always get DSPlayer with ffdshow or LAV splitters and get HD audio bitstreaming.

PS : Awesome gear btw (looking at your signature and drooling)


- Balthazar2k4 - 2012-01-12

GreenEyez Wrote:If you`re on Windows, you can always get DSPlayer with ffdshow or LAV splitters and get HD audio bitstreaming.

PS : Awesome gear btw (looking at your signature and drooling)

My problem with DSPlayer is that it is no longer actively maintained and way behind on the latest updates (such as Eden). So, yeah, I could make it work, but in many ways it isn't any less of a pain than using MPC-HC. Oh well, I'll keep monitoring the situation and dreaming of the day that XBMC is "complete" for me.

As for the gear, well, that was a slew of purchases made last year much to wife's dismay. Big Grin It is pretty awesome though. Thanks!


- liquidskin76 - 2012-01-12

Balthazar2k4 Wrote:My problem with DSPlayer is that it is no longer actively maintained and way behind on the latest updates (such as Eden).

It back in development by tiben. Plus it's being merged with nightlies so it's right there with Eden builds...

http://forum.xbmc.org/showthread.php?tid=106629


There's even a pull request to have it merged in to the nightlies however that won't happen until Eden's out the door...

https://github.com/xbmc/xbmc/pull/591

Cheers Wink


- Drae - 2012-01-12

Tiben and 0wing are working on DSPlayer again - indeed there is a pull request to merge it into trunk post-eden.


- Balthazar2k4 - 2012-01-12

liquidskin76 Wrote:It back in development by tiben. Plus it's being merged with nightlies so it's right there with Eden builds...

http://forum.xbmc.org/showthread.php?tid=106629


There's even a pull request to have it merged in to the nightlies however that won't happen until Eden's out the door...

https://github.com/xbmc/xbmc/pull/591

Cheers Wink

Oh, I was certainly not aware of that. I had not looked again since it went into hiatus early last year. Thanks for the update and I will take a look at it!


- GreenEyez - 2012-01-13

It`s actually ahead of the Eden beta1, last merge of DSPlayer with the main XBMC trunk was on the 5th of January, 7 days after the Eden beta hit the repo.


- DDDamian - 2012-01-13

Still requires a video source right? In other words doesn't help with HD FLACs, just Bluray format HD Audio bitstreaming?


- liquidskin76 - 2012-01-13

DDDamian Wrote:Still requires a video source right? In other words doesn't help with HD FLACs, just Bluray format HD Audio bitstreaming?

I believe tiben has sorted that one...

https://github.com/0wing/xbmc/commit/cc652d4aa8458f5c89d494335004c5fdc8fc4b96

You should now be able to play audio only files.

Cheers Wink


- DDDamian - 2012-01-13

liquidskin76 Wrote:I believe tiben has sorted that one...

Thanks bro - will check it out - it's been six months since I last tried DSPlayer.

I have spent a lot of hours in the last week going through the AE code. I believe, but it's premature, that I've found a cause of the audio dropouts with DTS-MA. I'll post here if I can fully verify.

The other things I've been working on as I decipher it are: getting it to run in Exclusive Mode, which I can't now, and running LPCM in passthrough avoiding the DWORD->FLOAT->DWORD or WORD->FLOAT->WORD conversions.

Both of these would give us the true audiophile no-bit-molesting end goal, but it's a painful process for someone who hasn't coded in years lol. Still, I'm getting there. Currently getting true Exclusive Mode with two-channel LPCM bistreaming, just choking on switching to multi-channel streams.

Will keep ya's posted, cause it'll need some testing help.

Cheers.


- shadow - 2012-01-14

Woohoo 45 minutes ago gnif updated his repo, looks like he is working on AudioEngine again.


- DDDamian - 2012-01-14

shadow Wrote:Woohoo 45 minutes ago gnif updated his repo, looks like he is working on AudioEngine again.

Awesome! Looks like he brought it up to date to start work again. Fantastic news. Maybe I can stop the work I started on the audiophile version or at least try keep it in sync with what work he continues with.

@gnif - hope whatever RW issues hit you back in September all worked out well!