Kodi Community Forum
HOW-TO synchronize your XBMC Media Center between every room in the house: Lifehacker - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Tips, tricks, and step by step guides (https://forum.kodi.tv/forumdisplay.php?fid=110)
+--- Thread: HOW-TO synchronize your XBMC Media Center between every room in the house: Lifehacker (/showthread.php?tid=80829)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38

- Ned Scott - 2011-11-14

hey all you people, help update/add/improve/whatever to the XBMC Wiki's new from-scratch how-to on this: HOW-TO:Synchronize multiple XBMC libraries

Just make an account if you don't already have one and start editing.

If you need any help on the wiki or have any questions, feel free to PM me or whatever.

- darkscout - 2011-11-14

Now the problem: How do we get the internet to take down old information?

- Fruitfly - 2011-11-16

Is anyone having the same problem as me and solved it?

I followed everything in lifehacker.

I installed the latest XBMC Dharma,
Installed MYSQL, typed in the first command prompt shown in lifehacker.
which was


then this error came up:
ERROR 1396 (HY000): Operation CREATE USER failed for 'xbmc'@'%'

I tried running as administrator. Tried google, still can't find an answer.Angry

I'm running windows 7 64-bit
4gb Ram
Geforce GTX 570

if that helps

please help me Confused

- darkscout - 2011-11-16

Fruitfly Wrote:then this error came up:
ERROR 1396 (HY000): Operation CREATE USER failed for 'xbmc'@'%'

You logged into the mysql server as root?

Else search google. This is a mysql error, not an XBMC error.

- Fruitfly - 2011-11-16

yeap, logged in as root, ran as administrator. Still the same.

- Xsabre - 2011-11-16

Fruitfly Wrote:CREATE USER 'xbmc' IDENTIFIED BY 'xbmc';

then this error came up:
ERROR 1396 (HY000): Operation CREATE USER failed for 'xbmc'@'%'

Going to make my first post count...

I don't know a thing about MySQL. But I had the same problem. Issues stems from which character is used "`" (located next to the 1 on the keyboard) verse " ' " (located...next to enter). I don't understand the syntax well enough. But follow the syntax below...

GRANT ALL PRIVILEGES ON `xbmc_%`.* TO 'xbmc'@'%';

Notice the different character before and after `xbmc_%`. verse 'xbmc'@'%'.

I have been try to get synchronizing multiple XBMC with nightly for over a week without luck. I keep telling myself to wait for final. But I can't let it go. I have learn quite a few things about MySQL in the last few days. Which I see as a plus

- Fruitfly - 2011-11-16

Nope didn't work,

Says here
ERROR 1046 (3D000): No database selected,

Also how do you log in as root?

- Fruitfly - 2011-11-16

Not sure if this helps

When I type SELECT User, Host, Password FROM MySQL.user;

It shows

A box of 3 users on the first column - root, xbmc, root

And then 3 Host in the next column - localhost, %, %

And passwords on the next

So it seems to me that it is reading xbmc somehow but can't create user

- darkscout - 2011-11-16


Just apply the proper permissions and be done with it.

- Fruitfly - 2011-11-16

Yes Thanks, got the mysql to work.

I did the advancedsettings.xml pasted it in my mac and my windows xbmc userdata folder both with the host's ip address. Didn't change the port. standard 3306 port.

Exported and imported host files to my mac. When import on mac. Nothing came up. Not even that scanning tab on the center top.

Is it actually suppose to auto scan everything to my mac after the whole set up is done?

- darkscout - 2011-11-16

You're going to have to rephrase that. You exported. Imported. And nothing is there? What does your debug log say?

- Klyde - 2011-11-17

I'm running into a similiar issue. Since I set this up, both PC's see the same library. But my tv shows when scanned only show the first episode of each season in the library? some of my movies are missing and I'm no longer able to flag media as watched? Any suggestions? Never got any errors with the MYSQL syntax, when I show databases and users they appear to be correct. Once I remove that advancedsettings.xml file from the folder my whole library reappears

- darkscout - 2011-11-17


- Klyde - 2011-11-17

Hopefully this is the part you require
Quote:09:59:38 T:3596 M:1104936960 NOTICE: Loaded advancedsettings.xml from special://profile/advancedsettings.xml
09:59:38 T:3596 M:1104936960 NOTICE: Contents of special://profile/advancedsettings.xml are...
09:59:38 T:3596 M:1104928768 WARNING: VIDEO database configuration is experimental.

I'm wondering if the last line has something to do with it?

- darkscout - 2011-11-17

No. That's basically just a dump of your advanced settings file.

We need the whole thing (in a pastebin, do NOT paste it here).