Kodi Community Forum
XBMC gets dedicated remote - Motorola Nyxboard - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: OS independent / Other (https://forum.kodi.tv/forumdisplay.php?fid=228)
+---- Thread: XBMC gets dedicated remote - Motorola Nyxboard (/showthread.php?tid=80968)

- mat____ - 2011-12-28

Thanks for the update Malard, pencil me in for one of those working ones should they arrive.
Mine has degraded to brick status for now I'm afraid, due to the navigation buttons mainly.

- Steini - 2011-12-29

Same here, i got one for christmas and I cant really use it because of the left button issue. Not sure, but i feel that the other directions are also getting worse. The dpad on the keyboard side is however silky smooth.

Mailed support and hopefully I can have a fixed version soon Smile

- KeRbDoG - 2011-12-29

I too received one of these remotes, returned it for another and then settled for a bluetooth keyboard from them.
btw if you get the option of a refund OR the bluetooth keyboard, just ask for a refund as its a cheap-n-nasty bluetooth remote you could get from a HK eBay seller.

Still waiting for my 'little something extra' which was promised to the folks who placed the first batch of pre-orders...maybe the hassle of the remotes was it? Confused

- matmabro - 2012-01-07

for the life of me I cannot figure out how to re-map the colored keys on this remote.. I've just spent literally all night trying. I have used various names for my keyboard.xml file in my /keymaps/folder. Currently nyxboard.xml (from what I understand, I could call it retardoscript.xml, or anything really, and it should work). The actual code contained is:

#<!-- Mappings for the Motorola Nyxboard remote -->
<f3>ContextMenu</f3> <!-- EPG: same as Guide (ctrl-G) on MCE remote -->
<f3 mod="shift">XBMC.ActivateWindow(10025,plugin://plugin.video.icefilms/)</f3> <!-- Red -->
<f4 mod="shift">XBMC.ActivateWindow(10025,plugin://plugin.video.hulu/)</f4> <!-- Green -->
<f5 mod="shift">XBMC.ActivateWindow(10025,plugin://plugin.video.yahoo.music.videos/)</f5> <!-- Yellow -->
<f6 mod="shift">XBMC.ActivateWindow(filemanager)</f6>
<f4>XBMC.ActivateWindow(favourites)</f4> <!-- Blue -->

I have tried substituting "remote" in the "keyboard" header with no luck.. also tried "keyboard name="Motorola Nyxboard Hybrid""

any help would be appreciated. Thanks

- pike - 2012-01-07

try and copy keyboard.xml from system to userdata/keymaps and add the missing f4-f6 keys and other missing keys to it (I suggest global section). restart xbmc.

ps - you have f4 mapped twice ? but it's the first one which is correct (mod="shift")

- matmabro - 2012-01-07

Thanks for the quick reply. keyboard.xml is already in the userdata/keymaps dir....as far as the f4 is concerned, I think both are correct, as I understand it, f4 = "user" key while f4 mod="shift" is the "green" key.. I was trying to go clockwise on the remote.

IT seems as though my xml files in the keymaps are ignored.... my standard keyboard buttons haven't even changed, let alone the functionality of my remote. Is it possible that I have to actually shutdown and reboot the system instead of just exiting and re-starting XBMC?

- pike - 2012-01-07

It all depends on how new your xbmc build is also...

- matmabro - 2012-01-07

I was on Eden Beta... just rolled back to pre-eden from Dec 10th.

- pike - 2012-01-07

it is enough to just restart xbmc.

I modified the system keyboard.xml and put it in userdata/keymaps and it worked here.

Maybe you should try to remove (backup first) all other xmls from userdata/keymaps and try again ? also check your xbmc.log for errors and such

- matmabro - 2012-01-07

my "nyxborad.xml" file is the only one in the directory at the moment.. I'd post a pastebin link, but I'm running the thing on my HTPC and searching on my laptop at the moment.

anyway..... ran debug.. something is wrong with my notepad xml file... I am getting "Line 0 Error document empty"

Tried opening and re-saving with wordpad in open office xml type and still same error... not sure what to make of this. I tried a few google searches...without much luck...

- oneadvent - 2012-01-07

real people use vi.


I would suggest using something like VI or notepad++, not notepad. it tends to do stupid things.

- matmabro - 2012-01-08

OMFG... never underestimate the shittiness of micro$oft. notepad++ did the trick.. I had to place the xml file in both /keymaps/ and kaymaps/nyxboard/ though...

No this works, I'm just looking forward to getting a working replacement unit come the end of January.... "by popular demand" ...lol.... Pulse-Eight should have really just put "because Motorola fucked up" on the site.

- gobbledigook - 2012-01-09

Malard Wrote:Motorola have been given until the 23rd of January to provide a sample batch of remotes that all must pass testing, i.e. I will try to replicate the faults everyone is having in each one of them, if they all pass, we will get new remotes and issue replacements to those who want them.

If they don't then well, all sorts of issues for Motorola Wink

this is great news Smile i already have had one replacement, and my last contact with support was left at replacing it, waiting for moto to get their asses into gear, or having a refund... i've done the waiting, so when these come will we be contacted about having our defective remotes replaced?

KeRbDoG Wrote:Still waiting for my 'little something extra' which was promised to the folks who placed the first batch of pre-orders...maybe the hassle of the remotes was it? Confused

i've given up on this... sod it, getting them to realise there was an actual problem with the remote and not to do a power supply issue was stressful enough!

- falafael - 2012-01-20

i received my 'replacement' remote on wednesday due to problems with the first batch, all i can say that i am 100% happy, works a treat, fast, responsive, learning seems to be easier too, overall a great product in my eyes, and works out the box, the wife loves the simplicity of it.....so well done and thank you from all of us here!

- quintesse - 2012-01-20

I have never used mine because of problems with range and the battery draining in 1-2 days. So I should get in touch with them for a replacement?