Kodi Community Forum
[Web Interface Addon] AWX - Ajax based Web Interface Addon for XBMC - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (/forumdisplay.php?fid=27)
+---- Forum: Web Interfaces (/forumdisplay.php?fid=156)
+---- Thread: [Web Interface Addon] AWX - Ajax based Web Interface Addon for XBMC (/showthread.php?tid=81775)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23

- MKay - 2010-11-03 19:25

hotlobster Wrote:It seems Awx doesn't support external database.

No movie & Tv Shows listing when using mysql database, everythings works ok whith sqlite.

More info on this thread:
As you mentioned in your thread there seems to be a problem with the JSON-API, because the float-value for rating is not well formatted.
Nevertheless this is strange because i am using mysql too and have no problems Smile

UndisclosedP Wrote:Not sure what i've done wrong but it seems as though AWX is only grabbing the wide banners for my shows and not the correct smaller banners?
What do you exactly mean? AWX is not grabbing wide banners or poster banners. It is just grabbing banners because the API does not differentiate between wide banners and poster banners. Smile
What's wrong with the "smaller banners" (poster banners?)? Are they not shown or are they shown in a wrong aspect ratio?

- hotlobster - 2010-11-03 19:30

in fact solved it by changing ratings fields from TXT to INT.

I don't know if that's my fault or the default config.

- UndisclosedP - 2010-11-03 20:08

Hi Mkay,

It looks like this:
[Image: Ciow3.png]

Both in the dark and light skins.

- MKay - 2010-11-03 20:15

Ok, so you have mixed type of tv-show-thumbs? Both banner and poster-images?
Because on startup of AWX it checks your tvshow-list if you have either poster-thumbs or banner-thumbs.

- ppic - 2010-11-03 20:17

and if we use landscape images ? Big Grin

- MKay - 2010-11-03 20:25

Then it will reboot your pc and automatically format all your hdd's Tongue

If other image formats are needed: just make a feature request Smile

- UndisclosedP - 2010-11-03 21:19

Aha, thanks Mkay, Somehow one show had managed to get itself a vertical thumb instead of a wide thumb, it also happened to be the first show in my library so I guess thats why AWX picked it. Cleaned that up and its now all ok! Love the interface.

- ppic - 2010-11-03 21:29

well landscape image are massively used but i don't want to overload you Wink

- MKay - 2010-11-03 21:34

Do you have an example image?

- ppic - 2010-11-03 23:00

yes find it on http://www.xbmcstuff.com

apart: i've tested with timeout = 60 still can't load movie or tvshow list, still have a "failed to retrieve" error

- MKay - 2010-11-03 23:17

If you have a linux running try this on a console and check if it returns your tvshow list and check how long it would take:
curl -u 'username:password -i -X POST -d '{"jsonrpc": "2.0", "method": "VideoLibrary.GetTVShows", "params": { "start": 0, "fields": ["genre", "director", "plot", "title", "originaltitle", "runtime", "year", "rating"] }, "id": 1}' http://your_xbmc_host/jsonrpc

- ppic - 2010-11-03 23:35

just giving me this:


- MKay - 2010-11-04 00:13

What's this? Big Grin A prompt waiting for user-input?
Try to redirect the output of the program into file Smile (by adding ">> filename" to the command above) Does the file contain any useful data (tvshow list)?

- ppic - 2010-11-04 00:44

don't work, i still get a prompt.

[email protected]:~$ curl -u 'xbmc:xbmc -i -X POST -d '{"jsonrpc": "2.0", "method": "VideoLibrary.GetTVShows", "params": { "start": 0, "fields": ["genre", "director", "plot", "title", "originaltitle", "runtime", "year", "rating"] }, "id": 1}' >> test.txt

- thazzy - 2010-11-04 10:29

ppic Wrote:don't work, i still get a prompt.

[email protected]:~$ curl -u 'xbmc:xbmc -i -X POST -d '{"jsonrpc": "2.0", "method": "VideoLibrary.GetTVShows", "params": { "start": 0, "fields": ["genre", "director", "plot", "title", "originaltitle", "runtime", "year", "rating"] }, "id": 1}' >> test.txt

Some characters needs to be escaped. Should be something like
curl -u "xbmc:xbmc -i -X POST -d \'\{\"jsonrpc\": \"2.0\", \"method\": \"VideoLibrary.GetTVShows\", \"params\": \{ \"start\": 0, \"fields\": \[\"genre\", \"director\", \"plot\", \"title\", \"originaltitle\", \"runtime\", \"year\", \"rating\"\] \}, \"id\": 1\}"