Kodi Community Forum
Transparency! SVN for XBMC nightly builds - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Skins Support (https://forum.kodi.tv/forumdisplay.php?fid=67)
+---- Forum: Transparency! (https://forum.kodi.tv/forumdisplay.php?fid=115)
+---- Thread: Transparency! SVN for XBMC nightly builds (/showthread.php?tid=83643)



- ronie - 2011-01-22

Zrino Wrote:Does this mean that now XBMC fully support DTS-MA and TrueHD bitstream?
i wouldn't be able to tell.

if you can read c++ you may be able to figure it out

gabbott Wrote:Doesn't look like it according to that commit.

also check the previous commits ;-)


- ashlar - 2011-01-25

Zrino Wrote:Does this mean that now XBMC fully support DTS-MA and TrueHD bitstream?
TrueHD gets decoded to LPCM (bit by bit identical, it only changes where the decoding happens). DTS-MA just gets identified correctly. Before the developers were unable to properly tell a DTS-MA track from a regular DTS one.


- ronie - 2011-02-08

nuzecast Wrote:I know this is being ultra-picky but that line under the XBMC logo (home screen) drives me crazy Oo

I used to extract the old xpr and replace it but now with xbt I don't know how.

Any chance of a skin setting where we could pick an image of our choice to use as the logo?

added to svn as of now.

Skin Settings > Home > Use custom logo
Skin Settings > Home > Use custom logo - File:


in case you just want to hide the xbmc logo,
enable this option but don't select a custom logo.


please test: movie-set case - ronie - 2011-02-08

i need a few svn testers.

i've added a movieset case in fanart view.
and before i add it to other views i'd really like to know if it is working correctly for everyone.

also check if fanart view in filemode does not show any odd cases.


cheers!


- OggyHr - 2011-02-08

ronie Wrote:i need a few svn testers.

i've added a movieset case in fanart view.
and before i add it to other views i'd really like to know if it is working correctly for everyone.

also check if fanart view in filemode does not show any odd cases.


cheers!
Here I am. tell me what to do...
I read the first page but I didnt understand where I can download the "test version"?


- ronie - 2011-02-08

OggyHr Wrote:Here I am. tell me what to do...
I read the first page but I didnt understand where I can download the "test version"?

you need to install some svn software first, like TortoiseSVN

with TortoiseSVN you'll be able to download the latest version of the skin from:
http://transparency-xbmc.googlecode.com/svn/trunk


- pyrodex - 2011-02-08

Ok, I've switched to the SVN version. I will give it a whirl and let me know if there is anything you need tested.


- kurai - 2011-02-09

Hi Ronie.

Just did an svn checkout, and got a rather odd result on all my Home screens ...

Image

I noticed that during the update both Includes_Home.xml and Includes_CDWall.xml had changes merged in.

The new grid on the Home screens is the same layout as the CDWall, but I can't follow the skin code well enough to work out exactly what parts are interacting badly.

In Includes_CDWall.xml the only lines that changed were :-
Code:
Line 6:  <visible>Skin.HasSetting(CDWallNoVisualisation)</visible>

to

Line 6:  <include condition="Skin.HasSetting(Viz-Animation)">backgroundanimation</include>
Line 7:  <visible>Player.HasAudio + Skin.HasSetting(Viz-CDWall) + ![substring(Player.FolderPath,pvr://) | substring(Player.FolderPath,http://) | substring(Player.FolderPath,https://) | substring(Player.FolderPath,htsp://)]</visible>

There were a lot more changes in the Includes_Home.xml merge, but nothing that leaps out as obviously linking to Includes_CDWall.

Any ideas ?


- ronie - 2011-02-09

kurai Wrote:Any ideas ?

i think i've already fixed that.
could you svn up and check again?


- ronie - 2011-02-09

ronie Wrote:i think i've already fixed that.

no i didn't.
r863 should fix it.

thanx for the report :-)


- kurai - 2011-02-09

Yep - that did the trick.

Thanks Ronie Smile


- PatK - 2011-02-09

Cinema Experience issues, I've installed the plugin and configured it... seems to work well and saved it as a favourite (again works well if you click it) but it doesn't play prior to a chosen movie/video even when I toggle the setting 'enable home theatre script and pathed it. SVN 3.11.4 and XBMC R10 35647 Dec 17 did I miss something?


- ronie - 2011-02-09

PatK Wrote:Cinema Experience issues, I've installed the plugin and configured it... seems to work well and saved it as a favourite (again works well if you click it) but it doesn't play prior to a chosen movie/video even when I toggle the setting 'enable home theatre script and pathed it. SVN 3.11.4 and XBMC R10 35647 Dec 17 did I miss something?

did you click the 'cinema experience' icon in the movie info dialog
to start the script/play the movie?

if so, i need a Debug Log.

otherwise...the above way is the only way to start the script before the movie


- PatK - 2011-02-09

ronie Wrote:did you click the 'cinema experience' icon in the movie info dialog
to start the script/play the movie?

if so, i need a Debug Log.

otherwise...the above way is the only way to start the script before the movie

Yup... that was what I was missing, I hadn't noticed this new icon... actually it's a very nice option and it didn't always operate this way. Having a separate folder for trailers makes sense now.


- Soutie - 2011-02-10

Ronnie,

Quick one, using the SVN version I noticed that the option "Show fanart instead of visuilisation" under Skin settings -> General is no longer there. Has this option moved or been removed all together?