Kodi Community Forum
Transparency! SVN for XBMC nightly builds - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Skins Support (https://forum.kodi.tv/forumdisplay.php?fid=67)
+---- Forum: Transparency! (https://forum.kodi.tv/forumdisplay.php?fid=115)
+---- Thread: Transparency! SVN for XBMC nightly builds (/showthread.php?tid=83643)



- steve1977 - 2011-11-05

ronie Wrote:xbmc pre-eden has files-in-lib and i don't think that'll work properly with a dharma skin.

No idea why, but it actually works so far. Let's see if probs come up along the way, but so far all good...

ronie Wrote:no clue really, maybe when the first eden beta is released.

Sounds good, will wait then.


WeatherPlus/Temp not updating on T!'s Home Page - mst3kroqs - 2011-11-06

Hi Ronie -

With the untimely death of the Weather Channel API, I've been switching over to WeatherPlus with the AccuWeather Global provider for my systems. Just to be sure - I've updated to the latest version of everything:

XBMC PRE-11.0 Git:20111105-1b2b245 (Compiled: Nov 5 2011)
WeatherPlus 2.3.2.b.1003.zip (latest beta as of this date)
Transparency 4.0.3 (SVN) revision: 1209 (updated today)

Choosing 'Weather' on the main menu does result in full WeatherPlus functionality/dialogs, and I can view maps/videos, etc., but for some reason the current temperature value and possibly the weather conditions icon are not updating on the Home screen.

When XBMC starts up, it displays 'BUSY', but then no temp value is displayed, just the temperature units - (F), as I am USA. The weather conditions icon *may* be right, but I'm not sure as it's been the same conditions all day ... ;^)

A pastebin of the debug log can be found here.


- ronie - 2011-11-06

i'll push a some minor changes that may fix your issue.

but other than that, weather is broken in the xbmc core and it may affect weather addons as well.

the team is aware of this and we are currently evaluating alternatives.


- mst3kroqs - 2011-11-07

ronie Wrote:i'll push a some minor changes that may fix your issue.

Your changes did the trick - I'm now seeing the correct temp and the weather info being diplayed.

Thanks Ronie!


Menus too far left. - eddiem - 2011-11-11

Never mind, wife playing with settings!! Big Grin


same issue. - PatK - 2011-11-11

ronie Wrote:i'll push a some minor changes that may fix your issue.
Where did you push the changes..? I just saw the weather question, it's in the latest SVN


It's in flux ... - mst3kroqs - 2011-11-11

FYI - the weather code is in flux - just picked up the 11-11 nightly and the Weather Plus 2.3.2 script is failing - I don't think this is because of T! because as I said T! was displaying the Weather Plus info OK a nightly revision or so back. Probably best to sit tight for awhile while the devs sort this ...


Can't choose a Favourite when creating custom menu item ... - mst3kroqs - 2011-11-11

Hi Ronie -

This is for SVN revision 1219, although it also did not work for a couple of previous revisions. I also installed the 11-11 XBMC nightly and had the same result.

First, I created a Favourite link to the Hulu plugin, and then opened the Favourite list from the Shutdown menu, and you can see that the Favourite is in the list, and it works fine, but when I try to create a Custom Home Menu item which is linked to the Favourite:

Settings->Skin Settings->Menu->Custom 1->Favourite does not yield a useful 'Favourites' dialog list to choose from, eg. there are no Favourites listed, and also apparently no key nav because I can't even select the Cancel button ...

Is this a bug, or is there a loose nut behind the keyboard (me)?

Rolleyes


- ronie - 2011-11-11

mst3kroqs Wrote:there are no Favourites listed

most likely you're missing the favourites script,
you can get it here: http://mirrors.xbmc.org/addons/eden-pre/script.favourites/


- mst3kroqs - 2011-11-11

Indeed I was - that did the trick! should this have been included in the nightly install package or is it a T!-specific script? I'm now wondering if I am missing other scripts/services that are needed ...

Thanks!


- ronie - 2011-11-11

mst3kroqs Wrote:Indeed I was - that did the trick! should this have been included in the nightly install package or is it a T!-specific script? I'm now wondering if I am missing other scripts/services that are needed ...

Thanks!

once T! is in the repo, all required scripts will be installed automatically.

these are the once you need:
  • script.favourites
  • script.logo-downloader
  • script.globalsearch
  • script.randomitems
  • service.qlock



- Polonda - 2011-11-12

I'm sure this is covered somewhere, but i cant seem to find it. How do I get movie ratings to show in Fanart Mode?


- ronie - 2011-11-12

Polonda Wrote:I'm sure this is covered somewhere, but i cant seem to find it. How do I get movie ratings to show in Fanart Mode?

they should show up by default.
if they're missing at your end, could you please post a screenshot?


- Polonda - 2011-11-14

Fiiguied it out.. Apparenty if you have the plot outline turned on when in Fanart you loose ratings.

I turned off plot outline and the ratings came back. Any way to have them both?


- ronie - 2011-11-14

Polonda Wrote:Fiiguied it out.. Apparenty if you have the plot outline turned on when in Fanart you loose ratings.

I turned off plot outline and the ratings came back. Any way to have them both?

the only way would be to mod the fanart view yourself. :-)