Kodi Community Forum
Transparency! SVN for XBMC nightly builds - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Skins Support (https://forum.kodi.tv/forumdisplay.php?fid=67)
+---- Forum: Transparency! (https://forum.kodi.tv/forumdisplay.php?fid=115)
+---- Thread: Transparency! SVN for XBMC nightly builds (/showthread.php?tid=83643)



- migr - 2010-12-19

im not sure if this has been requested or i just cant find the option and the answer is posted somwhere, but ive spend 2 weeks migrating from an xbox to a HTPC running XBMC and this is the best skin ive found to date. The only thing i wish to do is this...

1: to have all the avalible view options avalible in movies, and tv epps, enabled in the video directory.

2: to be able to view everything in date the date created order, as thats how i see what the newest movies are. Given that i run a communal share NAS, my neighbours can dump a movie on it, and i turn on XBMC and the top of the list presents me with a new movie i otherwise wouldnt know were there. As it is, you can view in date order in Video, but not in Movies and TV Epps. but even the ones i can use date added order on, i have an issue with which is outlined below.

The only bugs i have found which i expect is just me,

1: that in video mode when i select fanart as the view type, it doesnt show the fan art, just the pop corn background.

2: when viewing in date added order in Videos, it shows some really odd order. The latest movie is 5 down from the top, but from there the next movie, is a movie i added, and is still dated in 2007? It appears to go in alphabetical order from there on, ie Z then y ect. its strange.

I hope im not out of place in saying any of the above as like i said, its the best skin ive ever used on XBMC and ive been useing XBMC for about 5 years or more now. The build im useing is the latest as at about an hour ago off the SVN. and yes i dont expect things to be error free when useing the latest build.

Anyway, thanks again and you have done a fantastic job with this skin. Like i said, its the best skin out there.

Cheers

Migr


- ronie - 2010-12-19

migr Wrote:1: to have all the avalible view options avalible in movies, and tv epps, enabled in the video directory.

most of them should be available.
i think only 'item view' and 'wall view' are missing.
i'll look into adding them...they may not look great in filemode,
as they depend on extra information not available in filemode.

for some of the views to be available, you need to 'set content' on your sources though. otherwise the skin won't know if you're browsing your movies or your tv shows.

as for season / episode specific views...that's just not possible in filemode.

migr Wrote:2: to be able to view everything in date the date created order, as thats how i see what the newest movies are. Given that i run a communal share NAS, my neighbours can dump a movie on it, and i turn on XBMC and the top of the list presents me with a new movie i otherwise wouldnt know were there. As it is, you can view in date order in Video, but not in Movies and TV Epps. but even the ones i can use date added order on, i have an issue with which is outlined below.

in library mode, you can browse your recently added movies / episodes,
they're listed at the root of the video library.
or is this not what you're looking for?

migr Wrote:1: that in video mode when i select fanart as the view type, it doesnt show the fan art, just the pop corn background.

weird, regardless of the view type, it should always show the fanart images as the background.

if you could post a Debug Log on pastebin of you browsing your movies in filemode,
i'll have a look.

migr Wrote:2: when viewing in date added order in Videos, it shows some really odd order. The latest movie is 5 down from the top, but from there the next movie, is a movie i added, and is still dated in 2007? It appears to go in alphabetical order from there on, ie Z then y ect. its strange.

the skin has no influence on the order items are sorted, it's done by xbmc.
first check the sort direction (up/down) in the side menu.
next, i think the 'stack' option also affects the way items are sorted, so look into that option as well.


- migr - 2010-12-20

thanks for your quick response. Looking at the 1st quary where you recomend that i use library mode instead of file mode. Thats basicly the root of my problem. You see in library mode, anything that didnt manage to pull a cover or fan art is omitted from the list, which is why i have to go back to video and view it in file mode so i can see ALL the files rather than just the ones i have cover art for. Maybe thats the solution too, to enable it to show the files that it didnt manage to pull art for, while in library mode (if thats even possible). that would save the need for me to use the video dir in filelist mode. The same issue also applies to the TV series tab. because as it is, both Movies and TV ommit a lot of files forcing me to use file mode in the video directory.

addressing your 2nd and 4th response, yes the view by date is an option in movies while in library mode. I dont know what i was thinking when i said it wasnt. I think its more to do with the other issue i have with it showing in the incorrect order in date added view. But as you pointed out, thats to do with XBMC, not the skin, i have no idea whats going on there as the order is only out when in library mode in the movie dir, but if i go to the video dir and view by file in date order, its correct. When in library view in movies, as it stands now, i have it set to show the latest movies at the top, but the top 5 are random dates and then the rest start at Z and work back to A which seems more alphabetic, but the 1st 5 throw me as they arent alphabetic or date ordered lol. Im just at a total loss to explain that issue im having.

As for issue 3, the fan art not showing up in the video dir. i should point out, thats only when in filelist, not library mode. As soon as i turn library view off, thats when i lose the fanart. Its just that fanart is still an option when in fileview. But there in lies my issue.

Filelist = see all movies in correct date order including the ones without coverart, but cant view fanart.

Library mode = See all fan art but the date order listing is incorrect, and files without coverart are excluded.


The above 2 scenarios are both from within the video tab and confirmed as i typed this.

I hope that all makes sense. You could probibly ignore all of what ive typed and read just the text in red if you want as it summs everything up in 1 hit. Im happy to provide any debugging logs you want, but is that just done by enabling debugging, then collecting the log? or is there a debug just for the skin that i can use. Also where does it store the log, i couldnt find it even with a search lol. Bloody windows indexing.


- ronie - 2010-12-20

yes, there should be fanart in filelists.

about the debug log:
- enable debug logging in Settings > System
- restart xbmc
- browse your movies in file view
- post the log on pastebin

where the log is stored depends on your windows version,
most likely candidates:
c:\documents and settings\<username>\appdata\xbmc\xbmc.log
c:\users\<username>\appdata\xbmc\xbmc.log

...or something like that


- migr - 2010-12-21

done, i booted XBMC and navigated to videos which was in fanart view in file mode, scrolled down 4 movies or so and closed it. The log is on pastebin here... http://pastebin.com/9HTrP0mV

i had a look and it does mention an error getting the fanart each time i select a movie.
301.14:39:49 T:6048 M:2523340800 ERROR: XFILE::CDirectory::GetDirectory - Error getting smb://QNAP1/Movies/=[ Movies ]=/Cyrus/extrafanart/
302.14:39:50 T:6048 M:2524385280 DEBUG: SDLKeyboard: scancode: 80, sym: 274, unicode: 0, modifier: 0

at this point its prolly a good idea to point out im running this on a 32 bit win7 OS and the movies are stored on a NAS. but when in library mode the fan art does work. What i find strange is that it appears to be looking on the NAS in the movie folder for the fanart, but it only has read access to the NAS and as such all fanart must be stored locally on the XBMC machine. My guess is im just looking at the wrong part of the logs :p If you want any other logs, just let me know and ill post the results asap.


EDIT: here is a log of the fanart working in library mode (just in case). In this log, i navigated to videos, looked at 1 or 2 movies, then changed it to library mode and then i navigated 4 or 5 movies by title order which displayed the fanart just fine. http://pastebin.com/yRiKaeJr

Thanks again for your time ronie, i really appreciate it.


- ronie - 2010-12-21

migr Wrote:301.14:39:49 T:6048 M:2523340800 ERROR: XFILE::CDirectory::GetDirectory - Error getting smb://QNAP1/Movies/=[ Movies ]=/Cyrus/extrafanart/

that's not related to your problem.
T! allows you to store additional fanart images to create a slideshow in the extrafanart folder.
too bad.. i don't see any fanart related errors in the log.

could you check if you get fanart in filemode in Confluence?

migr Wrote:at this point its prolly a good idea to point out im running this on a 32 bit win7 OS and the movies are stored on a NAS. but when in library mode the fan art does work. What i find strange is that it appears to be looking on the NAS in the movie folder for the fanart, but it only has read access to the NAS and as such all fanart must be stored locally on the XBMC machine.

correct, xbmc caches the fanart locally.
i'm not sure if the local cache is used in filemode too.


- migr - 2010-12-22

good call, i just checked it in Confluence, and the fanart only shows up in library mode, not in file mode. Also the date order is wrong in library mode and correct in file mode. Does that mean theres a problem in the XBMC code? i mean its clearly not in the skin given that the problem is apparent in other skins too. Im sorry for wasting your time as i should have thought to try a different skin 1st. But at least the issue is narrowed down now.


FYI, I'm seeing something similar - mgtiger - 2010-12-23

I'm using the MyMovies program to catalog my collection which saves a fanart and thumbnail file to the folder with the movie. So when I view a new movie in XBMC, it uses those by default before I use the scraper. For various reasons, I'm using the file mode instead of library as well.

If I try to change the fanart using a scraper within XBMC, it never changes within file mode but it does in library. I confirmed this behavior in Confluence as well. Also, the thumbnail is updating correctly in file mode.


- dondre - 2010-12-25

mgtiger Wrote:I'm using the MyMovies program to catalog my collection which saves a fanart and thumbnail file to the folder with the movie. So when I view a new movie in XBMC, it uses those by default before I use the scraper. For various reasons, I'm using the file mode instead of library as well.

If I try to change the fanart using a scraper within XBMC, it never changes within file mode but it does in library. I confirmed this behavior in Confluence as well. Also, the thumbnail is updating correctly in file mode.

I believe this has nothing to do with Transparency! behavior but instead XBMC's.

Nevertheless I would rather recommend Ember Media Manager which works flawlessly for me Smile


Something I missed? - PatK - 2010-12-29

moving a folder from one spot to another drive, it looked like I lost the settings... so just reset and didn't rescan, although next start-up it rescanned quickly anyway (I have scan for new goodies on start-up set). I manually inspected the folder inside of XBMC and found one blank folder with the correct backdrop... but the video was missing, I guess it didn't copy over. I replaced it and rescanned... now I get this.

[Image: pipb.png]

This little picture in picture is neat, but is only available for this folder... is there some tag I've missed to turn these on? When I go to a neighbouring file.. I see the pip briefly slide in and then disappear instantly.


- ronie - 2010-12-29

PatK Wrote:is there some tag I've missed to turn these on? When I go to a neighbouring file..

those are extrathumbs.

Skin Settings > General > Movies – Use extra thumbs
Skin Settings > General > TV Shows – Use extra thumbs


- gabbott - 2011-01-22

Ronie,
Saw you just added DTS-MA flagging support. Have a couple titles with DTS-MA tracks but it isn't flagging them even after rescraping. Does xbmc just not support reading them yet? I'm running Dharma final.


- ronie - 2011-01-22

xbmc support was just added yesterday: https://github.com/xbmc/xbmc/commit/235d3d6317ab66f5017368de67d63092f10c4fd8

so you need to run a very recent git version of xbmc to use it.


- Zrino - 2011-01-22

Does this mean that now XBMC fully support DTS-MA and TrueHD bitstream?


- gabbott - 2011-01-22

Zrino Wrote:Does this mean that now XBMC fully support DTS-MA and TrueHD bitstream?

Doesn't look like it according to that commit.