Kodi Community Forum
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC (/showthread.php?tid=87552)

- fekker - 2011-04-15

I'm not going to commit this change as netflix appears to be working on the fix sometime in the next week or two, but I will provide what you need to change in order to see all items in the instant queue.

open netflix.py
change the getInstantQueue to the following code

def getInstantQueue(self,historyType=None,startIndex=None,maxResults=None,updatedMin=None,caUser=None):
        parameters = {}
        if startIndex:
            parameters['start_index'] = startIndex
        if maxResults:
            parameters['max_results'] = maxResults
        if updatedMin:
            parameters['updated_min'] = updatedMin
        if caUser:
            if (caUser == True):
                parameters['country'] = "ca"
        print "params: " + str(parameters)    
        parameters['v'] = str('2.0')
        parameters['filters'] = 'http://api.netflix.com/categories/title_formats/instant'
        parameters['expand'] = '@title,@synopsis,@directors,@formats,@episodes,@short_synopsis'
        parameters['output'] = 'json'
        if not isinstance(accessToken, oauth.OAuthToken):
            accessToken = oauth.OAuthToken(accessToken['key'], accessToken['secret'] )

        if not historyType:
            requestUrl = '/users/%s/queues/instant' % (accessToken.key)
            requestUrl = '/users/%s/queues/instant/%s' % (accessToken.key,historyType)
            info = simplejson.loads( self.client._getResource(requestUrl, parameters=parameters, token=accessToken ) )
            return {}
        return info

You'll notice the only change is removing the /available part of the URI string
if not historyType:
            requestUrl = '/users/%s/queues/instant/available' % (accessToken.key)
            requestUrl = '/users/%s/queues/instant/available/%s' % (accessToken.key,historyType)

if not historyType:
            requestUrl = '/users/%s/queues/instant' % (accessToken.key)
            requestUrl = '/users/%s/queues/instant/%s' % (accessToken.key,historyType)

This will show all items, including the tv shows by entire show

- Twwayne - 2011-04-15

just wondering if anyone can provide any guidance on this problem - sorry for the repost.

Hi I am having a problem that has been brought up before and I can't find where it has been resolved. When I click on a movie the movie plays behind xbmc - additionally it is not in fullscreen mode. The app looks great but can't get it to fully work in osx.

Instant Queue TV Episode Fix - vander1 - 2011-04-15

Thanks for the workaround to the Netflix instant queue TV series change. It worked like a charm. Great plugin,by the way. I normally use Windows Media Center, but the quality of Netflix playback in the browser (as facilitated by your plugin) is much better than WMC or Boxee's netflix plugin, so I've made the switch to XBMC (at least for netflix).

- saskwatch - 2011-04-15

For some reason, the plugin does not ask me to authorize. IE does not pop-up for me. Any thoughts?

Canadian Library - loyalcanadian - 2011-04-16

First of all I'd like to say thanks for this great plugin.
I'm using the "are you from canada" setting and everything works as it should. It did hang at the redirect screen for internet explorer in win 7 x64 but I just got it to launch Firefox instead.

My question has to do with how Netflix defines the library for Canadian users.
Most of the movies I click on tell me they are not available at this time.
Is there a way to scrape for the Canadian library? or is there a way to create a script that could the etect movies that aren't available via that error message and remove or highlight them from the list?

It also seems like there may be some movies that are in the ie browser listings that arent shown in the plugin listings. The only example i've seen so far is "the butterfly effect"

- saskwatch - 2011-04-16

I got the add-on to work now, but it is not giving me the movie posters. Thoughts?

- LazarusLong - 2011-04-16

New user to XBMC and Netflix (within XBMC). I have the plugin installed but can't seem to get it to work correctly. For whatever reason, it doesn't seem to be "tied" to my account and I also get Script failed: plugin.video.xbmcflicks


- loyalcanadian - 2011-04-17

I had the same error on my one pc. I was able to copy the appdata xbmc folder from the one pc to the other which resolved the problem. Bot pc's were running windows 7. I did not have this error when windows xp was installed. I couldnt really trace back the source if the problem.

- eQUIV - 2011-04-17

Love this plugin. One issue I'm having though -- I use a harmony remote on my Windows 7 Media PC to control XBMC.

Right now whenever I select a video, it loads the IE Netflix window. I have a key mapped to F on my remote, when i hit it nothing happens. I actually have to grab a mouse and click on the Netflix window before the remote key will work.

Is there anyway to make sure the IE Netflix windows is selected and completely on top upon launch of a video? It's mildly annoying to have to get up and grab the mouse and click on the screen before I can make the video fullscreen each time.

Any help would be greatly appreciated. Thanks.

- Alterity - 2011-04-22

So I am trying to set this up however, I seem to be having some issues. It looks like it's never creating a userinfo.txt I assume?

Here is my advancedsettings (I use MPC-HC to launch movies):

<filename>C:\Program Files\Media Player Classic - Home Cinema\mpc-hc64.exe</filename>

Here is my playerfactorysettings:

   <player name="MPC-HC64" type="ExternalPlayer" audio="false" video="true">
     <filename>C:\Program Files\Media Player Classic - Home Cinema\mpc-hc64.exe</filename>
     <args>"{1}" /fullscreen /close</args>
     <player name="IE" type="ExternalPlayer">
     <filename>C:\Program Files (x86)\XBMC\iewrap.exe</filename>
     <args> "{1}"</args>
<rules action="prepend">
   <rule filetypes="*.mkv" player="MPC-HC64"/>
   <rule name="html" filetypes="html" player="IE"/>

And here is the error I'm getting:

20:25:52 T:5552 M:1542221824  NOTICE: root folder: C:\Users\HTPC\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks
20:25:52 T:5552 M:1542221824  NOTICE: working folder: C:\Users\HTPC\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\
20:25:52 T:5552 M:1542221824  NOTICE: links folder: C:\Users\HTPC\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links
20:25:52 T:5552 M:1542221824  NOTICE: real link path: C:\Users\HTPC\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links
20:25:52 T:5552 M:1542221824  NOTICE: resource folder: C:\Users\HTPC\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources
20:25:52 T:5552 M:1542221824  NOTICE: lib folder: C:\Users\HTPC\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib
20:25:52 T:5552 M:1542221824  NOTICE: userinfo folder: C:\Users\HTPC\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\
20:25:52 T:5552 M:1542221824  NOTICE: USER INFO FILE LOC: C:\Users\HTPC\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\userinfo.txt
20:25:52 T:5552 M:1542217728   ERROR: Error Type: <type 'exceptions.IOError'>
20:25:52 T:5552 M:1542217728   ERROR: Error Contents: (2, 'No such file or directory', 'C:\\Users\\HTPC\\AppData\\Roaming\\XBMC\\userdata\\addon_data\\plugin.video.xbmcflicks\\userinfo.txt')
20:25:52 T:5552 M:1541763072   ERROR: Traceback (most recent call last):
                                              File "C:\Users\HTPC\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\default.py", line 26, in <module>
                                                import resources.lib.menu as menu
                                              File "C:\Users\HTPC\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\menu.py", line 474, in <module>
                                              File "C:\Users\HTPC\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 1334, in getInstantQueue
                                              File "C:\Users\HTPC\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 1309, in initApp
                                                f = open(userInfoFileLoc,'r+')
                                            IOError: (2, 'No such file or directory', 'C:\\Users\\HTPC\\AppData\\Roaming\\XBMC\\userdata\\addon_data\\plugin.video.xbmcflicks\\userinfo.txt')
20:25:52 T:2860 M:1539960832   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.xbmcflicks/?mode=10
20:25:52 T:2860 M:1539960832   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.xbmcflicks/?mode=10) failed
20:25:52 T:5428 M:1539620864  NOTICE: -->Python Interpreter Initialized<--

- down.easter - 2011-04-23

down.easter Wrote:Hi I have been trying to get the Netflicks plug-in to work on my first generation Apple TV and have had no success so far. I have installed Firefox and silverlight but have had no success getting the browser to come to the front so I can get the activation code. Even then I wonder how to manage to key in the info as the ATv has no keyboard and I can't find how to load the drivers for one (it does have a USB port).
Any help would be appreciated.

Okay I am slightly farther ahead. I have installed an app called Remote HD on my IOS device and on the appletv. I now have a keyboard but can't get the cmd tab key sequence to work so I can switch between programs (XBMC and Firefox to be exact). I also can't get past the Netflicks welcome screen (i.e. "Thanks for installing. Once installation is complete restart browser") I have restarted firefox a number of times but this is as far as things get. Does anyone have any suggestions? BTW I am using an exact copy of the XBMCFlicks plugin as on my iMac running Snow Leopard. It works well on the iMac and I can switch to the movie or TV show I selected with no problems. I have also used the ATVusb creator (v 3) to jailbreak my appletv and followed the awkwardtv site's instructions for installing silverlight and Firefox.

- arcooke - 2011-04-24

Problem here.

Just subscribed to netflix. Just downloaded XF from the repo. Every time I try to do ANYTHING in XF, it minimizes XBMC and opens the browser asking me to authorize 'xbmcflicks'. I authorize it and it says it was successfully authorized.. so I tab back into XBMC and it's stuck at "retrieving info 0%", and if I hit cancel, XBMC locks up and I have to kill the process.

I've been trying to fix this for well over an hour.. and have been reading trying to find someone else with the same problem.

One thing I did notice, is that my userinfo.txt is completely empty, 0 bytes (perhaps because I'm forced to kill the XBMC.EXE process before it gets written to?). I tried deleting it as was suggested in another post.. and it recreates the file but nothing ever gets written to it. Just stays empty.

Anyone know what to do? I'm getting unbelievably frustrated with this.

- Atreides - 2011-04-24

I am getting the same issue with XBMC flicks not showing any information after I go through the initial stage of setting it up. I link the account, and then it tells me to restart XBMC, I do this and there are no videos in any category. I also checked the plugin folder and I do not have the userinfo.txt file anywhere. Is there a fix for this, or somewhere where I can get a copy of a user file to modify and make it work?

EDIT:OK, so I ran through the entire thread and I found where people where having a similar issue, and it was stated that they need to turn on debugging and verbose user information. After that they need to open the log file, (Which for me would be in C:/User/*username*/Roaming/XBMC/Logfile.txt, Win7 64 bit OS) and there would be a line that would have the Key and Secret needed to put in the iqueue.py file. I tried this and it did not work, but I feel like I am missing something.

EDIT 2: OK, so I have looked closer at other peoples log files and I am not getting the same log entry as they are. For mine there i no Key or Secret in the log file. Here is my latest log.

Quote:08:42:06 T:4936 M:1842008064 NOTICE: ##########################################################
08:42:06 T:4936 M:1842008064 NOTICE: root folder: C:\Users\MediaCenter\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks
08:42:06 T:4936 M:1842008064 NOTICE: working folder: C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\
08:42:06 T:4936 M:1842008064 NOTICE: links folder: C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links
08:42:06 T:4936 M:1842008064 NOTICE: real link path: C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links
08:42:06 T:4936 M:1842008064 NOTICE: resource folder: C:\Users\MediaCenter\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources
08:42:06 T:4936 M:1842008064 NOTICE: lib folder: C:\Users\MediaCenter\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib
08:42:06 T:4936 M:1842008064 NOTICE: userinfo folder: C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\
08:42:06 T:4936 M:1842008064 NOTICE: USER INFO FILE LOC: C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\userinfo.txt
08:42:06 T:4936 M:1842003968 NOTICE: matched file contents, it is in the correct format
08:42:06 T:4936 M:1842003968 NOTICE: finished loading up user information from file
08:42:06 T:4936 M:1842003968 NOTICE: .. getAuth called ..
08:42:06 T:4936 M:1842003968 NOTICE: OSX Setting is set to: False
08:42:06 T:4936 M:1842003968 NOTICE: .. user configured ..
08:42:06 T:4936 M:1842003968 NOTICE: *** What's in the Instant Queue? ***
08:42:06 T:4936 M:1842003968 NOTICE: params: {'max_results': '75'}
08:42:06 T:4936 M:1842003968 NOTICE: http://api.netflix.com/users/BQAJAAEDEKyddWWEHBy427G_mqB17wQwOyeMFnEMfy27uaNpqsK_FSJzBhy4CZayLjzNlkKIrzAMufKpIh9vi6uYv7H14niK/queues/instant/available?oauth_nonce=78020008&oauth_timestamp=1303652526&oauth_consumer_key=******************&oauth_signature_method=HMAC-SHA1&oauth_version=1.0&max_results=75&oauth_token=**************************************&filters=http%3A%2F%2Fapi.netflix.com%2Fcategories%2Ftitle_formats%2Finstant&v=2.0&output=json&oauth_signature=*****************************%3D&expand=%40title%2C%40synopsis%2C%40directors%2C%40formats%2C%40episodes%2C%40short_synopsis
08:42:07 T:4936 M:1841958912 NOTICE: Max value: 75
08:42:07 T:4936 M:1841958912 NOTICE: In CA: False
08:42:07 T:4936 M:1841958912 NOTICE: {u'queue': [], u'track_url': u'http://api.netflix.com/catalog?track_id=2727717', u'meta': {u'queue_length': 0, u'available queue': u'http://api.netflix.com/users/BQAJAAEDEI7veXu7lKIYsxifhZciN2gwlHua2q8Y5d_kWe1ziunP--bufnneGlcg0EPPeb-TkdZX4-ZxXiclg043qZY6n3ot/queues/instant/available', u'etag': u'0', u'saved queue': u'http://api.netflix.com/users/BQAJAAEDEI7veXu7lKIYsxifhZciN2gwlHua2q8Y5d_kWe1ziunP--bufnneGlcg0EPPeb-TkdZX4-ZxXiclg043qZY6n3ot/queues/instant/saved'}, u'track_id': 2727717}
08:42:08 T:4848 M:1843380224 WARNING: XFILE::CVideoDatabaseDirectory::GetLabel - Unknown nodetype requested 6
08:42:09 T:2884 M:1843433472 NOTICE: -->Python Interpreter Initialized<--
08:42:09 T:2884 M:1842335744 NOTICE: ##########################################################
08:42:09 T:2884 M:1842335744 NOTICE: Arg1: 0
08:42:09 T:2884 M:1842335744 NOTICE: Arg2: ?mode=0
08:42:09 T:2884 M:1842335744 NOTICE: Mode: 0
08:42:09 T:2884 M:1842335744 NOTICE: ##########################################################
08:42:09 T:4848 M:1842335744 WARNING: XFILE::CVideoDatabaseDirectory::GetLabel - Unknown nodetype requested 6

Note:I replaced some of the code with * since I do not know what someone can do with this stuff. Thought I would be safe rather than sorry. Smile


- johol545 - 2011-04-25

saskwatch Wrote:For some reason, the plugin does not ask me to authorize. IE does not pop-up for me. Any thoughts?

I got the same problem. I managed to solve it to set IE as default browser instead of FireFox.

- anixon - 2011-04-25

Hi guys, I'm new to XBMC i installed the plugin and I got it working.

Just a note for OSX users, the script seems to default to Firefox on OSX. I was using chrome and it wouldn't pop a browser to register with netflix, switched my default browser to firefox and it worked.

Anyways, when i choose a show it loads up a new chrome tab and starts playing but it's really intrusive. It doesn't go full screen and instead of opening it's own chrome window it just makes a new tab in my current browser.

How can i control the browser settings to make it seem more integrated. I.E> get it to automatically go full screen and also open it's own window.

Here is my config files.


<player name="IE" type="ExternalPlayer">

<rules action="prepend">
<rule name="htm" filetypes="htm" player="IE" />

Thanks, any help is appreciated.