Kodi Community Forum
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC (/showthread.php?tid=87552)



- fekker - 2011-05-05

eQUIV Wrote:Excellent. The updated wrapper works now. However, the focus function does not. I still have to click before I can send keyboard/remote presses.

I would like to thank you for your hard work and efforts to resolve the problem. Perhaps yourself or someone can come up with a proper solution soon.

if you press f10 does it close the wrapper?
I'm wondering if it's that that the wrapper doesn't have focus, or the embedded window on that wrapper needs the focus.


- skrypj - 2011-05-05

dont know if this is where I should post but here it goes.

I just installed XBMCflicks on XBMC on OSX 10.6.7. It installed fine but then when i was propmted to "Click ok after you finish the link in your browser" but my browser is never opened so I cannot register the device with Netflix. Any idea what I should do.

I was running chrome as my default browser and tried setting Safari to default but that did not work. I did go into the configurator and specified that it was OSX as well.

THANKS!


- Atreides - 2011-05-06

Hey guys
I keep running into an issue where the iewrap just wont open. I have my playercore settings correct and it will only open in IE. I have the logs and player core posted. Anyone else running into this? I don't know where else to tell the plugin to point to the iewrap. I am using the latest iewrap and I appreciate any help I can get on this. Thanks!

Code:
ame: c:\Program Files (x86)\Internet Explorer\iexplore.exe
17:57:44 T:5552 M:1925488640 WARNING: ExternalPlayer: invalid value for warpcursor: none
17:57:44 T:5552 M:1925488640  NOTICE: ExternalPlayer Tweaks: hideconsole (false), hidexbmc (false), islauncher (false), warpcursor (none)
17:57:44 T:5552 M:1925488640  NOTICE: CExternalPlayer::OpenFile: C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149443.html
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: Player : c:\Program Files (x86)\Internet Explorer\iexplore.exe
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: File   : C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149443.html
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: Content:
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: Args   : -k "{1}"
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: Start
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: Releasing audio device 2
17:57:44 T:5888 M:1926193152  NOTICE: CExternalPlayer::ExecuteAppW32: c:\Program Files (x86)\Internet Explorer\iexplore.exe "c:\Program Files (x86)\Internet Explorer\iexplore.exe" -k "C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149443.html"
17:58:00 T:5888 M:1913659392  NOTICE: CExternalPlayer::ExecuteAppW32: WAIT_OBJECT_0
17:58:00 T:5888 M:1913659392  NOTICE: CExternalPlayer::Process: Stop
17:58:00 T:5888 M:1913659392  NOTICE: CExternalPlayer::Process: Showing XBMC window
17:58:01 T:5888 M:1922179072  NOTICE: CExternalPlayer::Process: Reclaiming audio device 2
17:58:01 T:5552 M:1923047424 WARNING: XFILE::CVideoDatabaseDirectory::GetLabel - Unknown nodetype requested 6
18:03:24 T:5552 M:1937694720  NOTICE: ExternalPlayer Filename: c:\Program Files (x86)\Internet Explorer\iexplore.exe
18:03:24 T:5552 M:1937694720 WARNING: ExternalPlayer: invalid value for warpcursor: none
18:03:24 T:5552 M:1937694720  NOTICE: ExternalPlayer Tweaks: hideconsole (false), hidexbmc (false), islauncher (false), warpcursor (none)
18:03:24 T:5552 M:1937694720  NOTICE: CExternalPlayer::OpenFile: C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149444.html
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: Player : c:\Program Files (x86)\Internet Explorer\iexplore.exe
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: File   : C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149444.html
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: Content:
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: Args   : -k "{1}"
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: Start
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: Releasing audio device 2
18:03:24 T:5692 M:1938665472  NOTICE: CExternalPlayer::ExecuteAppW32: c:\Program Files (x86)\Internet Explorer\iexplore.exe "c:\Program Files (x86)\Internet Explorer\iexplore.exe" -k "C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149444.html"
18:03:37 T:5692 M:1931898880  NOTICE: CExternalPlayer::ExecuteAppW32: WAIT_OBJECT_0
18:03:37 T:5692 M:1931898880  NOTICE: CExternalPlayer::Process: Stop
18:03:37 T:5692 M:1931898880  NOTICE: CExternalPlayer::Process: Showing XBMC window
18:03:37 T:5692 M:1931268096  NOTICE: CExternalPlayer::Process: Reclaiming audio device 2
18:03:38 T:5552 M:1931386880 WARNING: XFILE::CVideoDatabaseDirectory::GetLabel - Unknown nodetype requested 6

Code:
<playercorefactory>
  <players>
    <player name="IE" type="ExternalPlayer">
     <filename>C:\iewrap.exe</filename>
     <args>Focus "{1}"</args>
     <hidexbmc>false</hidexbmc>
     <hideconsole>false</hideconsole>
     <warpcursor>none</warpcursor>
    </player>
  </players>

  <rules action="prepend">
    <rule name="html" filetypes="html" player="IE" />
  </rules>
</playercorefactory>



Script Error - dbrine - 2011-05-06

I following the wiki and various post. can someone help? here is my log

[HTML]
16:03:44 T:4968 M:4294967295 NOTICE: ##########################################################
16:03:44 T:4968 M:4294967295 NOTICE: root folder: C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks
16:03:44 T:4968 M:4294967295 NOTICE: working folder: C:\Users\dbrine\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\
16:03:44 T:4968 M:4294967295 NOTICE: links folder: C:\Users\dbrine\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links
16:03:44 T:4968 M:4294967295 NOTICE: real link path: C:\Users\dbrine\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links
16:03:44 T:4968 M:4294967295 NOTICE: resource folder: C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources
16:03:44 T:4968 M:4294967295 NOTICE: lib folder: C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib
16:03:44 T:4968 M:4294967295 NOTICE: userinfo folder: C:\Users\dbrine\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\
16:03:44 T:4968 M:4294967295 NOTICE: USER INFO FILE LOC: C:\Users\dbrine\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\userinfo.txt
16:03:44 T:4968 M:4294967295 NOTICE: couldn't load user information from userinfo.txt file
16:03:44 T:4968 M:4294967295 NOTICE: .. getAuth called ..
16:03:44 T:4968 M:4294967295 NOTICE: OSX Setting is set to: False
16:03:44 T:4968 M:4294967295 NOTICE: .. user configured ..
16:03:44 T:4968 M:4294967295 ERROR: Error Type: socket.error
16:03:44 T:4968 M:4294967295 ERROR: Error Contents: (10054, 'Connection reset by peer')
16:03:44 T:4968 M:4294967295 ERROR: Traceback (most recent call last):
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\default.py", line 26, in ?
import resources.lib.menu as menu
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\menu.py", line 474, in ?
getInstantQueue()
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 1362, in getInstantQueue
initApp()
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 1357, in initApp
user = getAuth(netflixClient,VERBOSE_USER_LOG)
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 61, in getAuth
(tok, url) = netflix.user.getRequestToken()
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\Netflix.py", line 45, in getRequestToken
response = client.connection.getresponse()
File "special://xbmc/system/python/Lib\httplib.py", line 866, in getresponse
response.begin()
File "special://xbmc/system/python/Lib\httplib.py", line 336, in begin
version, status, reason = self._read_status()
File "special://xbmc/system/python/Lib\httplib.py", line 294, in _read_status
line = self.fp.readline()
File "special://xbmc/system/python/Lib\socket.py", line 317, in readline
data = recv(1)
error: (10054, 'Connection reset by peer')
16:03:44 T:7428 M:4294967295 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.xbmcflicks/?mode=10
16:03:44 T:7428 M:4294967295 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.xbmcflicks/?mode=10) failed
16:03:44 T:4904 M:4294967295 NOTICE: -->Python Interpreter Initialized<--[/HTML]


- fekker - 2011-05-06

Atreides Wrote:Hey guys
I keep running into an issue where the iewrap just wont open. I have my playercore settings correct and it will only open in IE. I have the logs and player core posted. Anyone else running into this? I don't know where else to tell the plugin to point to the iewrap. I am using the latest iewrap and I appreciate any help I can get on this. Thanks!

Code:
ame: c:\Program Files (x86)\Internet Explorer\iexplore.exe
17:57:44 T:5552 M:1925488640 WARNING: ExternalPlayer: invalid value for warpcursor: none
17:57:44 T:5552 M:1925488640  NOTICE: ExternalPlayer Tweaks: hideconsole (false), hidexbmc (false), islauncher (false), warpcursor (none)
17:57:44 T:5552 M:1925488640  NOTICE: CExternalPlayer::OpenFile: C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149443.html
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: Player : c:\Program Files (x86)\Internet Explorer\iexplore.exe
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: File   : C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149443.html
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: Content:
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: Args   : -k "{1}"
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: Start
17:57:44 T:5888 M:1925488640  NOTICE: CExternalPlayer::Process: Releasing audio device 2
17:57:44 T:5888 M:1926193152  NOTICE: CExternalPlayer::ExecuteAppW32: c:\Program Files (x86)\Internet Explorer\iexplore.exe "c:\Program Files (x86)\Internet Explorer\iexplore.exe" -k "C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149443.html"
17:58:00 T:5888 M:1913659392  NOTICE: CExternalPlayer::ExecuteAppW32: WAIT_OBJECT_0
17:58:00 T:5888 M:1913659392  NOTICE: CExternalPlayer::Process: Stop
17:58:00 T:5888 M:1913659392  NOTICE: CExternalPlayer::Process: Showing XBMC window
17:58:01 T:5888 M:1922179072  NOTICE: CExternalPlayer::Process: Reclaiming audio device 2
17:58:01 T:5552 M:1923047424 WARNING: XFILE::CVideoDatabaseDirectory::GetLabel - Unknown nodetype requested 6
18:03:24 T:5552 M:1937694720  NOTICE: ExternalPlayer Filename: c:\Program Files (x86)\Internet Explorer\iexplore.exe
18:03:24 T:5552 M:1937694720 WARNING: ExternalPlayer: invalid value for warpcursor: none
18:03:24 T:5552 M:1937694720  NOTICE: ExternalPlayer Tweaks: hideconsole (false), hidexbmc (false), islauncher (false), warpcursor (none)
18:03:24 T:5552 M:1937694720  NOTICE: CExternalPlayer::OpenFile: C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149444.html
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: Player : c:\Program Files (x86)\Internet Explorer\iexplore.exe
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: File   : C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149444.html
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: Content:
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: Args   : -k "{1}"
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: Start
18:03:24 T:5692 M:1937694720  NOTICE: CExternalPlayer::Process: Releasing audio device 2
18:03:24 T:5692 M:1938665472  NOTICE: CExternalPlayer::ExecuteAppW32: c:\Program Files (x86)\Internet Explorer\iexplore.exe "c:\Program Files (x86)\Internet Explorer\iexplore.exe" -k "C:\Users\MediaCenter\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70149444.html"
18:03:37 T:5692 M:1931898880  NOTICE: CExternalPlayer::ExecuteAppW32: WAIT_OBJECT_0
18:03:37 T:5692 M:1931898880  NOTICE: CExternalPlayer::Process: Stop
18:03:37 T:5692 M:1931898880  NOTICE: CExternalPlayer::Process: Showing XBMC window
18:03:37 T:5692 M:1931268096  NOTICE: CExternalPlayer::Process: Reclaiming audio device 2
18:03:38 T:5552 M:1931386880 WARNING: XFILE::CVideoDatabaseDirectory::GetLabel - Unknown nodetype requested 6

Code:
<playercorefactory>
  <players>
    <player name="IE" type="ExternalPlayer">
     <filename>C:\iewrap.exe</filename>
     <args>Focus "{1}"</args>
     <hidexbmc>false</hidexbmc>
     <hideconsole>false</hideconsole>
     <warpcursor>none</warpcursor>
    </player>
  </players>

  <rules action="prepend">
    <rule name="html" filetypes="html" player="IE" />
  </rules>
</playercorefactory>

my guess is your chaning the wrong playercorefactory
look for one in C:\Users\MediaCenter\AppData\Roaming\XBMC


- fekker - 2011-05-06

dbrine Wrote:I following the wiki and various post. can someone help? here is my log

[HTML]
16:03:44 T:4968 M:4294967295 NOTICE: ##########################################################
16:03:44 T:4968 M:4294967295 NOTICE: root folder: C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks
16:03:44 T:4968 M:4294967295 NOTICE: working folder: C:\Users\dbrine\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\
16:03:44 T:4968 M:4294967295 NOTICE: links folder: C:\Users\dbrine\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links
16:03:44 T:4968 M:4294967295 NOTICE: real link path: C:\Users\dbrine\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links
16:03:44 T:4968 M:4294967295 NOTICE: resource folder: C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources
16:03:44 T:4968 M:4294967295 NOTICE: lib folder: C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib
16:03:44 T:4968 M:4294967295 NOTICE: userinfo folder: C:\Users\dbrine\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\
16:03:44 T:4968 M:4294967295 NOTICE: USER INFO FILE LOC: C:\Users\dbrine\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\userinfo.txt
16:03:44 T:4968 M:4294967295 NOTICE: couldn't load user information from userinfo.txt file
16:03:44 T:4968 M:4294967295 NOTICE: .. getAuth called ..
16:03:44 T:4968 M:4294967295 NOTICE: OSX Setting is set to: False
16:03:44 T:4968 M:4294967295 NOTICE: .. user configured ..
16:03:44 T:4968 M:4294967295 ERROR: Error Type: socket.error
16:03:44 T:4968 M:4294967295 ERROR: Error Contents: (10054, 'Connection reset by peer')
16:03:44 T:4968 M:4294967295 ERROR: Traceback (most recent call last):
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\default.py", line 26, in ?
import resources.lib.menu as menu
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\menu.py", line 474, in ?
getInstantQueue()
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 1362, in getInstantQueue
initApp()
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 1357, in initApp
user = getAuth(netflixClient,VERBOSE_USER_LOG)
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 61, in getAuth
(tok, url) = netflix.user.getRequestToken()
File "C:\Users\dbrine\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\Netflix.py", line 45, in getRequestToken
response = client.connection.getresponse()
File "special://xbmc/system/python/Lib\httplib.py", line 866, in getresponse
response.begin()
File "special://xbmc/system/python/Lib\httplib.py", line 336, in begin
version, status, reason = self._read_status()
File "special://xbmc/system/python/Lib\httplib.py", line 294, in _read_status
line = self.fp.readline()
File "special://xbmc/system/python/Lib\socket.py", line 317, in readline
data = recv(1)
error: (10054, 'Connection reset by peer')
16:03:44 T:7428 M:4294967295 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.xbmcflicks/?mode=10
16:03:44 T:7428 M:4294967295 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.xbmcflicks/?mode=10) failed
16:03:44 T:4904 M:4294967295 NOTICE: -->Python Interpreter Initialized<--[/HTML]
firewall setting ?
seems to be a network error: Connection reset by peer'


- fekker - 2011-05-06

skrypj Wrote:dont know if this is where I should post but here it goes.

I just installed XBMCflicks on XBMC on OSX 10.6.7. It installed fine but then when i was propmted to "Click ok after you finish the link in your browser" but my browser is never opened so I cannot register the device with Netflix. Any idea what I should do.

I was running chrome as my default browser and tried setting Safari to default but that did not work. I did go into the configurator and specified that it was OSX as well.

THANKS!
it's possible it was in the window behind xbmc, hopefully one of the mac users can assist


- dbrine - 2011-05-06

Forgot to add my configuration.

Windows 7 Home
latest XBMC
Netflix 1.0.19 plugin


- skrypj - 2011-05-06

fekker Wrote:it's possible it was in the window behind xbmc, hopefully one of the mac users can assist

No its not, I had it minimized to make sure. Is there a link that I could type in manually or does it need to happen via the script?


- fekker - 2011-05-06

skrypj Wrote:No its not, I had it minimized to make sure. Is there a link that I could type in manually or does it need to happen via the script?

yup, from the faq

Code:
1. Get nexflix working on your machine natively - this will ensure that you already have siverlight and anything else netflix might want to get working.

2. Turn on Plugin Debugging
   Go to Videos / Add-Ons
   Right Click XBMC Flicks
   Select Add-On Settings
   Under Debugging, turn on Both options
   Back out to the Add-Ons menu

3. Start XBMC Flicks

At this point your bowser should kick off asking you the account to authorise for netflix usage - do so.  If that doenst kick off, you can pull the url from the xbmc.log file in a line that looks like "Authorize user access here: https://api-user.netflix.com/..."
    

4. Get your 'key' and 'secret' values from the XBMC.LOG file
   Open the debug log - %appdata%\XBMC\xbmc.log
   Find the lines near the bottom mentioning the 'key' and 'secret' - you will need those values

5. Put your 'key' and 'secret' values into the iqueue.py file
   Open %appdata%\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py
      Note, windows notepad is not a good util for this, best getting something like Programmers File Editor (freeware)
   Find the section of the file called MY_USER = {
   Put in the key and secret (from the xbmc.log) between the ' ' for those values both by 'request' and 'access'



- skrypj - 2011-05-06

fekker Wrote:yup, from the faq

Code:
1. Get nexflix working on your machine natively - this will ensure that you already have siverlight and anything else netflix might want to get working.

2. Turn on Plugin Debugging
   Go to Videos / Add-Ons
   Right Click XBMC Flicks
   Select Add-On Settings
   Under Debugging, turn on Both options
   Back out to the Add-Ons menu

3. Start XBMC Flicks

At this point your bowser should kick off asking you the account to authorise for netflix usage - do so.  If that doenst kick off, you can pull the url from the xbmc.log file in a line that looks like "Authorize user access here: https://api-user.netflix.com/..."
    

4. Get your 'key' and 'secret' values from the XBMC.LOG file
   Open the debug log - %appdata%\XBMC\xbmc.log
   Find the lines near the bottom mentioning the 'key' and 'secret' - you will need those values

5. Put your 'key' and 'secret' values into the iqueue.py file
   Open %appdata%\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py
      Note, windows notepad is not a good util for this, best getting something like Programmers File Editor (freeware)
   Find the section of the file called MY_USER = {
   Put in the key and secret (from the xbmc.log) between the ' ' for those values both by 'request' and 'access'

Thanks! Ive been using my Wii for netflix and I hate it with a passion. Im excited to try this


- skrypj - 2011-05-06

Just so you know, I was checking my log file and it appears that it was calling for "Firefox.app" which I dont have, could that be the issue?

NOTICE: open /Applications/Firefox.app . . . . .


- DLJones - 2011-05-06

Can someone tell me way IE is not opening up with netflix? Below is what the log capture trying to watch a movie.

22:24:30 T:4864 M:2829676544 NOTICE: curTitle: [email protected]
22:24:30 T:4864 M:2829676544 NOTICE: curTitleShort: [email protected] [PG] (2007)
22:24:30 T:4864 M:2829676544 NOTICE: curRating: 3.8999999999999999
22:24:30 T:4864 M:2829676544 NOTICE: curRuntime: 6480
22:24:30 T:4864 M:2829676544 NOTICE: curGenres: Documentary
22:24:30 T:4864 M:2829676544 NOTICE: curID: 70084235
22:24:30 T:4864 M:2829676544 NOTICE: curPoster: http://cdn-2.nflximg.com/us/boxshots/ghd/70084235.jpg
22:24:30 T:4864 M:2829676544 NOTICE: curSynop: Available Until: 01 Apr 2012
22:24:30 T:4864 M:2829676544 NOTICE: curDirector: "Stephen Walker}, {uid: uhttp://api.netflix.com/catalog/people/30151284",
22:24:30 T:4864 M:2829676544 NOTICE: curFullId:
22:24:36 T:5644 M:2830254080 NOTICE: DVDPlayer: Opening: D:\Documents and Settings\djones\Application Data\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70084235.html
22:24:36 T:5644 M:2830331904 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
22:24:36 T:2196 M:2830323712 NOTICE: Creating InputStream
22:24:36 T:2196 M:2830778368 NOTICE: Creating Demuxer
22:24:36 T:2196 M:2826530816 ERROR: CDVDDemuxFFmpeg::Open - error probing input format, D:\Documents and Settings\djones\Application Data\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70084235.html
22:24:36 T:2196 M:2826530816 ERROR: CDVDPlayer::OpenDemuxStream - Error creating demuxer
22:24:36 T:2196 M:2826530816 NOTICE: CDVDPlayer::OnExit()
22:24:36 T:2196 M:2826530816 NOTICE: CDVDPlayer::OnExit() deleting input stream
22:24:36 T:5644 M:2826518528 ERROR: Playlist Player: skipping unplayable item: 0, path [D:\Documents and Settings\djones\Application Data\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\70084235.html]
22:24:36 T:5644 M:2826514432 NOTICE: CDVDPlayer::CloseFile()
22:24:36 T:5644 M:2826514432 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
22:24:36 T:5644 M:2826514432 NOTICE: DVDPlayer: waiting for threads to exit
22:24:36 T:5644 M:2826514432 NOTICE: DVDPlayer: finished waiting
22:24:46 T:2096 M:2827411456 NOTICE: -->Python Interpreter Initialized<--
22:24:46 T:2096 M:2824065024 NOTICE: ##########################################################
22:24:46 T:2096 M:2824065024 NOTICE: Arg1: 0
22:24:46 T:2096 M:2824065024 NOTICE: Arg2: ?mode=0
22:24:46 T:2096 M:2824052736 NOTICE: Mode: 0
22:24:46 T:2096 M:2824052736 NOTICE: ##########################################################


- fekker - 2011-05-06

skrypj Wrote:Just so you know, I was checking my log file and it appears that it was calling for "Firefox.app" which I dont have, could that be the issue?

NOTICE: open /Applications/Firefox.app . . . . .

yup, if you don't have firefox you'll either need to change that line or install it
At some point i'll add in more options into the UI for OSX, to help everyone out, please post your config once ya get it sorted out.

Quote:DLJones Can someone tell me way IE is not opening up with netflix? Below is what the log capture trying to watch a movie.
You must already have a playercorefactory.xml file, if it was missing xbmcflicks would make one, if you already have one, you need to modify it, please see post 1/2/3 for details on what files to modify.


- eQUIV - 2011-05-06

fekker Wrote:if you press f10 does it close the wrapper?
I'm wondering if it's that that the wrapper doesn't have focus, or the embedded window on that wrapper needs the focus.

Yes, F10 does close the wrapper. So does that mean it's the embedded window?

I also noticed that if I come back to XBMC after a few hours of being away -- when I select a video the wrapper will load directly to Netflix homepage instead of the selected video. When I then close the wrapper, and re-select the video it loads fine and all following selections load fine. Has anyone else using the wrapper experienced this? Not a huge deal, but a little strange. Almost as if it times out and needs to be re-verified .