Kodi Community Forum
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC (/showthread.php?tid=87552)

- vtwin0001 - 2011-06-21


I guess this has been addressed sometime in the past, so I apologize if it has.

My question is:

Is it possible to make xbmcflick work as an app rather than an Add-on, so that it in fact could work as a streamer rather than just a link between xbmc and firefox (et al)?

Thank you for such great support Smile

- jgonsalves - 2011-06-26

Seems like a great Add-on thanks!

just having one issue with getting listings from netflixs.ca.

The issue is Flicks does not retrieve any information for the following options. "Top 25 New Arrivals: TV", "All New Arrivals: TV", and "browse by Genre".

any help is appreciated.

retrieve issue - jgonsalves - 2011-06-26

Seems like a great Add-on thanks!

just having one issue with getting listings from netflixs.ca.

The issue is Flicks does not retrieve any information for the following options. "Top 25 New Arrivals: TV", "All New Arrivals: TV", and "browse by Genre".

any help is appreciated.

- Jonstar - 2011-06-26

jgonsalves Wrote:Seems like a great Add-on thanks!

just having one issue with getting listings from netflixs.ca.

The issue is Flicks does not retrieve any information for the following options. "Top 25 New Arrivals: TV", "All New Arrivals: TV", and "browse by Genre".

any help is appreciated.

Having the same problem too.

- zeny - 2011-06-30

Jonstar Wrote:Having the same problem too.

Same here as well ...also "Recommendations" doesn't populate for me as well. I have debugging on and nothing shows up as an error.

- lordabdul - 2011-07-02

I tried XBMCFlicks up here in Canada and at first I couldn't even see my Instant Queue. I went into the code and realized it was disabled for Canadian users... why is that? I uncommented the conditional statement and got a working Instant Queue right away.

Also, some of the listings are for american users. For example, getting the list of episodes for a TV series, or browsing the new arrivals, all return US results (which means sometimes a TV series is empty, or sometimes a title can't actually be played). I fixed the code in a few places to make it work. I didn't fix all the problems yet, but the main ones are fixed. How can I submit the patches back to the dev team? (the fixes are really minimal so far).

- TerranQ - 2011-07-03

Any chance you can upload your fixed version for us Canadians? I'm not using this plugin for those very reasons. Thanks

- Sycobob - 2011-07-04

fekker Wrote:you can rem out the menu items from the menu.py file (for those ya don't want)

As for adding it as a source, not so much, but what you can do is to create a bookmark to whatever section ya want, and have that linked off the main xbmc window (that's what i use), there's an addon that lets you add bookmarks to the xbmc home page.

Awesome, this will work.

I've noticed something else I'd like to ask about. Some movies and shows don't show the plot, some don't show runtimes, some show neither. Any idea what might be causing this? Also, some TV shows show a runtime of 0 and some show a runtime that's the sum of all the episodes.

EDIT: Forgot to mention, Browse By Genre doesn't work

I'm reading what I can find about adding things to the home screen, but everything I can find says to modify either the skin or XBMC .xmls to do it. I can't find a bookmarking addon. There's Launcher and Executor, but those don't seem to be what you meant. I don't mind messing with the .xmls if I need to, but the addon would be a much cleaner option, imo.

- risner - 2011-07-05

Fekker, am I the only one having trouble?

It hasn't worked since Feb 2011 for me.
Either the browser appears behind the XBMC interface, or in front non-full screen.
The controls don't kill the browser window, I need to log into the box and kill -9 the browser.

I've reinstalled the plugin and XBMC several times (most recently today.)

What should I do to get it to work again? Or is it no longer supported on MacOS Snow Leopard?

- fekker - 2011-07-06

Browse by Genre fix

open the iqueue.py file
search for

replace it with

for OSX, and it popping up behind xbmc, I'm gonna have to ask one of the OSX users to chime in (i don't have a system to test it on) but it's a setting somewhere

lordabdul - shoot me the code changes via PM or create a github account and send me your username and I can add you to github so you can post a patch for it, you could even use pastebin it if ya like, currently it's just me working on xbmcflicks so not really an in place formal method

Maybe someday netflix will actually release the api information for netflix.ca and I won't have to guess what calls to make, hopefully before they go and expand to every country as that's going to be a nightmare without some documentation from netflix

- xboxbox451 - 2011-07-09

@fekker, thanks for the development of this plugin, it works great. It actually works better and is more reliable than the three other streaming solutions I've tried for Netflix. For instance...
  • Netflix on Firefox: video always freezes, though audio keeps playing
  • Netflix on Windows Media Center: major audio sync problems
  • Netflix on Internet Explorer: Video keeps blanking
Right outta the box, XBMC Flicks has been working perfectly for me. I applied that fix for Genres, which works great. Thanks.

I was over at the EventGhost forum, and asked the dev of the XBMC2 plugin for an option to add an XBMC Flicks action and he promptly provided a solution for anyone that's interested. The action shown in the post will take you right into Instant Movies and Shows. This solution sends an HTTP command, so make sure "Allow control of XBMC via HTTP" is turned on in system settings.

EventGhost Link

If you want to go into the first window of XBMC Flicks, use this code in place of whats listed on the EG forum post.


Thanks again for your continued development.

- johnlocke - 2011-07-10

Anyone have an eventghost file for actually controlling the thing. i've seen some stuff previously in this thread but they don't seem to be very fluid. This is the only thing keeping me from using this great plugin. I currently use boxee for Netflix but would love to use it straight from XBMC.

I have my own makeshift eg profile but it's sorely lacking.

Thanks guys.

- speed32219 - 2011-07-10

I uderstand that google chrome will support Netflix using linux. It was suppose to be released June 15th, but I am looking for the status now. If netflix and google have an agreement (might be with html5) and it is being released any day if not already in beta format, how would this plugin work in that scenerio?

Snippet form another page:

"Ubuntu users rejoice! Google has been working on Netflix support at least since February. This affects not only Ubuntu users, but any linux users who also use the Chrome/Chromium web browser. It was reported this morning during the Chromebook presentation at Google I/O that there would be Netflix support. With the Chromebooks being released June 15th, we should all see Netflix support in Google Chrome within the month"

Update: I have just installed the latest chrome for linux, went to youtube and tested it on their beta html5 videos using the XBMC launcher plugin. It works great with the videos in full screen, just needs the ability to go full screen on startup which is being worked on from the google searches I did. Netflix is still looking for MAC/Win devices though, so the html5 is not yet implemented on their end.

- Raynes - 2011-07-10

When I tried to use this on my Snow Leopard mac, I wasn't able to authenticate. It tried to open Firefox but my default browser was Chrome so it threw me the actual Firefox app folder in Chrome. If you pass a URL to 'open', it'll open it in the default browser. Why not do that instead of forcing firefox?

- echosa - 2011-07-11

I have the same issue as Raynes. I spent about two hours yesterday working on this.

First off:
Brand new Mac Mini Server (2 HDs, no internal DVD drive)
Latest version of Snow Leopard Server

I read that there are issues with Apple TVs. I use a Mac Mini Server so I don't think the issues would be related, but maybe? Also, I don't think the Server part is part of the issue, since I get the same symptoms and issues when trying to get it working on my brand new Mac Book Pro at work.

Anyway, here's a quick synopsis of what I did yesterday to try to get it working on my Mac Mini Server.

At first, when I only had Safari installed (no Firefox or Chrome), I would try to view my Instant Queue, which would tell me it was opening the browser for authentication. Never happened.

I searched for an answer, and people talked about using Firefox or Chrome. I figured what the hell and installed both. Then, attempting to open Instant Queue would open Firefox to a blank page *and* Chrome to a local file page showing me the contents of Firefox.app.

I figured it was an argument issue, so I turned on the extra debugging and began digging. I found in the logs that the program was trying to run

open /Applications/Firefox.app "http://url.to.netflix/authorization?code=xxxx"

Obviously the url above is a fake placeholder, but it did seem like an appropriate url. When I copied and pasted the URL into the browser address bar, the page would load find.

A quick note, when opening an application, shouldn't you use, for instance

open -a Firefox "url-goes-here"

Anyway, I manually visited the link shown in the log file, and netflix seemed to accept the authorize. The log file also showed the token id and secret and said to put them in MV_USER.request (I think?). A bit more Google searching led me to the iqueue.py file, which has a variable where I could add the token information and secret to request.

I did so, and tried to load instant queue again thinking "ok, netflix has accepted auth and the token info is in the iqueue.py file, it should work". Fail. saw an xml error stating timeout. Ok, maybe I took too long looking up the iqueue request stuff after the netflix auth and the token expired. No problem, I'll re-auth and put the token info in asap, then try again (which is what the log says to do). I did, still didn't work.

Looking in the logs, I couldn't see any obvious config, auth, or browser errors. It looked like the python script(s) were failing. Not being much of a python developer, that's pretty much where I stopped.

So, definite issues *appear* to be:

1.) The opening of Firefox for auth. This a) shouldn't *require* Firefox, and b) should run a proper command. I should note, that I played with the playercorefactory.xml files located both in the XBMC userdata folder *and* in the netflix add-on folder. I also noticed that there is a playercorefactoryOSX.xml. I'm not sure if that file gets used instead when the Is OSX option is set. Anyway, I tried modifying the commands in both of those files, and while it seemed to make a difference, I was really only able to get the same results as before (blank Firefox, other browser open to Firefox app directory) except with Safari replacing Chrome.

2.) Adding proper token info to the correct file. It seems like the token id and secret should be added to the iqueue file automatically, since not everyone will have debugging on and have `tail -f` watching the log file. This never seemed to work.

3.) Any and all python errors in the scripts. This may be Mac OS issue, but python is pretty standard, and Snow Leopard (I would think) should have a new enough version to work.

Hopefully this information will be helpful to the devs. I'm pretty much out of ideas at this point. I've seen questions and posts on other sites (via Google searches) of others having the same, or similar, issues. It would really be great to get this working. I'm currently using Boxee instead of XBMC simply because the Netflix part works, but I would much rather use XBMC.