Kodi Community Forum
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC (/showthread.php?tid=87552)

- atandon - 2012-01-13

I am using Eden Beta.
I don't see the add on listed in the repo. I saw an earlier post suggesting that this may be a temporary thing. Any updates?

- woodg8 - 2012-01-13

I'm currently using XBMC on my second screen (via HDMI)

However when I try and play a title from xbmc, it loads the full screen IE on Window 1. Any idea how I can get it to load on Window 2?

- vogelap - 2012-01-13

atandon Wrote:I don't see the add on listed in the repo. I saw an earlier post suggesting that this may be a temporary thing. Any updates?

Same here...

- Nemesis8899 - 2012-01-13

vogelap Wrote:Same here...

same here. where did it go?

- xbmcsnapper - 2012-01-14

erkerb Wrote:Hello,

I just have a quick question.. I have the plugin installed, and linked my account. I can browse TV Shows, and start them fine. But i cannot seem to browse the Movies, other then the Top 25 that is listed on the main page. I can watch the movies IF they are on the Instant Queue. But in order to do that, i added it from the web interface. IS this how it's done? I have to go to netflix.com, browse through movies and add them to Instant Queue to watch them? Or am i missing something here?

Thank you..

You should be able to browse alphabetically, and by genre in addition to browsing your Instant Queue. Also, the search should be functional, but I don't think the experimental search works (I could have that the wrong way around - I'm not certain).

Not sure if this helps but have a look at post #619 about getting Browse by Genre to work. IIRC, that's what I needed to do to get it to work.

- apkeene - 2012-01-14

I'm new to XBMC, being a long time nextPVR (new GBPVR) user, I stumbled across XBMC when looking for a way to navigate and play netflix from my couch with a remote. I'm in Ireland with an irish netflix sub.

I've installed XBMC and version 1.0.18 of the add-on (cant find the later beta versions) and it navigates some parts fine, but like others just brings up the homepage in the browser and doesn't play. I also have a VPN subscription so can connect to the US and view US content, which plays fine when using netflix via a browers, but via the app just brings up the browser also. So I'm guessing it's related to an irish account, not the location/content actually viewed. Any thoughts? Is this likely to get fixed for UK/Irish netflix users??

- Dangelus - 2012-01-14

It seems to be a limitation of the API which is oly authorised or US accounts. It must be able to distinguish between account nationalities and disable playback on non US accounts.

I'm currently using Kylo Browser as my HTPC Netflux 10ft interface and it works pretty well. Hopefully Netlix will start to allow non-US APIs soon.

- apkeene - 2012-01-15

I think you're right re it distinguishing between account nationalities and not specifically the location of where the user happens to be. Hopefully they will sort out non US API access. Did they for Canada? Are they available anywhere else where they have or haven't bothered sorting API access? As a clue if they're likely to bother or not...

Thanks for the Kylo suggestion. Never come across that before. Will give it a go! All I want is an interface I can fire up from my PVR and control from the remote...

- iorifly - 2012-01-15

Friends, I am not able to use the plugin in Brazil! could you help me? where command shows me the movies shows movies hedge and when run from the command error.

- Icarus3000 - 2012-01-16

Is this currently working for anyone in Canada? I can browse and search, but when I click on a movie or TV title to begin streaming, nothing happens. (Windows 7, eden beta).

- xbmcsnapper - 2012-01-16

Icarus3000 Wrote:Is this currently working for anyone in Canada? I can browse and search, but when I click on a movie or TV title to begin streaming, nothing happens. (Windows 7, eden beta).

Yes - works for me in Canada with Eden beta. Also worked in Dharma. Canadian account. No VPN. With XBMC Flicks I can browse, search, instant queue, playback, it's all good. The only thing that isn't working perfectly yet is the browser doesn't obtain focus when playback begins, so I have to click somewhere onscreen before my MCE remote commands will work. Then I can full-screen, escape, pause and play. And Alt-F4 to kill it.

Unfortunately, I did not document all of the things I had to revise/fiddle with to get where I am now, but I have enabled the Canada option in the XBMC-Flicks add-on config setup, I am using IE9 (although you can apparently use any browser you want - see post #192), and the latest version of Silverlight on W7/64. I also tried the IE wrapper which also works, but I don't see why anyone would need that. If I recall correctly, the Canadian-specific changes I had to make were in the iqueue.py file, changing all occurrences of "http://www.netflix.ca" to "http://ca.netflix.com/".

Hope that helps. Other than that, I can only suggest reading through all of fekker's posts.

- erkerb - 2012-01-16

admviper Wrote:I just finished reading through all 60+ pages of this thread as well as a few others, and I cannot find the answer to my issues. All of these problems have shown to be true on 3 different installations of the software

1) Browse by Genre is blank, there are 0 results returned whenever I click it

2) Searching newly added movies returns about 90% foreign films many of which state they cannot be played at this time, nor am I able to find them on another device say the Wii or XBox.

3) Searching for any title for instance say Star Trek, returns 19 TV shows, and 0 movies. Many TV shows are quite far fetched, such as Yo Gabba Gabba. Man in the Iron Mask returned every Iron Man animated show available, right after The Office

4) Recommended fails to return the same Recommended titles that show up online, and again seem to only return TV shows and not any movies.

5) I have no idea what the experimental Search does, but that always returns 0 regardless of what I search.

I know the account is properly synced as the only thing that does seem to be working correctly is what I recently play shows up online, even if there doesn't seem to be a recently watched queue in xbmc flicks.

Thank You for your help.

This is exactly what i am experiencing.. Unless i go online, and add movies to the Instant Queue, i cannot seem to find any movies using XBMC NetFlix .:|

- Dangelus - 2012-01-16

A bit more information for UK users:

I have managed to get some success with a UK account but you need to have a VPN or similar service to access the US content.

Direct play of content does not work. All it does is open a browser windows to the Netflix home screen but the plugin does allow you to add items to your instant queue. This baffled me as UK accounts do not support instant queue (even directly on the website, over VPN browsing US content, there is NO access to one) but the plugin seems to succeed to add to one. Is it hidden or something?

Anyway, once an item is in this queue it successfully plays!

- apkeene - 2012-01-16

How did you add something to the queue? I couldn't work out how to do that with a VPN to the US or connected natively. Granted I have an irish not an uk user but assume they work the same. Mind you, I probably tried via the browser and the VPN...

I had thought that the plugin would be usable if I could fill the queue up somehow.

- Dangelus - 2012-01-16

You just get to the item you want to add, right click, select add to instant queue.