Kodi Community Forum
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC (/showthread.php?tid=87552)



- Stranger - 2012-02-03

nunovi Wrote:I can watch Netflix on my Apple TV 2 in the UK. Shouldn't it be possible then to get XBMC Flicks working too?

It's so fickle. Someone from the UK will have to take it on, and would need the knowledge and TIME to build and MAINTAIN it. The API is available, we just need a hero.

Open Source - Love/Hate/Patience


- A.D.I.D.A.S - 2012-02-04

Got some of the buttons to work but the problem now is when I launch xbmcflicks I cannot use the remote with it until I use the mouse and click the screen then it works.
Is there a way to make it run on top so I do not have to use the mouse at all??


- risner - 2012-02-04

A.D.I.D.A.S Wrote:Has anyone got this to work with a remote and function properly?

It's been broken and unusable for me since Sept 2010. Prior to 9/2010 it worked perfectly fine.

I think the guy complaining you should read the first post is saying we both missed this line in the first post:
ctrl+alt+shift+left arrow OR just F = full screen

What he doesn't care or understand is this isn't an option. I'm simply not going to stand up, walk over to the TV and click a button to make it work as it used to work before Sept 2010.

As it is now, I've asked how to get this working properly many many times over the last 16 months or so. I still don't have it working. I've reinstalled, I've installed Eden. I really have no idea what to do. It works in the background (the video is playing in the browser under the XMBC UI) but you can't see it and you can't control it (like stop the video) without logging in remotely and killing the browser window.


- xekon - 2012-02-05

my remote is working fine. I wrote a small autoit script to click the screen and put it into fullscreen.

I use girder for remote control and it launches the autoit script that I wrote when I press a button on my remote. you could possibly also create a shortcut to autoit file and in that shortcuts properties bind a hotkey to it if you dont use girder

here is the script (in order to use this you need autoit installed, or if you install autoit you can compile the script and then uninstall autoit and just use the compiled executable):

just save the below as xbmcremote.au3
Code:
opt("PixelCoordMode", 2)
opt("MouseCoordMode", 2)
Opt("WinTitleMatchMode", 2)
opt("MouseClickDelay", 100)
opt("MouseClickDownDelay", 100)

If WinExists("netflix") Then
    WinActivate("netflix")
EndIf
WinWaitActive("netflix")
Sleep(500)
MouseClick("Left", 50, 50)
Sleep(500)
Send("{f down}")
Sleep(20)
Send("{f up}")



- xekon - 2012-02-05

I am using Windows XP. All updates. current direct X, .net framework 4 client profile, ATI Radeon HD 6450 with driver 12.1 (latest)
the XBMC version that I am using is listed on this page: http://wiki.xbmc.org/index.php?title=Hi10P_playback
XBMCSetup-20111208-6094fbb-dx: http://www.mediafire.com/?e9h77fr86d04zef

I just installed this sytem. but i've used xbmc + xbmc flicks in the past on other system.

pressing ctrl+alt+shift+m brings up the menu while watching netflix and you can see the AV stats.

playing directly from IE it shows CPU Usage (process/system): 10% / 10% (on average, the two numbers jump around between 10-20% and area always about equal.)

using XBMC flicks from XBMC it shows CPU Usage (process/system): 10% / 60% (on average, the system number always has about +50% more than the process number)

What does this mean? I can only guess that XBMC is sucking up cpu time even when im running a video in netflix via xbmc flicks. Anyone got any ideas for me?

EDIT: also I am using xbmc flicks with default install and fetch 25 titles instead of 75 is the only option I changed. I did not do anything extra to install the IE wrapper, so I dont believe im using that unless its included by default.

EDIT2: on my last system it kinda did something similar but the other way around. If I watched a netflix video everything was fine, but if i closed the netflix video and wanted to watch a video on my local system through xbmc it would lag until I rebooted. so basically on my old system anytime I watched netflix I would have to reboot afterwards if I wanted to watch something from my hard drive.

I am really wondering if there is a setting or file or something that can be edited to make this run smoothly from xbmcflicks (for my system, because obviously it some obscure problem probably specific to my system or display drivers, i got no idea really) because I really love it.

EDIT3: as another test, I opened XBMC, then minimized it to desktop by pressing the windows key. then launched IE directly and loaded up a netflix video, the cpu usage process/system remain low and equal around 10% im not sure why using xbmcflicks would cause the cpu usage that im seeing, if anyone can help I would greatly appreciate it.


- xekon - 2012-02-05

Ive been trying different things for hours, tried IE, chrome, firefox, tried the iewrap wrapper. tried lots of different settings with xbmc, bios, video settings. I tested different scenarios, etc.

I finally resolved the issue by going from the home menu of XBMC to:
system > settings > system
then under "system - settings" goto the top tab "video output" and check the radio button for "Use a fullscreen window rather than true fullscreen"

once I used the fullscreen window my cpu usage is now normal. 10-20% for both process/system as upposed to 10% process 60% system.

and now the playback is smooth again, instead of getting all the screen tearing I was getting because of cpu bottleneck that was going on


- oneadvent - 2012-02-05

I tried to install this via the git from a few posts back (I installed it by downloading the zip and unzipping it to .xbmc/addons and naming it plugin.video.xbmcflix [directly under which it has the addon.xbm, so should be structured right], but it still doesn't show up under the video plugin list on xbmc, even after 2 reboots)

Can I get a walkthrough on installing this on Eden, apparently I'm missing something.


- oneadvent - 2012-02-06

OK I hear that Linux can't do SilverLight and so no netflix, but then this:
http://www.ehomeupgrade.com/2011/08/09/netflix-app-hits-the-chrome-web-store-limited-to-chrome-os-on-linux/

can we do this?


- clarity2431 - 2012-02-07

Hello, I am new to the ATV scene and I've just added XMBC and came across this plug in. I'm having a hard time getting it to function properly. I'm reading the instructions and I feel like I'm missing something or taking something out of context. If someone could please take the time to give me a little guidance, I would be much appreciative. This is a fresh install and there shouldn't be any old user data or anything like that. I've got the application working to an extent on the actual ATV but I know I'm not doing everything correctly because I'm still getting errors....Thanks for your time and help guys I truly appreciate it!


- ralph9994 - 2012-02-08

So i want to get an US Netflix Subscription.
We have a Acer Revo under the TV running XBMC live atm.

What's the best option to watch Netflix?
I checked out boxee but they stopped developing that.
And we already have XBMC. But i think its to hard for my other family members to control XBMC when im not around. Since it looks to complicated for them.
So..

Any suggestions?


- Death-Axe - 2012-02-08

This is not showing on the offical repo in the addons section, any where I can download this? Nm, found it and it doesn't work for UK DOH!.


HTTP status error 500 - neoblasted - 2012-02-10

HI,

I installed XBMC and Flicks, but when xbmc try to access the API.
https://api-user.netflix.com/oauth/login?application_name=xbmcflix&oauth_consumer_key=gnexy7jajjtmspegrux7c3dj&oauth_token=vkp5wdcd768peq44m5mbnwja

I get an error HTTP Status 500 in the browser... something is wrong ?


- xekon - 2012-02-11

go into internet explorer settings and clear the cache, when you clear the cache you will want to uncheck the box that says dont clear cache for favorited sites. because if you have even one netflix favorite then it wont clear the cache for netflix which is the whole problem.


- hardrock_121 - 2012-02-12

Death-Axe Wrote:This is not showing on the offical repo in the addons section, any where I can download this? Nm, found it and it doesn't work for UK DOH!.

I cant still find it.. where is it ?? its not under xbmc.ord =>video addons.. i m on windows 7SadSadSad


- xekon - 2012-02-12

I could not find it in the repository either. I had to download it as a zip file: https://github.com/spudsdude/XBMC-Flicks click the zip button to download as zip file.

Then in XBMC goto settings addons, install addon from zip file. and browse to where you downloaded the file.