Kodi Community Forum
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC (/showthread.php?tid=87552)



RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - tribugames - 2012-03-22

Hello y new in comunity
My english is very poor but y needhelp y testing this spudsdude-XBMC-Flicks-1d81b3a whiy eden wotk fine when vpn usa but y live en shout america please help
if anyone like to help i can send the data you need to run only the search for letter that way I can add to favorite look from the series and very grateful


RE: - TheMonkeyKing - 2012-03-23

I tested Chrome last night. It worked but still had the same issue with going back to XBMC console after exiting Chrome/Netflix.

Code:
<playercorefactory>
  <players>
    <player name="Chrome" type="ExternalPlayer">
     <filename>C:\Documents and Settings\XXXX\Local Settings\Application Data\Google\Chrome\Application\chrome.exe</filename>
     <args>--start-maximized "{1}"</args>
     <hidexbmc>false</hidexbmc>
     <hideconsole>false</hideconsole>
     <warpcursor>none</warpcursor>
    </player>
  </players>

  <rules action="prepend">
    <rule name="html" filetypes="html" player="Chrome" />
  </rules>
</playercorefactory>


I also used --kiosk instead of --start-maximized because kiosk mode is close to IE's -k switch.

ISSUES
--------------
1) Either one works but...when you try to quit, it does not exit gracefully and resume XBMC'x console. In kiosk mode, there are no controls. Using F11 on a keyboard doesn't quit the application but does change it from fullscreen. "Start maximized" shows the menu bar which disappears when the the viewer starts. However this goes back to wanting to use the diNovo mini which has no function keys. [/php]

2) I'm getting a Netflix login screen when using maximized. It does not happen when I use kiosk.

3) kiosk is incredibly laggy. However I had some other programs running so this is not definitive. But I did run it maximized with the same environment and it wasn't as laggy.

I will work on it some more this weekend.


(2012-03-07, 18:10)TheMonkeyKing Wrote: I am using Win7 Ultimate with a diNovo Mini (Logitech) keyboard/mouse. The video is ported out to my AV receiver and then on to my TV. The diNovo Mini does not have Function keys so using F4 or F10 is not possible for me. I think I may try the IE wrapper as well as testing it with IE-64.

I want to try next testing Chrome and or Nightly [Firefox 64-bit]. Unfortunately, the Nightly/Firefox browser do not come with a command line switch to put the browser into kiosk (full screen without toolbars). Chrome does so using "chrome.exe --kiosk"




RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - br_hermon - 2012-03-25

Ok.... Total newbie here.... but XBMCFlicks is not working for me. I'm trying to set it up and it isn't working.
I'm following these instructions:
http://www.howtogeek.com/howto/43724/how-to-view-netflix-watch-instantly-in-xbmc/

Those instructions indicate that "you will be prompted to click OK after you finish authorizing the add-on." Then it goes onto say a browser window should pop up from Netflix asking for permission. My problem is that xbmcflicks never "prompts me to click ok" instead when I enter it, there's a list of Instant Movies and shows, disc by mail and rental history. I click Instant movies and shows and then get a longer list. I click on any entry in that list, then an xbmc pop up briefly shows up stating "xbmc flicks - netflix for XBMC" Loading Directory Retrieved 0 items and the only button is "cancel" the reason I say briefly is because it's at that point then the IE pop up shows up requesting permission. I grant it, Minimize IE, go back to XBMC, it's still on that popup and just sits there doing nothing. If I click cancel xbmc locks up and I have to force close it. I try to re-enter XBMC, hoping it took, nope... I end up just repeating the same process over.

In an attempt to fix this, I even tried one of the opening posts, copying my "key" and "Secret" into the iqueue.py file. That somewhat helped, I can navigate through the different xbmcflicks menu options, but nothing ever shows up.

More info that may help.
System = Windows XP Pro SP3 XBMC 10.1
IE = IE8
I have already successfully viewed a netflix show through the browser. However, when I go into my account settings, Preferences, Connected Applications (which I assume would list XBMCFlicks) it isn't listed. Which I find odd, even after I granted it permission.)

Excuse me but, What the H*ll is going on!? Sorry but its driving me absolutely nuts! Please, Please,Please someone, anyone out there, can you help me? Thanks in advance.


RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - sourbob - 2012-03-25

(2012-03-20, 19:41)PantsOnFire Wrote: Colour me noob but I can't see XbmcFlicks in the add-ons list anywhere to install it. (XBMC pre-11.0 compiled 23rd Nov 2011)
where should it be?

Same here.


RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - MrsAngelD - 2012-03-25

Yeah I can't find this anywhere in the addon list Sad


RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - crimsonfury - 2012-03-25

Does this work in the new final Eden?


RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - kaktusjack - 2012-03-25

Hi,

I can't connect xbmc flicks with my netflix account.

- OSX Lion
- xbmc Eden
- xbmc flicks 1.0.22

While trying to access any watch instantly option the default browser (firefox or safari, same result) opens the netflix application linking page. Klicking Yes seems to be successful (but isn't). Within xbmc I'm getting the message "Error Script failed ..."

xbmc.log:

14:28:23 T:2954915840 NOTICE: USER INFO FILE LOC: /Users/user/Library/Application Support/XBMC/userdata/addon_data/plugin.video.xbmcflicks/userinfo.txt
14:28:23 T:2954915840 NOTICE: couldn't load user information from userinfo.txt file
14:28:23 T:2954915840 NOTICE: .. getAuth called ..
14:28:23 T:2954915840 NOTICE: OSX Setting is set to: False
14:28:23 T:2954915840 NOTICE: .. user configured ..
14:28:24 T:2954915840 NOTICE: Token did not contain any errors
14:28:24 T:2954915840 ERROR: Error Type: <type 'exceptions.IOError'>
14:28:24 T:2954915840 ERROR: Error Contents: (10, 'No child processes')
14:28:24 T:2954915840 ERROR: Traceback (most recent call last):
File "/Users/user/Library/Application Support/XBMC/addons/plugin.video.xmbcflicks/default.py", line 26, in <module>
import resources.lib.menu as menu
File "/Users/user/Library/Application Support/XBMC/addons/plugin.video.xmbcflicks/resources/lib/menu.py", line 674, in <module>
getInstantGenres()
File "/Users/user/Library/Application Support/XBMC/addons/plugin.video.xmbcflicks/resources/lib/iqueue.py", line 1543, in getInstantGenres
initApp()
File "/Users/user/Library/Application Support/XBMC/addons/plugin.video.xmbcflicks/resources/lib/iqueue.py", line 1357, in initApp
user = getAuth(netflixClient,VERBOSE_USER_LOG)
File "/Users/user/Library/Application Support/XBMC/addons/plugin.video.xmbcflicks/resources/lib/iqueue.py", line 71, in getAuth
webbrowser.open(url)
File "/Applications/XBMC.app/Contents/Frameworks/lib/python2.6/webbrowser.py", line 61, in open
if browser.open(url, new, autoraise):
File "/Applications/XBMC.app/Contents/Frameworks/lib/python2.6/webbrowser.py", line 599, in open
rc = osapipe.close()
IOError: (10, 'No child processes')
14:28:24 T:2902651584 ERROR: GetDirectory - Error getting plugin://plugin.video.xbmcflicks/?mode=10001
14:28:24 T:2902651584 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.xbmcflicks/?mode=10001) failed


I'm wondering about the line "OSX Setting is set to: False". Shouldn't this be true on OSX??

Thanks



RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - gui - 2012-03-26

(2012-03-25, 01:18)sourbob Wrote:
(2012-03-20, 19:41)PantsOnFire Wrote: Colour me noob but I can't see XbmcFlicks in the add-ons list anywhere to install it. (XBMC pre-11.0 compiled 23rd Nov 2011)
where should it be?

Same here.

lets try this way.....

please pretty please can you guys tell us were to download the XBMC Flicks ,please.
thanx


RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - PaulD72 - 2012-03-26

I was able to just install the 10.* version and it worked from the zip file.

This says it's the Eden branch 1.0.22 https://github.com/spudsdude/XBMC-Flicks (Upper left hand corner click the "zip" button).



RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - crimsonfury - 2012-03-26

"No Internet Connection" every time I try to play from xbmc flicks but Netflix from pc works great.... Why does it pop up with that message?


RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - TheMonkeyKing - 2012-03-26

The original developer has posted the addon outside of the main repository. See comment #656 for the exact location of his repository. The link is the zip file. Download it and go to Systems --> addons --> install from zip file.


(2012-03-26, 12:58)gui Wrote:
(2012-03-25, 01:18)sourbob Wrote:
(2012-03-20, 19:41)PantsOnFire Wrote: Colour me noob but I can't see XbmcFlicks in the add-ons list anywhere to install it. (XBMC pre-11.0 compiled 23rd Nov 2011)
where should it be?

Same here.

lets try this way.....

please pretty please can you guys tell us were to download the XBMC Flicks ,please.
thanx




RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - crimsonfury - 2012-03-26

I can play instant stream straight from IE just fine but from xbmcflicks it keeps saying "Internet connection error" after it loads to 7% every time. Why?


RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - ejkram - 2012-03-27

Same problem, however my OSX is set to "yes" in the add-on settings. But, when you do this, safari doesn't open asking you to link your account, it just does nothing. The only way I can get safari to open to link my account is to set the option OSX to "No". But then as described below you get script errors.

(2012-03-25, 20:52)kaktusjack Wrote: Hi,

I can't connect xbmc flicks with my netflix account.

- OSX Lion
- xbmc Eden
- xbmc flicks 1.0.22

While trying to access any watch instantly option the default browser (firefox or safari, same result) opens the netflix application linking page. Klicking Yes seems to be successful (but isn't). Within xbmc I'm getting the message "Error Script failed ..."

xbmc.log:

14:28:23 T:2954915840 NOTICE: USER INFO FILE LOC: /Users/user/Library/Application Support/XBMC/userdata/addon_data/plugin.video.xbmcflicks/userinfo.txt
14:28:23 T:2954915840 NOTICE: couldn't load user information from userinfo.txt file
14:28:23 T:2954915840 NOTICE: .. getAuth called ..
14:28:23 T:2954915840 NOTICE: OSX Setting is set to: False
14:28:23 T:2954915840 NOTICE: .. user configured ..
14:28:24 T:2954915840 NOTICE: Token did not contain any errors
14:28:24 T:2954915840 ERROR: Error Type: <type 'exceptions.IOError'>
14:28:24 T:2954915840 ERROR: Error Contents: (10, 'No child processes')
14:28:24 T:2954915840 ERROR: Traceback (most recent call last):
File "/Users/user/Library/Application Support/XBMC/addons/plugin.video.xmbcflicks/default.py", line 26, in <module>
import resources.lib.menu as menu
File "/Users/user/Library/Application Support/XBMC/addons/plugin.video.xmbcflicks/resources/lib/menu.py", line 674, in <module>
getInstantGenres()
File "/Users/user/Library/Application Support/XBMC/addons/plugin.video.xmbcflicks/resources/lib/iqueue.py", line 1543, in getInstantGenres
initApp()
File "/Users/user/Library/Application Support/XBMC/addons/plugin.video.xmbcflicks/resources/lib/iqueue.py", line 1357, in initApp
user = getAuth(netflixClient,VERBOSE_USER_LOG)
File "/Users/user/Library/Application Support/XBMC/addons/plugin.video.xmbcflicks/resources/lib/iqueue.py", line 71, in getAuth
webbrowser.open(url)
File "/Applications/XBMC.app/Contents/Frameworks/lib/python2.6/webbrowser.py", line 61, in open
if browser.open(url, new, autoraise):
File "/Applications/XBMC.app/Contents/Frameworks/lib/python2.6/webbrowser.py", line 599, in open
rc = osapipe.close()
IOError: (10, 'No child processes')
14:28:24 T:2902651584 ERROR: GetDirectory - Error getting plugin://plugin.video.xbmcflicks/?mode=10001
14:28:24 T:2902651584 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.xbmcflicks/?mode=10001) failed


I'm wondering about the line "OSX Setting is set to: False". Shouldn't this be true on OSX??

Thanks




RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - jw15851 - 2012-03-28

XBMCFlix seems to be dead. it's no longer in the standard repository, you have to hunt to find one of three (now 4 with the link above) places on the internet that happens to make a passing reference as to find it. Then you install it, (or in my case scrap the linux live version and shift to win7) and find that it is buggy as hell, and generally no longer works.

For me, most of the time playlists don't load, through sometimes after several retries and waiting 1-3 minutes they will occasionally load. Then you can try to play a movie/show. 1/2 the time, it fails, the other half, launches internet explorer where your remote control will no longer work and a whole different set of keys operate the netflix player experience. If you want to fix this, you need to selectively remap the keys using one of two other obscure pieces of software that you have to hunt down. Then exiting from the player (actually IE), is clunky. Once you exit, you are back to having to wait 1-3 minutes for a playlist to load (with most of the time, it failing to load) All in all, for me, it requires about 5-10 minutes of fighting with it, to play a single 1/2 hour episode of a show.

I'm sure there must be political/legal reasons why this can't just be built into the software, but this is really driving me crazy. Netflix is a large portion of our viewing experience, and without that functionality, it's really hard to justify building the media center PC (That I just built). I love the appearance, and customization of XBMC, but once I get it setup, I want it to just work and work reliably. I can't expect my wife and kids to have to jump through the hoops it will require to make Netflix, and XBMC play nice.

I can't understand why the developers don't just give up on trying to build in the player, and just make it launch a full screen IE window with the Netflix site already logged in. The XBMC site/silverlight keeps track of your movies, etc. Why even try to integrate it? When the IE window with Netflix is in front, it remaps the keys to work with the standard controls, when you are done, it closes the window returning you to the XBMC experience. If you have to use IE, just use it and quit trying to do some kind of hybrid thing.

The other part is the Linux thing. I guess there may be legal issues around obtaining the secrets to building it into linux with an open source project. But clearly, Netflix works with Linux (unless it's an x86 cpu thing) Boxee has a functional implementation of it (built on XBMC), Boxeebox (which runs on linux) works fine, Tivo has it (linux), or any one of almost all the BluRay players on the market (generally flavors of linux) all have it.

Regardless, I've come to the very disappointing and frustrating (if you can't tell) conclusion that I have to stay with my Boxee box, despite having just built a complete media center PC. Sure the Boxee box skin is butt-ugly compared to XBMC, but, it works. Youtube works, Hulu works, Netflix works, and streaming video from a NAS works (and the scraper works pretty well too). No configuring hidden xml files, no remapping keys or completely different control interface for Netflix. If the twits at Boxee would just allow some custom skins, it would absolutely dominate.

I really *really* wanted to use XBMC. I built a Mini-ITX PC, purchased a bluetooth keyboard/dongle, got the IR remote, Installed Linux (no bluetooth, No Netflix) then installed Win7 (apparently no functional Netflix) and spend 3 full evenings till the wee hours of the morning, trying to get some kind of reliable operation...the whole 9 yards. But without Netflix working reasonably well (about 60% of our viewing) and without it working reliably overall once I've taken the time to set it up (oops Hulu died again, oops the skin you spent hours configuring isn't compatible with the last update, oops Netflix is nowhere to be found (in any repository) and 30% functional when you do hunt it down, so it's pointless for our uses.

Damn.


RE: [RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC - falafael - 2012-03-28

I feel your pain mate, oddly enough, i have been tinkering this morning with the netflix addon due to the fact that lovefilm isn't going to allow itself on xbmc, so i thought i would try netfix, but no luck.
Sure xbmc is sweet, but sometimes there times when ya have to pee around with files just to get them to work (demand 5,4OD), and truth be told, some people do not have the knowledge to do that, hell this set up is used by all the family, but i have to do all the setting up, the wife hasn't a clue bout addon ons, repositorys etc.

So yes, at times, xbmc does need to be more 'frendlier' to the average 'user'
There are times when i have been annoyed at the stupidity and greed of certain companies not allowing there services on xbmc, as i do believe that this software can go a long way still, but maybe time will tell.