Kodi Community Forum
[LINUX] HOW-TO use VAAPI HW Acceleration on AMD Zacate (Fusion) platform - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (https://forum.kodi.tv/forumdisplay.php?fid=52)
+---- Thread: [LINUX] HOW-TO use VAAPI HW Acceleration on AMD Zacate (Fusion) platform (/showthread.php?tid=99154)

- WytRaven - 2011-06-22

On ASUS E35M1-I Deluxe that would be:
<cputempcommand>sensors|sed -ne "s/temp1: \+[-+]\([0-9]\+\).*/\1 C/p"</cputempcommand>

Well on my setup anyway (I say this as my sensors output is currently raw from lm-sensors install, no probing has been done). Basically replace that Core 1: part with whatever label you see at the start of the line when you type sensors in the terminal

The end result of the above command run in terminal should be that you see XX U. Where XX is the numeric representation of the temperature and the U is either C or F; the unit of temperature measurement. When xmbc runs it it will take the output and insert a degree symbol between the two when displaying.

- peterk2005 - 2011-06-22

WytRaven Wrote:I know by consulting my xbmc logs that my TV is capable of both true 24Hz and the 23.936Hz variant (which of course my TV will say are both 24Hz when switching so it's hard to tell which is being used) I wonder if this is where the issue is occurring.

I doubt it, because I created modelines for both, and setting the refresh rate explicitely to any of them won't make any difference, the problem is there. While mplayer plays these files perfectly no matter if the refresh rate is actually true 24Hz or 23.976. Well, perhaps not perfectly because 24 vs 23.976 could cause some minor stuttering like 60Hz does on 24P material. But this is nowhere near the terrible jumping-back-and-forth stuttering we see in XBMC. This is a different story and I believe is a bug. Just no-one seem to believe it /or be interested/ yet amongst those people who could fix it. Sad

- Rapoza - 2011-06-22

About the sensor capturing, I must say that in my installation, lm-sensors setup said that my mobo wasn't supported. And at the end had the same result that javum, ? on xbmc.

At the 24p, I can confirm that all the files that I can't play correctly are 23.976.
I know that the only modelines I added at xorg.config are for 60 and 59hz.
Could be that additional modelines for 25 and 23.976 had to be entered in config and letting xbmc change display freq accordingly?

I'll be making the test, but it will be interesting to someone else do it, in case I have some other problem.

Ah @WytRaven, the autostart is now worky, It would be interesting to take into account that if you do add the user to one group after the initial add command (the long one), it will add the user to that group, but also removes all other asignations. So I think its better to re-set at the end.

Also on the instructions provided for the init script, was missing the last line for reconfigure.

EDIT: Just do the following after the instructions provided by htpcero for autologin:
sudo dpkg-reconfigure x11-common
#Choose "Anyone" when asked.

Suspend-shutdown-restart from xbmc seems a bug thou.

- javum - 2011-06-22

<cputempcommand>sensors|sed -ne "s/temp1: \+[-+]\([0-9]\+\).*/\1 C/p"</cputempcommand>

Shutdown, reboot problem was solved here and here

- devil103 - 2011-06-23

I'm also experiencing some bugs I think...
I'm getting the segmentation crash at times, I know I've read about it here somwhere and will go look for it now.

Seconly, I'm using the simplicity skin with all addons and it is working perfectly, however sometimes when starting XBMC it stops at the main screen. It freezes and doesn't show any animation and controls are not responsive.

However when tailing the log I can still see calls to the webpage when they are made. The last lines in the log are:


Any thoughts?

- DioEraclea - 2011-06-23


the strange thing with the 24p problem is, that it also happens with 50FPS content.

I live in europe and I am using tvheadend with xbmc and if I watch HD TV (720p50) using VAAPI using a refresh rate of 50Hz I have the same problem as watching 24p content with 1080p24. Watching 720p50 using 60Hz works (but isn't smooth...).

I noticed that the Video is played smooth for the duration of a few seconds (3-4?) but this changes after the picture becomes black for the duration of a frame (at least I think it's one frame). Afterwards the problem with the 'jumping' Frames start.

- RudolfR - 2011-06-24

Great thread.

I think I managed to get VAAPI up and running on my FoxConn nt-a3500.
XBMC doesn't crash and CPU use is reasonable.
When I get home I'll be able to see what it looks like, can't wait.

Thanks for the great guide WytRaven.

How to stop GDM from running Unity but XBMC instead - devil103 - 2011-06-24

So, now that everything is working over here I'm wondering how to make XBMC autostart instead of GDM / Unity.

Especially since this is an alternate desktop install and not a Ubuntu minimal installation. My knowledge on X is a little rusty and the usual locations of X seem to have changed since I last dabbled with it.

I guess just changing the login session under Unity GUI won't work? Especially since we don't seem to need xbmc --standalone.

I tried installing the scripts mentioned a few pages back and they appear to be working but I'm still default entering the Unity desktop.

I'm guessing here that I'll have to manually define an X session script to run as my xbmc user?

Thanks for any help

So i've found the XBMC.desktop file in /usr/share/xsessions and when running this sessions without --standalone and with --standalone I get the dreaded crash on vaapi playback. Any reason for this? I'm sure my user is added to the video and audio group...

export - devil103 - 2011-06-26

Unfortunatly I have to run these command every time I reboot or else I get the segmentation fault. Any way to make these command stick?

export LIBVA_DRIVERS_PATH=/usr/lib/va/drivers

- WytRaven - 2011-06-26

Rapoza Wrote:if you do add the user to one group after the initial add command (the long one), it will add the user to that group, but also removes all other asignations. So I think its better to re-set at the end.

Consider the user bob. bob is going to start off in the following groups:

If you want to just add a user to another group (leaving their current groups intact) then use adduser

adduser bob coolgroup

Now bob is in the following groups:

If you want to define a users complete group list (current groups are replaced with those specified) then use usermod

usermod --group coolgroup,hotgroup bob

bob is now only in coolgroup and hotgroup.

- WytRaven - 2011-06-26

devil103 Wrote:Unfortunatly I have to run these command every time I reboot or else I get the segmentation fault. Any way to make these command stick?

export LIBVA_DRIVERS_PATH=/usr/lib/va/drivers

Append those lines to /etc/environment

- RudolfR - 2011-06-26

What's the best way to autostart XBMC on Ubuntu Minimal?
I'd like to use 'xbmc-live', cause it autostarts on crash, but I can't get it too work with VAAPI. Any recommends?

- SDM2011 - 2011-06-27

Fixed the shutdown/suspend issues: the key is to use ck-launch-session on the login shell, not in any subshells. So you have to change slim.conf to modify the launch command to start the login shell via ck-launch-session.

Anotherone getting it run - Jan0sh - 2011-06-27

Hi @ all!
Just wanted to report my sucessfull installation on ASUS E35M1-I Deluxe.
Vaapi keeps CPU load at avg. 20-25% on VC-1 HD mkvs.

wytravens log of install did the trick and worked for me.

Now i have just a few question to other E35M1 users. What is your avg. powerconsumption while playing movies and idle? I won't get under 37 W with 2 x 120 System Fans and 2x2 TB WD Caviar green. Typical consumption is about 42 - 47 W. The PSU is 80+ 350W ( MS-Tech Vertigo V-GO 350W ATX 2.3)
I have read about powerconsumption @ windows about 20 W.
Are there any missing chipset drivers ? Can't be that idle consumtion is only 5 W less than watchig movies?!
Also I could not find any option @ EFI to turn off wlan and bluetooth.

Any tips how to reduce powerconsumption on natty?

Thx so far! Nerd

- Genibox - 2011-06-27


I'm trying to do a minimal install of 11.04 however the command line install takes forever on "installing base system" this is due to a very slow broadband connection, is it possible that someone could maybe tell me approx how big the installation is? Anyone kind enough to upload their finished image so I could maybe download this from work? (I have tried the nemek build but the installer just loops endlessly)

Also how do I go about compiling this in Virtualbox on windows then make an iso of it for future use? I read the OP's advice on this with unetbootin but i'm unsure about how I should do this?

Thank you