•   
  • 1
  • 11
  • 12
  • 13
  • 14(current)
  • 15
  •   
[RELEASE] X10 - lights (Domotica Commander)
Hi,
Seems like a great add-on, however I cannot get it to work with LightwaveRF.
Has anyone managed to get it working?
Reply
Hi guys! I am trying to install the X10 Server on my win7 PC which also runs Switch King. However, despite that I run this server application as "Administrator" I'm facing the error message "Socket Error #10013 - Access Denied". I've read something about that it is caused by insufficent rights (should be solved by running it as an Administrator) or a conflict on port 6063. What do you think?
I will appreciate any support. Thanks
Reply
Okay, I think I am going to need some support from a kind soul. I will try to set this up with Switch King.
I have installed the XBMC addon, so far so good. I also configured it with the basic information:

Application IP-adress: 192.169.1.69 (this is the adress to my server which runs Switch King)
Application Port: 8800 (should be fine, works with android app)
Application Security: Yes, and then username and password for the Switch King server
Device Application: Switch King
Application Debugging: Yes

That is how the Host Settings is set, should be pretty straight forward (this cannot be done in so many ways)

Device 01 (the only device):
Device Active: Yes
Device ID 01: 6 (this is the Switch King ID of the switch)
Player Start Event: Yes
Free Definable Action: No
Action: Off

Is this a correct setup?
Do I also need the X10 Commander server on the server that runs Switch King? I assume that I don't, since Switch King can receive commands by URLs (for instance (http:192.169.1.69:8800/devices/6/turnoff).

I would be so incredible happy if someone could try to help/guide me with this.

Thanks in advance!
Reply
I collected this information from the Kodi.log:
21:10:24 T:139731367085824 NOTICE: X10-Lights: *************** Handeling an Event **************
21:10:24 T:139731367085824 NOTICE: X10-Lights: Event Type = P_Start
21:10:24 T:139731367085824 NOTICE: X10-Lights: Switch King, Switch lights or Device OFF
21:10:24 T:139731367085824 NOTICE: X10-Lights: Switch King, URL: http://username:[email protected]:88...06/turnoff
and some other info from the video player, and then
21:10:25 T:139731367085824 NOTICE: X10-Lights: Switch King, The OFF Event Failed
21:10:25 T:139731367085824 NOTICE: X10-Lights: Event Device ID = 06
21:10:25 T:139731367085824 NOTICE: X10-Lights: Event Action = OFF
21:10:25 T:139731367085824 NOTICE: X10-Lights: Event Value = 50
21:10:25 T:139731367085824 NOTICE: X10-Lights: Event Free CMD = False
21:10:25 T:139731367085824 NOTICE: X10-Lights: Event ROOM = 0
21:10:25 T:139731367085824 NOTICE: X10-Lights: *************************************************

For some reason this fails, despite tha fact that if I paste this into a browser (http://username:[email protected]:88...06/turnoff), the lights actually turns off. I am a bit puzzled, so close but in another way very far away Is this a type of access issue for XBMC, that XBMC don't have the access needed to send these commands?

Anyway, I hope this last piece of information can help you guys to help me!

BR
Henke
Reply
Since I switched from XBMC to Kodi, the lights don`t respond to the 'stop' command/button anymore.
Everything else works like A charm, pause, play etc.
I didn`t change anything to the (X10 commander) settings...
Is there anything I can do?

Some help and/or advise would be highly appreciated!

Thanks in advance!

regards,
Luuk
Reply
Another thought on this:
21:10:25 T:139731367085824 NOTICE: X10-Lights: Switch King, The OFF Event Failed
21:10:25 T:139731367085824 NOTICE: X10-Lights: Event Device ID = 06
21:10:25 T:139731367085824 NOTICE: X10-Lights: Event Action = OFF
21:10:25 T:139731367085824 NOTICE: X10-Lights: Event Value = 50
21:10:25 T:139731367085824 NOTICE: X10-Lights: Event Free CMD = False
21:10:25 T:139731367085824 NOTICE: X10-Lights: Event ROOM = 0
21:10:25 T:139731367085824 NOTICE: X10-Lights: *************************************************

Why does it say Event Value = 50? Is it dim level? Because the switches I use are not dimable, they're on/off. But I didn't choose a dim level, I chose on/off. Might this be the problem?
Reply
Hi,

Does anybody have a trick to let this work only after sunset? i know it is at the "wishlist" but maybe anybody has a "dirty trick" or something



Kind Regards
Reply
cool have been away for some time... see that i've been mentioned in the manual!
thnx for that!
Reply
Is it possible to connect my x10 interface directly in my raspberry with x10 commander server running, so i wont need tu keep my pc running ?
Reply
I can't get it to work.

I have a Domoticz server (raspberry pi)
I entered the IP address
Port 8080

Device 1
Have set ID 16 ( the device ID in Domoticz )
Set on play start turn off
on play stop turn on

But nothing happen. Nothing in the Domoticz logs



I have set to no password needed on local subnet ( same as my openelec is connected )
Reply
Hi All,
Ok i,m struggling to get the domotica commander working with the domoticz server, i have a rfxtrx433 plugged into domoticz and setup with lightwaverf witch i can control with an iphone. so my next part is to get kodi to control the lights when playing a movie.
Ive installed the x10 lights service on my raspberry pi 2 running osmc.

I've so far setup the configuration as follows
Host settings: Application port is the same ip as the domoticz server
Port is 8080 the same port i used to setup the iphone app
security is turned off
Device application is set to lightwaverf, i,ve also tried this setting on domoticz as well.

Device 01: this is where im struggling i think
Device active is on
Device id where do i find this?
Room Active is on
Room for device id where do i find this?
Plyer start event is enabled
free definable action is off
Action id dim
percent is 50


i have set up a manual light switch in domoticz also with settings for lightwvaerf id E1 01 01 unit 01 and the switch controls the wall lights ok
I have also set no password

please let me know if you need any more information,
I,ve also checked the log in domoticz and it does'nt appear to show any events for kodi asking to use the lights

Many Thanks
Reply
Thanks for this addon Smile Just what I was looking for.

I haven't gotten it installed yet, so this might be obvious - but is it possible for the addon to differentiate between tv-shows and movies? I ask because I would like for the dimming and/or turning off and on of lights to only be active for when I'm watching Movies, not when I'm watching my tv-shows.
Reply
(2015-01-07, 10:34)hoodrat Wrote: Hi,
Seems like a great add-on, however I cannot get it to work with LightwaveRF.
Has anyone managed to get it working?

For LightwaveRF, I have created the interfacing.
I tested it with the (test) applications from Lightwave I have recieved when developing.
It worked on that.
However the tester for which I made it eventualy did not buy LightwaveRF.
So it is never tested on real device's.

Maybe you ar able to post some log files and I can analyze them.
(See manual, chapter 8 debugging on how to create log files)
Reply
(2015-03-02, 21:05)Varazir Wrote: I can't get it to work.

I have a Domoticz server (raspberry pi)
I entered the IP address
Port 8080

Device 1
Have set ID 16 ( the device ID in Domoticz )
Set on play start turn off
on play stop turn on

But nothing happen. Nothing in the Domoticz logs



I have set to no password needed on local subnet ( same as my openelec is connected )

Have you checked chapter 6. know Issue's, issue number 3 on page 15 of the manual?
maybe this helps
Reply
(2015-04-11, 15:16)pavo325 Wrote: Hi All,
Ok i,m struggling to get the domotica commander working with the domoticz server, i have a rfxtrx433 plugged into domoticz and setup with lightwaverf witch i can control with an iphone. so my next part is to get kodi to control the lights when playing a movie.
Ive installed the x10 lights service on my raspberry pi 2 running osmc.

I've so far setup the configuration as follows
Host settings: Application port is the same ip as the domoticz server
Port is 8080 the same port i used to setup the iphone app
security is turned off
Device application is set to lightwaverf, i,ve also tried this setting on domoticz as well.

Device 01: this is where im struggling i think
Device active is on
Device id where do i find this?
Room Active is on
Room for device id where do i find this?
Plyer start event is enabled
free definable action is off
Action id dim
percent is 50


i have set up a manual light switch in domoticz also with settings for lightwvaerf id E1 01 01 unit 01 and the switch controls the wall lights ok
I have also set no password

please let me know if you need any more information,
I,ve also checked the log in domoticz and it does'nt appear to show any events for kodi asking to use the lights

Many Thanks

You should set Device application to Domoticz
As device id use the idx number form domoticz of the device you want to control.
Also for you check out chapter 6. know Issue's, issue number 3 on page 15 of the manual
(Check out the manual any way, setting stuff up with domoticz is explained)
Reply
  •   
  • 1
  • 11
  • 12
  • 13
  • 14(current)
  • 15
  •   
 
Thread Rating:
  • 4 Vote(s) - 4.75 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] X10 - lights (Domotica Commander)4.754