•   
  • 1
  • 21
  • 22
  • 23(current)
  • 24
  • 25
  • 208
  •   
  Thread Closed
Artwork Downloader
PatK Wrote:View download report from the latest download run: produces change log text. V1.0.6 Eden B2 T! 4.0.5

lol yeah that was a bug in T! Big Grin
ronie already fixed it in his svn repo some time ago.

Just tried and works fine for me.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Star 
Martijn Wrote:lol yeah that was a bug in T! Big Grin
ronie already fixed it in his svn repo some time ago.

Just tried and works fine for me.
Just updated... working fine.
Limiting artwork by rating doesn't seem to be working. I've been watching for about a week now and artwork that is rated below five starts (my current thresh hold) is still being downloaded. Even if I clear my artwork and let it redownload everything. I have even tried installing XBMC with Artwork Downloader on another mac just to make sure it wasn't something being cashed that was messing things up. Here are a couple of examples of artwork that are downloading that shouldn't be with the default setting...

From Fightclub on themoviedb.org
http://cf2.imgobject.com/t/p/original/1p...AldS8e.jpg

From So You Think You Can Dance on thetvdb.com/
http://thetvdb.com/banners/fanart/original/78956-14.jpg
brendon2424 Wrote:Limiting artwork by rating doesn't seem to be working. I've been watching for about a week now and artwork that is rated below five starts (my current thresh hold) is still being downloaded. Even if I clear my artwork and let it redownload everything. I have even tried installing XBMC with Artwork Downloader on another mac just to make sure it wasn't something being cashed that was messing things up. Here are a couple of examples of artwork that are downloading that shouldn't be with the default setting...

From Fightclub on themoviedb.org
http://cf2.imgobject.com/t/p/original/1p...AldS8e.jpg
Uhm slight typo in code Shocked
Will be fixed in next update. Instead of the average it uses the number of votes.
Thanks for noticing Smile

Quote:From So You Think You Can Dance on thetvdb.com/
http://thetvdb.com/banners/fanart/original/78956-14.jpg
This the date from TVDBD and as you can see this image has no rating in his API respons.
PHP Code:
<Banner><id>514361</id>
<
BannerPath>fanart/original/78956-14.jpg</BannerPath>
<
BannerType>fanart</BannerType><BannerType2>1280x720</BannerType2>
<
Colors/><Language>en</Language>
<
Rating/>
<
RatingCount>0</RatingCount>
<
SeriesName>false</SeriesName>
<
ThumbnailPath>_cache/fanart/original/78956-14.jpg</ThumbnailPath>
<
VignettePath>fanart/vignette/78956-14.jpg</VignettePath>
</
Banner

I know it takes more than three days for ratings and info to get through for TMDB. Don 't know how long it takes for TVDB.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Martijn Wrote:Uhm slight typo in code Shocked
Will be fixed in next update. Instead of the average it uses the number of votes.
Thanks for noticing Smile


This the date from TVDBD and as you can see this image has no rating in his API respons.
PHP Code:
<Banner><id>514361</id>
<
BannerPath>fanart/original/78956-14.jpg</BannerPath>
<
BannerType>fanart</BannerType><BannerType2>1280x720</BannerType2>
<
Colors/><Language>en</Language>
<
Rating/>
<
RatingCount>0</RatingCount>
<
SeriesName>false</SeriesName>
<
ThumbnailPath>_cache/fanart/original/78956-14.jpg</ThumbnailPath>
<
VignettePath>fanart/vignette/78956-14.jpg</VignettePath>
</
Banner

I know it takes more than three days for ratings and info to get through for TMDB. Don 't know how long it takes for TVDB.

Glad I could help! Thanks for looking into it so quickly. I am noticing in the example you have above that thetvdb.com API return is giving a "0" return for RatingCount and "" for Rating. It doesn't seem that artwork should have been downloaded even with the average being used instead of the number of votes. Does there need to be a check for 0 and nil so that unrated fanart isn't downloaded? This may already be fixed. Now that AD is checking the API for Rating return, getting a false return may properly exclude the fanart, whereas the RatingCount returning a 0 is what was throwing things off.

I also have a question about the "Exclude fanart that has text" option. I love the idea of it, and I had assumed I would be able to go to the themoviedb.org and toggle an indicator so that Artwork Downloader could pull that detail from the API. That doesn't seem to be an option though. I know I'm getting plenty of artwork that has text in the jpeg. Is that option actually doing anything or am I misunderstanding its objective?
When it has 0 votes we do download it. If we chose to ignore it a lot would not download. This way we force the users to take actively part in the process of getting images rated.

The exclude text option isn't available on TMDB. They just started the support for ratings last week in their API. The language wasn't only has been available since a month. So maybe one day it may be posible. However that would mean all fanart has to be tagged with text/no text.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Martijn Wrote:When it has 0 votes we do download it. If we chose to ignore it a lot would not download. This way we force the users to take actively part in the process of getting images rated.

Ah, I see. Sounds good to me. Big Grin

Martijn Wrote:The exclude text option isn't available on TMDB. They just started the support for ratings last week in their API. The language wasn't only has been available since a month. So maybe one day it may be posible. However that would mean all fanart has to be tagged with text/no text.

Do any sites support the exclude text option right now, or is this just a way to get people thinking about what is possible?
brendon2424 Wrote:Ah, I see. Sounds good to me. Big Grin

Do any sites support the exclude text option right now, or is this just a way to get people thinking about what is possible?

TVDB does.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
When I upgraded to Eden B2 I started using the media stub (i.e. movie.dvd.disc) to get my physical movie collection into XBMC. I noticed that unless I have a movie.nfo file for a movie, no extra art is downloaded. Is that perhaps because it's looking at the file name minus the extension and seeing movie.dvd (i.e. A Bug's Life.dvd.disc is seen as A Bug's Life.dvd which isn't a movie it can find).

I can go ahead and add movie.nfo files that just have the URL for the moviedb listing if I have to, but I wanted to see if I was missing something obvious before I start down that road.

Thanks.
Providing a debug log: Log_file/Easy (wiki)
Leia Estuary mod: 333143 (thread)
Artist Slideshow: Add-on:Artist_Slideshow (wiki)
SpeedFan Information Display: Add-on:SpeedFan_Information_Display (wiki)
pkscuot Wrote:When I upgraded to Eden B2 I started using the media stub (i.e. movie.dvd.disc) to get my physical movie collection into XBMC. I noticed that unless I have a movie.nfo file for a movie, no extra art is downloaded. Is that perhaps because it's looking at the file name minus the extension and seeing movie.dvd (i.e. A Bug's Life.dvd.disc is seen as A Bug's Life.dvd which isn't a movie it can find).

I can go ahead and add movie.nfo files that just have the URL for the moviedb listing if I have to, but I wanted to see if I was missing something obvious before I start down that road.

Thanks.
It doesn't look for files themselves. I only retrieves what's in the XBMC library.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Martijn Wrote:You should be asking in the general section for xbmc questions, not here. It only downloads artwork for movie movies that are in your library. It doesn't look foor files.

Sorry I wasn't clear. These are movies that are in my library, but the only ones that get downloaded are the ones that have a movie.nfo file in the directory structure.
Providing a debug log: Log_file/Easy (wiki)
Leia Estuary mod: 333143 (thread)
Artist Slideshow: Add-on:Artist_Slideshow (wiki)
SpeedFan Information Display: Add-on:SpeedFan_Information_Display (wiki)
pkscuot Wrote:Sorry I wasn't clear. These are movies that are in my library, but the only ones that get downloaded are the ones that have a movie.nfo file in the directory structure.

Stil the same answer Rolleyes
Then they are probably not stored correctly in XBMC library or in a different way. I suspect it's trying to download it to the discs themselves because you use mediastubs that point to an optical disc

Could you make a full debug log when trying to download extrafanart for one of those movies and post it using pastebin.com?
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Martijn Wrote:Stil the same answer Rolleyes
Then they are probably not stored correctly in XBMC library or in a different way. I suspect it's trying to download it to the discs themselves because you use mediastubs that point to an optical disc

Could you make a full debug log when trying to download extrafanart for one of those movies and post it using pastebin.com?

I removed the movie source from my library and deleted artwork downloader. Then I added the source back, rescanned to add the movies, and then downloaded and ran artwork downloader again. Now it's working fine. Go figure. Thanks for the pointers.
Providing a debug log: Log_file/Easy (wiki)
Leia Estuary mod: 333143 (thread)
Artist Slideshow: Add-on:Artist_Slideshow (wiki)
SpeedFan Information Display: Add-on:SpeedFan_Information_Display (wiki)
Hi all..

First of all i just want to say a great addon and work fine on 485/488 downloads Smile.

i have read all post in the thread and been looking around on otherplaces on the forum and on the web about the problem.

I downloaded the right clearart image on a show but it will not show the image i download, it shows a difrent image from the downloader. the image in the tvshow folder is the correct image i downloaded. that problem i have on 2 tv-shows. stargate atlantis and stargate sg-1.

and then i have the same problem but with a logo download, right image downloaded, and right image in the folder but xbmc show the worng image.
but this time the walking dead tvshow.

/Spikey
Spikey1989 Wrote:Hi all..

First of all i just want to say a great addon and work fine on 485/488 downloads Smile.

i have read all post in the thread and been looking around on otherplaces on the forum and on the web about the problem.
..........

/Spikey

Just wait 24 hours and the new image will show Smile
This is how long it takes for XBMC to refresh it's cache
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
  •   
  • 1
  • 21
  • 22
  • 23(current)
  • 24
  • 25
  • 208
  •   
  Thread Closed
 
Thread Rating:
  • 18 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
Artwork Downloader4.4418
This forum uses Lukasz Tkacz MyBB addons.