•   
  • 1
  • 128
  • 129
  • 130(current)
  • 131
  • 132
  • 208
  •   
  Thread Closed
Artwork Downloader
(2014-05-04, 14:38)Martijn Wrote: This will change for my Gotham release. It's already implemented but not tested.
So it will ask if it should rename all current files and update database accordingly and from then on only download in the "xbmc format".
It should also skip online searching better.

Since i'll be going to LinuxTag i won't have time for early release.

Sounds very good, thank you!
I seem to have a problem with artwork downloader. It seems it will only scrape and download artwork that has language tagged english, but ignores the tv shows that only have artwork in japanese/etc but not english,

Example:
TV Show: Tokyo Magnitude 8.0
clearart: Japanese
logo: Japanese

Is there way for the addon to automatically download whatever is availiable, even if it is does not have the viewer's preferred language? I'd rather have the addon grab something rather than nothing.
(2014-05-04, 14:38)Martijn Wrote: This will change for my Gotham release. It's already implemented but not tested.
So it will ask if it should rename all current files and update database accordingly and from then on only download in the "xbmc format".
It should also skip online searching better.

Since i'll be going to LinuxTag i won't have time for early release.

Will your Gotham release do anything to automatically add all this extra artwork that is already in the appropriate folders with the correct names?
I have 2 questions:

1) Similar to another recent poster.... I have read and reread the wiki, read the first 10 and last several threads here, but can't find my answer. In Limit Artwork, what does the Minimum rating do?

2) Excellent product that you made for us, Martijn! Do you have a way to send you a donation? That Buy You A Beer thing looks like it is turned off, and not really how I want to donate.
OK What's going on now? Upgraded to Gotham Full Release. Now there is no option to add any additional artwork from the main Art button and if I scroll down to Get Artwork all the local artwork I spent hours accumulating, editing and naming isn't recognized. And yes, use local folders is checked off. This all worked fine in RC1. What's going on? Sad

Figured out how to get extra local art for my TV Shows. Well ok I didn't figure it out I just tried different things then suddenly the options were there. Still nothing for movies though. Going to go bang my head against the wall now.
Clearart/logo issue when tv-shows spread over multiple folders

I tried to use as few words as possible and structure it so nobody should have any issues understanding the issue. I would appreciate any workarounds / explanations / solutions. I would not even mind adjusting the python code or using some SQL.

Set-up
  • Ubuntu 14.04 (fully updated)
  • XBMC Gotham 13.0 git:d420b5c may 6 2014 (official PPA)
  • Aeon MQ5 2.0.2 2/7/2014 (official repo)

Situation

Seasons of tv-show spread over different directories:
Code:
/media/disk-alpha/TV.DVD/South Park/
--South.Park.S01/
--South.Park.S02/
-- (...)
--South.Park.S10/

/media/disk-beta/TV.BluRay/South Park/
--South.Park.S11/
--South.Park.S12/
-- (...)
--South.Park.S16/


Action
  • Enable Use Local Files in Artwork Downloader settings
  • Run Artwork Downloader

Result

Artwork Downloader only downloads files into one of the directories:

Code:
/media/disk-alpha/TV.DVD/South Park/
--extrafanart/
--South.Park.S01/
--South.Park.S02/
-- (...)
--South.Park.S10/
--landscape.jpg
--banner.jpg
--poster.jpg
--character.png
--fanart.jpg
--logo.png
--clearart.png

/media/disk-beta/TV.BluRay/South Park/
--South.Park.S11/
--South.Park.S12/
-- (...)
--South.Park.S16/

Main menu > TV-Shows:
  • Clearlogos are shown on the top left
  • Extrafanart is shown

Main menu > TV-Shows > South-Park:
  • This display does not feature clearart
  • Extrafanart is shown for seasons 1-10
  • Black background for seasons 11-16

Main menu > TV-Shows > South-Park > Season XX:
  • Clearart is shown for seasons 1-10
  • No clearart shown for seasons 11-16!

Trouble-Shooting
  • [Solved] Show extrafanart for seasons 11-16:
    Code:
    cp -R /media/disk-alpha/TV.DVD/South Park/extrafanart /media/disk-beta/TV.BluRay/South Park/
  • Copying logo.png and clearart.png has no effect!
  • Tried to delete Textures.db to recache with no luck
  • Tried to run Artwork Downloader again with no luck
  • Tried to remove South Park from library and add it back with no luck
Since upgrading to Gotham 13.0 Full Release I've had issues getting my extra artwork from AD to work. I spent days accumulating logos and such for nearly 1400 movies and 50 TV Shows. None of that art, stored locally, was found by AD after a fresh Gotham install. To get it to work I had to do the following.

All my extra artwork is named like the following example,

D:\Blu-ray Movies\Bad Boys Bluray (1995)\Bad Boys Bluray.mkv
D:\Blu-ray Movies\Bad Boys Bluray (1995)\Bad Boys Bluray.nfo
D:\Blu-ray Movies\Bad Boys Bluray (1995)\Bad Boys Bluray-clearart.png
D:\Blu-ray Movies\Bad Boys Bluray (1995)\Bad Boys Bluray-clearlogo.png
D:\Blu-ray Movies\Bad Boys Bluray (1995)\Bad Boys Bluray-discart.png
D:\Blu-ray Movies\Bad Boys Bluray (1995)\Bad Boys Bluray-fanart.jpg
D:\Blu-ray Movies\Bad Boys Bluray (1995)\Bad Boys Bluray-poster.jpg

I created copies of the extra art for Bad Boys and named them logo.png, disc.png and clearart.png, used the 'Get Artwork' button for AD to search both locally and the web and it found the local files. Once added I went back to just 'Choose Art' and the options for Clearart, Clearlogo and Discart appeared. Selecting them found the locally saved art with movie name and added it easily. Tried another movie and all the options are there and easily finds the art. Strange way that had to force itself to work but it's now "fixed".

For TV Shows I had to force it the same way, use 'Get Artwork' on the first show to find the logo and clearart locally and install. Then the next show worked simply from the 'Choose Art' button.

If only all this art could be automatically added though. Dare to dream I guess.


And now I've discovered that having all the art simply named can automatically be scraped in one fell swoop. Is it not possible to have the same thing occur if the art is named MOVIETITLE-clearart.png?
I've been doing some reading and found some very confusing things. First, I now believe I understand how AD works. It can and will look in local folders (provided Use Local Folders is enabled) to find locally stored artwork BUT only if named with a simple syntax (logo.png, disc.png and clearart.png for the artwork I am wanting to have). Now this will be scanned in ONLY if I run AD after importing my library or updating it to add any new movies.

Now when I export my library with fanart, XBMC may or may not also export the artwork AD added but will name it as FILENAME-logo.png etc, the same as it names posters and fanart. AD cannot automatically scrape/load/add local artwork that is named with the XBMC syntax. However, once extra fanart has been established for 1 movie XBMC will present easy options to add this artwork without needing to use AD if the artwork is named with the XBMC syntax.

So now my library of 1400 movies, each with clear logo, clear art and disc art files all named with XBMC syntax stored locally, to be added I need to manually add each piece of art to every movie OR rename every piece of art to the AD simple syntax and run AD to automatically add the art? Is my understanding correct?

For future additions to my library I would need to use the simple syntax naming, update my library and then run AD to automatically add the artwork, or use the XBMC syntax, update my library and the manually add the extra artwork myself?

Is there code I can change myself within AD to have it look for the XBMC syntax and not the simple syntax? I'd gladly do that to make my life easier. Or can this option not be added to the program itself? To use XBMC local file naming or AD local file naming?

It almost seems as though I should create duplicates of all this artwork for each movie using both naming syntax because XBMC will always try and export the artwork using it's naming but if something ever happens to my library again I would still need the AD syntax to be able to simply re-add all this art. Makes it even more difficult when I have to do this on my friend's library which is almost 1100 movies.
You've got it right. However if you want to automate the import of your artwork as it is currently named you do have the option of the script in my sig (plus mklocal.py) which I think I've mentioned to you before so I'm not going to belabor this point.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-05-11, 07:20)MilhouseVH Wrote: You've got it right. However if you want to automate the import of your artwork as it is currently named you do have the option of the script in my sig (plus mklocal.py) which I think I've mentioned to you before so I'm not going to belabor this point.

I'm not sure I fully understand what your script does but I have looked at it. Sometimes I spent too many hours staring at the computer and things just stop making sense. I've already renamed all my artwork (took about an hour and a half) and I'm running AD now. Hoping this works.

AD Seems to have updated all the artwork now. Upon exporting my library it did create a few more files with the filename, mostly discarts. I still have all the files with the filename in them so I'm just going to copy them back into the folders and have duplicates incase anything else ever goes wrong. I'm covered both ways. This has been exhausting. And now to do it all over again at my friend's house. Yippy!
Hello and thanks for this hard work.

I have an ASCII error launching artwork downloader. Here is the log file:
http://pastebin.com/nCTYTCmC

I use xbmc 13.0 in linux mint 16, both in spanish language.

Please, help. I see solutions for others addons using Python but i don't how use it. I'm not a programmer...
Encountering an issue and I'm not sure if it's Gotham related, skin related or possibly AD related because I have 'Use Local Folders' checked. I have movies on 2 seperate HTPCs. One is the main and has 98% of all my media. The other only has, to this point, 23 movies on it. Because of that I don'thave the HTPC running constantly. Now in my library when I scroll to those movies on the second HTPC the artwork doesn't show up. Is this because it's looking for the art directly from that HTPC and not from a local library folder? It never did this before I did a fresh install of Gotham 3.0 with Aeon Nox 4.1.9.9.
I'm curious if there's an easy way to "clean" central directories. I've removed a couple of TV shows that I don't watch anymore, but the fanart is still in that directory.
Limit rating is working correctly?

Example: I set the rating limit to 5

The add on finds fanarts with rating that goes from 1 to 6 and some without rating.
I am expecting that the fanarts without rating are not being downloaded.

What i found is that it download them and the result is that they are not good as the rated ones.

Can anyone confirm this bug or there is something wrong in my setup?
A suggestion: an option to make AD prioritize the current default TMDB poster image for a movie in specified language or then in English if not found.
  •   
  • 1
  • 128
  • 129
  • 130(current)
  • 131
  • 132
  • 208
  •   
  Thread Closed
 
Thread Rating:
  • 18 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
Artwork Downloader4.4418
This forum uses Lukasz Tkacz MyBB addons.